1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Dual Boot Vista and Ubuntu 9.10: No Internet Connection in Ubuntu

By ATTENTIVE ยท 10 replies
Feb 2, 2010
  1. Acer Desktop PC Model: AM1610
    sis ethernet adapter
    webstar dpx 2000 series cable modem

    After setting up a dual boot system successfully,
    Vista connects to internet via ethernet, Ubuntu does not.

    sis ethernet driver is updated to latest version

    I can access the internet from Ubuntu however, after shutting down the pc, unplugging the power cord, removing the cmos battery and reinstalling. I reinsert the power cord and boot up as normal into Ubuntu, and have full access to internet.

    Simply removing/reinserting ethernet cord, removing/reinserting pc or cable modem power cord, or resetting cable modem, does not work.

    I am asking if there is a solution as to where I can log off Vista and restart pc into Ubuntu and have internet access automatically, bypassing all these steps I've explained?

    After perusing multiple forums where people have described similar if not same issues, I've yet to find a solution to this.

    I ran ipconfig in Vista and have the results. I ran ifconfig in Ubuntu 9.10 and have the results.

    As these results may contain information that can present a vulnerability regarding system/ip identification, I have omitted them here.

    If needed, I will respond via personal message with the contents.

    Thank you in advance for your continued contributions in aiding the computer world "handicapped".
  2. Mugsy

    Mugsy TS Evangelist Posts: 529   +56

    Ubu 9.10 has known issues

    If you are using Ubuntu 9.10, it has known issues with the built-in Network Manager and DSL modems (and presumably Cable modems as well)..

    Currently, there is no fix (short of going back to 8.10 or hoping it is fixed in Ubu10 due out in April (iirc). Sorry.

    ATTENTIVE TS Rookie Topic Starter

    Thanks Mugsy for the reply. I felt it may be related to some coding in the new linux kernel. I am hoping with the release of Ubuntu 10 this is resolved. I am enamored with Linux.
  4. Mugsy

    Mugsy TS Evangelist Posts: 529   +56

    Maybe KDE?

    I'm not 100% certain, but the problem maybe related to the Gnome desktop specifically.

    If you are willing to try again, try using KDE Desktop/gui instead of the default Gnome desktop with Ubu 9.10.

    ATTENTIVE TS Rookie Topic Starter

    Versions (X)(Y)(Ultimate Edition)(SuperOS)(Ubuntu)

    I used these versions live and have yet to be able to connect. I don't quite know whether it's the linux kernel, or Windows holding the connection hostage even after shutdown. It seemed to me I should have at least been able to connect on one of these systems, especially after backing down to 9.04 from 9.10.
  6. Mugsy

    Mugsy TS Evangelist Posts: 529   +56

    Forget 9

    My personal experience has been nothing but trouble trying to connect to the Net "the proper way" using Ubu 9.

    I have the 9.10 Live CD on a 1GB Flash stick and simply connect each time *manually* by running "pppoeconf" from the Terminal. Annoying, but it works.

    I even run Wine this way so I can safely run simple Windows apps from Ubu (mostly small programs I suspect may contain viruses). I must re-install Wine with every use doing it this way, but the alternative... risking running them under Windows... is out of the question.
  7. ucould2

    ucould2 TS Guru Posts: 258

    Have you tried to connect manually to the webstar dpx 2000 series cable modem using a modem adapter card (if you have one) . Then for the other O/S use a crossover cable (Intranet or local connection if you have that too) to the modem. Then restart computer and modem? Instead of using the one configuration eg.sis ethernet adapter? I say 'Manually' as you may not be asked to specify one or the other connection, so during the restart unplug the one you're using for the other O/S.
  8. Mugsy

    Mugsy TS Evangelist Posts: 529   +56

    No, never

    I can honestly say I've never had to do any of that. I use a DSL router connected to the onboard Eithernet port on my MoBo.

    If you are using a separate PC Card for your interface, you may be out of luck, as the Ubuntu Live CD is unlikely to contain the necessary driver to recognize it.

    If you REALLY need a working copy of Ubuntu with Internet access working, you're best bet is going back to v8.10 until v10 comes out (which may or may not have resolved the problem by then).
  9. ucould2

    ucould2 TS Guru Posts: 258

    Define or Designate~driver attributes

    I received a copy of Kosmic Kolala 9.10 http://www.ubuntu.com/GetUbuntu/download that I was intending on using as the O/S on an OLD Intel P3 that is around here. But the core memory was not accepting 'anything' so I could not load to HD, however the Live CD did run on only the 512Mb of RAM! I was able to check my email & log onto sites etc. I just needed to configure the USB stick as the Modem! :cool: What I'm trying to suggest to you is that the Windows side of what you are doing is stopping you from doing what it is you want to do. This is the Windows configuration that every cat and dog LOVES (the all seeing, all doing) "Windows knows what's best" ~ don't you remember the advertisements, there's probably a Jingle to go with that recollection too (something to jog your mems http://news.bbc.co.uk/2/hi/technology/8499859.stm ).
    The basis of the idea ( idea because I have a USB Modem) was to basically line up your parameters. Designate a type of connection to one O/S type reboot both computer & Modem, then re-designate the other type of connection to the other O/S type reboot again computer & Modem. This should in theory dedicate for Windows which connection to use and which is on call to the other O/S. If I am correct then all you would need to change from one to the other is a 'Gateway' type switch BUT not a three-way switch ( or manually plug and unplug the different router cables) :zzz:
  10. tonylukac

    tonylukac TS Evangelist Posts: 1,376   +72

    Greetings to the person from down under. I often think of moving there. Just grasping at straws here, but (somewhat expensive if it doesn't work) get a wireless router, configure it on windows, then connect to it like you were going thru ethernet. I never had trouble with that with Slackware linux, and wouldn't have the slightest idea of how to direct connect to my dsl modem, if it supports linux at all. I guess in my case I just lucked out.
  11. Removing networkmanager and manual configuration through /etc/network/interfaces does not fix this?

    Try the following at the bottom of the /etc/network/interfaces and reboot:

    auto eth0
    iface eth0 inet dhcp
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...