DVD/CD Drive not working

By Pirran ยท 6 replies
Jan 8, 2010
  1. Hello Tech Spot :)

    I have a gh22ns50 LG "super multi" DVD-RAM drive and last week it just suddenly stopped working. It's reasonably new, and when it stopped playing games, it could play audio CDs for a bit but now it's not reading anything.

    Nothing is showing up in My Computer when I put a disc in, though the drive shows up empty, and it takes hours of opening and closing the tray and trying to get games to run before they'll run (but yes, they'll get read and they'll run once the drive actually recognises them). The Device Manager says there's nothing wrong with it.

    I have tried the following:

    Upper and Lower filter removal (there weren't any)
    Disc cleaning
    System restore
    Antivirus/Adaware/Registry cleaning
    Computer cleaning (the thing was disgustingly dusty inside, I've now taken it off the floor)
    Firmware updates
    Driver updates of everything
    Uninstalling and reinstalling the drive

    I thought it could be a problem with SecureROM as my boyfriend has installed some of his games that have that, and I know that can be an issue, but my drive doesn't play anything, even things that don't have that software installed. I don't know if it matters but my drive has SecurDisc written on the front. (I'm not too hardware savvy, sorry)

    I could not find the jumpers on the drive to check what they were set to, I even removed the thing to look and I couldn't see anything, the cables were plugged in fine and the light flashes.

    I also don't know if this matters, but when I bought the computer four or so months ago, I removed Vista and installed XP instead. Google has failed me! Are you guys able to help?
  2. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    Check in the Device Manager under IDE ATA/ATAPI controllers and see if the optical drive has reverted to the slower PIO mode instead of the DMA mode. If so, try changing it back to the DMA mode. Check back later to make sure it remains in the DMA mode.
  3. Pirran

    Pirran TS Rookie Topic Starter

    Oops, I forgot to add that to my tried things. It had already been set to DMA and I'd changed it to PIO and back again and it had done nothing. I also tried something that slowed down the speed at which the drive read discs and that hadn't done anything either.
  4. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    Despite the fact that it is fairly new, there is the possibility the drive has basically died.
  5. Pirran

    Pirran TS Rookie Topic Starter

    Even if it still runs things after ages of trying to get it to read? Bugger.
  6. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    Well, you wouldn't consider that normal operation would you? If that's the only way it works, then that's not really working IMHO.
  7. Pirran

    Pirran TS Rookie Topic Starter

    Yeah, that's true. I just pulled out an old dvd drive from the PC before this one and plugged it in. It took me a while to figure out because it had different connections, but Fallout 3 works fine now, so it must have been the hardware after all :( Thanks for your attempt at helping though, it was appreciated :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...