EMachines T2240 no sound

By ToonPal ยท 8 replies
Apr 23, 2008
  1. EMachines T2240 no sound (RESOLVED!!!)

    I finally figured out what was keeping me from getting sound from this old eMachine. I thought I'd share my discovery here in case anyone else runs into this problem. You can read the original message further down to get a grasp of the problem I was having.

    The original sound driver that was installed on this system, Avance AC'97 Audio dated 06-2002, was not compatible with the Imperial GV's AC'97 implementation. But strangely, installing compatible Realtek AC'97 Audio drivers wasn't working, either. These drivers worked fine in fresh installs of Windows XP but not in the old installation which I wanted to keep active. Well, I went ahead and messed around with a fresh installation somemore, and I finally reproduced the problem I was having with the old installation. It turned out that not all of the files from the old Avance driver were removed from the system, the culprit being a file left in the C:\WINDOWS\SYSTEM32\DRIVERS directory named ALCXINIT.DAT that wasn't getting installed by the newer drivers. Apparently, even the newer-version drivers were trying to use this file and ended up killing all audio output in the process. So, I deleted the file, rebooted, and voila! Now I can keep using the old XP installation and even use it to play MP3s, again!

    This may not mean much, everyone, but thanks for trying to lend a hand. I really do appreciate it. See you all around!
    Original message:
    Here's something that has me utterly stumped.

    I have this old eMachine system. It's not really a T2240, anymore, since its core hardware component, its motherboard, died and was replaced by an inexact match; This model eMachine had a Trigem Imperial GL_VE motherboard, and that died and was replaced with a Trigem Imperial GV motherboard. Both of these motherboards have an i845 chipset(although one is GL and the other GV). For the most part, a drop-in replacement of the motherboard worked pretty good. The system booted up and re-detected all hardware. Everything was fine, except sound.

    I would like to get sound working with the existing Windows XP installation on this system without wiping it out and starting over. I have tested this system with a fresh installation of XP, and with that, absolutely everything, including sound, works perfectly. But that hasn't helped me understand why I can't get it working with an old installation of Windows XP.

    The main symptom of my problem is, simply, no sound. Everything looks fine in appearance; no exclamation point on the Avance AC97 Audio driver(or Realtek in case of newer drivers), "This device is working properly", volume controls available, playback, recording, and MIDI devices are there, everything. But, despite all that, the system is dead silent; no sound from the speakers. I've even gone so crazy-far as to try to get sound by plugging the speakers into the Mic and Line-In jacks just to be sure I'm not using the wrong jack!

    To help narrow things down, here's what I've tried so far:
    Driver uninstall and re-install
    Install updated drivers
    Uninstall drivers, clear device manager of all deletable devices, and clean up registry entries related to those devices, including Microsoft Kernel Audio drivers

    After all this, I am just plain stumped. Does anyone have anymore ideas that I could try? Or, by some chance, does someone understand exactly what is going on that can tell me what I'm doing wrong?

    Oh... In case anyone was wondering, I am aware of the front case panel incompatibilities that the GV board has with eMachines cases designed for GL_VE motherboards. I've taken the necessary steps to steer clear of any issues caused by those incompatibilities. Like I said, I can get sound with a fresh installation of Windows XP, but I'd like to keep the existing installation since it contains a great deal of software and settings that would be extremely inconvenient to re-implement in a fresh installation.

    Thanks in advance!
  2. turbo1

    turbo1 TS Maniac Posts: 353

    have you tried going into your BIOS & enabled the onboard sound?
  3. ToonPal

    ToonPal TS Rookie Topic Starter

    Would onboard sound work in a fresh XP installation if it were disabled in the BIOS?
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    The answer is no... By default your on-board sound should be enabled in the bios. Try a bios or CMOS reset. If this doesn't work, try installing a PCI sound card
  5. ToonPal

    ToonPal TS Rookie Topic Starter

    I was being sarcastic.

    Look, like I said in my initial post, the onboard sound works perfectly with a fresh installation of XP. BIOS settings are NOT the problem. I am asking for help in understanding why my current XP installation doesn't make sound despite appearing to be correctly installed and fully functional at a cosmetic level.
  6. ToonPal

    ToonPal TS Rookie Topic Starter

    Well, the PCI sound card experiment might be a good idea. Unfortunately, I don't have one to test with. But say that it also gives me the same problems; cosmetically correct installation but no sound. What would be the solution?
  7. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Ok look in the device manager and see if you notice any yellow asterisks or exclamation marks in the list. Uninstall any yellow notations and restart. See if the on-board sound is detected and corrected
  8. ToonPal

    ToonPal TS Rookie Topic Starter

    I'm repeating myself, again.

    No exclamation points. Everything appears to be correctly installed and working properly. The only symptom of a problem is no sound. Nothing else. In a fresh installation of XP, everything looks the same. The only difference is that sound works. I thought I made all this clear in my initial post.

    I suppose I could add that I'm getting no service errors. Although, usually, a service error related to a device is coupled with a device with an exclamation point in device manager.
  9. ToonPal

    ToonPal TS Rookie Topic Starter

    Problem solved!

    I finally found the answer! This old T2240 eMachine(actually, it's more of a T2682, now) finally has a voice, again!

    I edited my initial post in case anyone is curious as to how I solved my problem.

    Thanks, and see you all around!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...