1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Epson USB printer/driver issue

By Cynapse ยท 17 replies
Dec 24, 2011
Post New Reply
  1. I have recently purchased receipt printers (Epson TM-U220B[usb connection]) to use in conjunction with a POS program. I am running Windows 7 64bit HP

    I am unable to even print a test page to them at the moment.

    Here are the steps that I have taken:

    -Disconnected the printer.
    -Uninstalled all EPSON driver software & restarted the computer.
    -Reinstalled EPSON Advanced Printer Driver V4.52 (APD_452E) with these configuration settings:
    Setup Type
    Printer Configuration
    -Add EPSON TM-U220 Receipt
    -EPSON TM-U220 Receipt[US]
    Create a USB port
    -Restarted computer (for good measure!)
    -Connected printer.
    -Windows then installs device driver automatically with the following commentary:
    EPSON UB-U02III - Searching Windows Update
    EPSON USB Controller For TM/BA/EU Printers - Ready to use​
    At this point the printer is shown in Devices and Printers under Unspecified with the name UB-U02III (which it looks like is the model designation for the USB adapter board on the back of the printer).

    The installed printer (installed via APD driver) EPSON TM-U220 Receipt printer is showing up as Not available in its status.

    What am I doing wrong?? The driver is downloaded directly from Epson on their product page for the U220.

    Incidently I get an identical result trying the above on a Windows XP machine.

    I hope this is concise and not to waffly!

  2. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    I had an experience with POS before; get the system to print a simple X.TXT file
    and then address the POS finding and using it.
  3. Cynapse

    Cynapse TS Rookie Topic Starter

    The issue isn't with the POS program (I haven't even got this far yet!). I cant get Windows to recognise the printer properly. When plugged in the device listed is UB-U02III which is the inbuilt epson chip board serial>USB adapter. The automatic driver assigned is 'Epson Controller for TM/EU/BA Printers' desipte the fact that the Epson APD v4.52 driver is installed for a TM-U220 printer.
  4. Rabbit01

    Rabbit01 TS Evangelist Posts: 787   +58

    Reading through the manual on EPSON's site, it talked about DIP switches on page v. Not sure where those are since there's no illustrations. But I guess you'll see them once the cover is opened. Anyway, have you tried adjusting those?
  5. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    Go to the device and UPDATE the driver manually, telling it to look where the new driver is located, f:\thumbdrive or perhaps in your c:\downloads for example
  6. Cynapse

    Cynapse TS Rookie Topic Starter

    Haven't looked at the DIP switches.

    When I try and Update the driver from the Printers and Devices screen, automatically it tells me the driver is up to date, and if I manually search for the .inf file it says its not compatible the device or if it is it isn't compatible with 64bit despite Epson saying it is...
  7. Cynapse

    Cynapse TS Rookie Topic Starter

    DIP Switches are set all to off except DSW2, 2, Which is on:

    1 OFF [Data Receive Error] Prints "?"
    2 OFF [Receive buffer capacity] 4KB
    3 OFF [Handshaking] DTR/DSR
    4 OFF [Word Length] 8bits
    5 OFF [Parity Check] No
    6 OFF [Parity selection] Odd
    7 OFF [Transmission Speed] 9600bps
    8 OFF [BUSY Condition] Receive buffer full or offline

    1 OFF [Print Column] 40/33
    2 ON [For internal use only (autocutter)] Enabled
    3 OFF [undefined] -
    4 OFF [Serial Interface Selection] DIP switch
    5 OFF [undefined] -
    6 OFF [For internal use only (flash memory rewriting)] Disabled
    7 OFF [Pin 6 reset signal] Not used
    8 OFF [Pin 25 reset signal] Not used
  8. Rabbit01

    Rabbit01 TS Evangelist Posts: 787   +58

    In the technical reference manual, it says that the USB model needs to have the USB device driver installed:

    5. Install the UB-U01II/02II device driver on the host computer.

    This appears to be separate from the APD. Have you installed the USB driver? If not, maybe it's the TMCOMUSB Serial Emulation Driver?
  9. Cynapse

    Cynapse TS Rookie Topic Starter

    Hmmm I didnt see that in the paper manual Ive got. Having said that I had thought of it but I cant seem to find the UB-U02III driver anywhere?
  10. Cynapse

    Cynapse TS Rookie Topic Starter

    Right well the TMCOMUSB driver is now known as the TMVirtualPortDriver which I have tried, despite the fact there is no documentation on the Epson website for it (even though this is where I downloaded it from). As for the UB-U02III driver, it sounds as though this is part of the APD although this could be untrue...

    PS Have been on the phone to epson support for over a week, Initially I was told that the engineer would find a printer and try and install it himself on win 7 64 bit, no one got back to me, then i was told he had trouble getting hold of that model but would do it asap, no one got back to me, then I was told this guy had been moved from this team but the problem had been sent to Level 2 support, no one got back to me, then i was told that another customer was having the same problem and theyve sent in their printer so Epson can diagnose the problem.... They literally are the worst customer service center I've ever had the misfortune to have to deal with. WHY CANT THEY JUST BE HONEST!?
  11. Rabbit01

    Rabbit01 TS Evangelist Posts: 787   +58

    I got the tech reference guide from here: http://pos.epson.com/developers/techresdetails.htm?productpk=545

    Under the utilities section, there's one called virtual port driver, it's version 7.10a. Maybe it's an updated version to the TM virtual port driver you've tried? It'd be so much better if there's a brief description somewhere.

    Hope somebody there will get back to you soon.
  12. spotthediflinux

    spotthediflinux TS Rookie

    1) Deleting all the software as you describes is not enough, it still leaves bits and pieces throughout your system

    2)Can I just ask first, is there any chance that you connected your printer to your computer BEFORE you installed all the drivers and software, the first time? I suspect that is what you have done. If so, you will get exactly the behaviour that you are talking about here.

    3)further to "1)" above, if you have done "2)" or if you want to remove your software completely, you need to also search the Window registry after you have removed the software and remove anything it has put in there. Make sure you make a backup of your registry first.

    4) yes windows is retarded, so compare this to Linux, To get almost any USB printer to work on Kubuntu Linux you just ............ PLUG IT IT!! No driver, no software, they just plugin and auto configure and in a few second just work!
    HP make a good effort to fully support all their printers on Linux, so all things being equal, always buy a HP. Most other brand common usb printers also just plug in and work as well, but HP makes the most effort, hence deserves preferential treatment at purchase.
  13. spotthediflinux

    spotthediflinux TS Rookie

    Your problem is almost certainly that you physically plugged in your printer BEFORE you installed the software THE FIRST TIME. If you did, then you will get the behaviour that you are describing here.

    So I have rewritten my post with more "how fix it" information.

    Important notes -
    1) Deleting all the software in the way you describe does NOT remove it all, it still leaves behind "stuff" in your system. You also have to search your registry and delete the appropriate entries. If you do anything with your registry, back it up first!!!!

    2) Yes, Windows really is so retarded that it will give you these results.

    Your solution is


    1) UN-install all the printer software, and any other software you may have tried to install to fix this problem.
    2)workout what windows put in your registry when you first physically connected your printer, and delete it. Almost certainly since it didn't have the printer driver installed first, stupid windows thought it was a UB-U02III. Now stupid windows has associated your USB-id number to UB-U02III, rather than the printer.
    3) so almost certainly you need to go into the registry and delete the references to UB-U02III
    4) now re-install your printer driver software WITHOUT CONNECTING THE PRINTER!!!!!

    Windows try's to mitigate some of it retardedness by automatically saving "restore" points when you install hardware, you may well be able to achieve my manual instruction better by restoring to a restore point, if the system made one at a convenient point in time, which I think it would have. BIG WARNING THOUGH, you need a restore point BEFORE you physically connected your printer, NOT ONLY BEFORE YOU INSTALLED THE PRINTER DRIVER SOFTWARE.

    Now for my fee for my time giving this advice, ..... you have to read my Linux advice! :)

    To install a printer in Kubuntu Linux (or any other modern desktop Linux) you follow this procedure.........

    Just plug the stupid printer in, wait 5 seconds for Linux to automatically configure it and ..........that's it.

    U]YES, Linux really is that clever, [/U] no installing drivers and software, it is all included and automatic. Just plug almost any printer in and it just works!!!!

    HP makes the most effort to fully support Linux, so if all other aspects are equal, always buy a HP printer.

    Happy New Year!!! :)
  14. Cynapse

    Cynapse TS Rookie Topic Starter


    Thanks for you reply, I will try the fix in the morning.Yes I DID connect the printer before the APD installation (having too much faith in windows has its price!). Didn't think it would be necessary to manually go through the registry. Unfortunately I cannot run Linux on the machine due to the software constraints I am faced with. Any tips on where to look in the registry would be appreciated seeing as it being such a jungle that it is!

    Thanks again.
  15. spotthediflinux

    spotthediflinux TS Rookie

    Yeah sure,
    search for
    1)printer brand name, Epson, printer model name, TM-U220B
    2)name of the USB device that windows thinks the printer is
    e.g. UB-U02III, TMCOMUSB, TMVirtualPortDriver

    I don't think it will work but you could try this first just in case, since you may find it easier. Go to the control pannel, system, device manager, find the item that Windows thinks is there when you connect your printer and force it to use the driver for your printer. But when I had to fix this same problem once a few years ago, with a different USB printer that someone had also plugged in before loading the software, I am sure it did not work. I know that in that case I definitely had to go to the registry, so I imagine that this is still the case.

    Just make sure you you do the back up first, promise?
    1)back up your registry before you start stuffing around with it. VERY important!
    2)Un-install all the printer software BEFORE you search the registry.
    3)Make sure your printer is, and remains DISCONNECTED through out the registry searching/deleting process and remains so until you AFTER you have re-installed the software from your CD that came with the printer/software downloaded from Epson. Usually the installation process will ask you to connect your printer at some point during the software/driver installation, if/when it does, that's when to connect the printer, otherwise just wait until after all software is installed.
    4) reboot the computer after you have edited the registry BUT before you have re-installed the printer software. This reboot is how you unload the old registry and load up the newly edited registry. If you don't reboot you will still have the old wrong unedited registry in memory despite your edits to the registry on the HDD.

    I think from memory there will only be a couple of things to delete, and make sure you don't delete something that you need. Be conservative, delete one or two thing that seem obvious and then try it.

    Now for my fee more rant : -)

    If you are running something that needs to be reliable like a website, or a POS system, you should be on Open source software, there are open source pos applications out there as well as Linux o/s.

    Nothing much is 100% true in the IT world, but in 99% of cases this is accurate advise. You will find there is a lot of Windows centric IT advise out there of dubious quality, mostly it is just poor quality IT staff that really don't know what they are on about, they have usually only used Windows.

    good night and good luck,

    P.S. Please tell me how you go.
  16. Cynapse

    Cynapse TS Rookie Topic Starter


    The solution was to roll back windows to a state before the first time ever the printer was plugged in (I reverted to original factory install). Then I had to install the driver BEFORE plugging in the device.

    The problem was the very first time I plugged the printer in, the Epson APD driver wasnt installed. Windows therefore assigned the most relevent driver and created registry keys associated to the physical hardware ID of the printer. Even when the windows chosen driver was uninstalled and so too was the Epson software, the keys created by windows associated with the printer ID remained. So the keys had to be deleted (or a system restore to a point where the reg keys never existed).

    In short NEVER EVER EVER ring Epson customer support because they are crap. Their many solutions were mostly fob offs or time extenders for them. Their final one was send them the printer. Which wouldnt have resolved this problem even if I had done it.

    Finally, in one form or another, the problem always always lies with the drivers. (Unless your hardware is in more than 34 pieces, in which case its probably smashed!).


    You were completely spot on. I briefly tried deleting the registry keys but I spent all of about 10mins on it. It wasnt a problem to roll back to factory install because basically the computer is new anyway and I knew this would sort out any registry issues, but I'm 100% positive the problem lay with the reg keys.

    Your advice was invaluable and you have solved umpteen hours of work on this. I cant thank you enough.

    I can't tell you how true this is. Unfortunately I am running a POS system that is constructed in VB6 by an external company so it isnt prudent to run Open Source which is rather irritating.

    Again thank you so much for all of your advice.
  17. spotthediflinux

    spotthediflinux TS Rookie

    OK that's good, sort of, but now I am a little worried, see below.

    Your description of the problem is correct I didn't tell you all of that detail in advance because, well I had already written an essay! :)

    I just recently purchased a really cheap 3-in-one HP printer for my mother. It had stickers with large red writing saying in capitals "DO NOT PLUG IN BEFORE INSTALLING SOFTWARE" or something like that, over the cable and printer plug.

    How stupid is Epson if they didn't instantly work out what the problem was!! I saw what the problem was instantly, I was only doubtful because I thought surely Epson would have thought of this first thing and asked you about it.

    You say "don't call Epson support", better to say "don't buy an Epson in the first place" if their support is so stunningly incompetent!

    Now the concerns.
    What you have said brings up all sorts of questions and doubts in my mind.
    Particularly reading between the lines.

    1)what do you mean "roll back to factory install"? There is a Windows roll back feature which rolls back to "restore points" one of which would be original install. But I think you might mean you re-installed the whole system software back to original factory? Either way, make sure you now go back and immediately do all of the windows updates and ALL the updates for all applications immediately, most particularly urgent if this system has any access to the Internet.

    2) what security software and anti-virus software are you running?
    3) is the pos system connected to either the Internet? or a network in which any other device is connected to the Internet?
    4) written in VB6!!! It is extremely unlikely that you need a special purpose application, and it is not very likely (but I guess not impossible) that your application is any good if it is written in VB6!
    5) I could be wrong, but I would bet that you are being taken advantage of (ripped off). It sounds like it, anyway. I think you need some independent advice.
    6) Have they written in VB6 because they are linking you into MS applications? If so that is also a concern, then you have to pay for an MS application that you don't otherwise need and you are open to all the vulnerabilities in that MS application as well.
    7)open source does not HAVE to mean free of charge, it just means that they have to show anyone the source code. They could still sell you the service of providing you a working POS set up using open source software. They could even still sell you the software still if they wanted to.
    8) in general terms one of the main reasons companies/people don't want to let there code go "open source" is that they know that then anyone can read it and thus all their crappy workmanship will be obvious. I know that sounds like an extraordinary statement to make, but I think you would be surprised at how true it is.

    Without knowing a lot about your business, obviously my advice is very general and may not even apply to your business, but my experiences makes this seem doubtful.

    Remember that you own your data, don't let unethical companies tie your data up in formats and applications that restrict your access to your data and tie you to their products.

    If their product is good, works well etc. then why would anyone bother to go to all the effort and risk in moving to any other software? So why do they tie you in with artificial difficulties? Answer, because they know their software is crap and you can get better elsewhere cheaper or for free.

    You say it wouldn't be prudent to use opensource, I strongly suggest that what would not be prudent would be to continue with that external company!

    Anyway I am happy that you fixed your problem so easily, good luck and happy new year!

  18. smackdead

    smackdead TS Rookie

    Hey I have the same problem, can you help me??

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...