1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Explorer.exe not responding / running slow

By Orinath ยท 14 replies
Jan 24, 2012
Post New Reply
  1. [Solved] Explorer.exe not responding / running slow

    I recently started having a problem opening files and programs on my pc. Startup has also gotten really slow and I don't understand what the problem is. Going into My Computer and just searching through some files takes 10x longer than normal, if not longer. Often it results in Explorer.exe not responding. Programs on the other hand take 2 minutes to open up when before it would take seconds.

    If I start the computer in safe mode I do not have the problem. I assume since windows explorer runs properly in safe mode that the problem is being caused by something that loads in normal mode. How do I figure out what is causing the problem?

    Here is what I have tried so far:
    - I used Advanced System Care v5.1 Pro and did a deep scan.
    - I have tried a virus scan with BitDefender.
    - I have run registry mechanic on the system.
    - I have disabled all third party startup items under msconfig
    - I have run ShellExView and stopped all third party extensions
    None seem to help.

    Edit: - I have not restored to a time before the problem occurred because there were not restore points available before the problem occurred.
  2. gbhall

    gbhall TechSpot Chancellor Posts: 2,419   +77

    I think you may just need a 'clean and polish'. Your HDD should be tested for read problems (run chkdsk /r) then all unnecessary temporary files and Internet cache ahould be cleaned out (ccleaner), finally defragment (auslogics disk defrag)
  3. jobeard

    jobeard TS Ambassador Posts: 12,205   +1,361

    system {XP,Vista,Win/7} and version {pro,basic,ultimate} ???

    Installed Antivirus? Firewall?

    get a command prompt and enter tasklist>myTasks.txt
    copy & paste the contents of myTasks.txt
  4. Orinath

    Orinath TS Rookie Topic Starter

    gbhall - I have done everything mentioned and I'm still have the problem.

    joebeard - I'm using Windows Vista Home Premium 64bit. Nothing popped up after typing this, tasklist>myTasks.txt, in the command prompt. I opened myTasks.txt and it was empty.
  5. jobeard

    jobeard TS Ambassador Posts: 12,205   +1,361

    try it again from an Admin Login or
    runas /user:administrator cmd and provide the password
    and then enter tasklist >myTasks.txt
  6. Orinath

    Orinath TS Rookie Topic Starter

    So after playing around with some startup services I finally narrowed it down to a microsoft service that is causing the problem.

    Shell Hardware Detection

    I don't really know what to do from here. How important is this to run?
  7. jobeard

    jobeard TS Ambassador Posts: 12,205   +1,361

    I guess you STOPPED the service and the system responds better???
    Not at all -- It controls AUTOPLAY, which frankly can be considered to be a risk.
    Consider; You pop in a cd and the autoplay does it's thing - - but how do you know that was safe?
    The ONLY way to safely do this is to disable autoplay (there is a registry fix) so as to
    allow you to use your A/V software to scan the autoplay files, eg autorun, setup, *.ini
  8. Orinath

    Orinath TS Rookie Topic Starter

    Yes, I turned off the service and the system is running without any issues. Just a smooth as day 1.

    Will keeping it off interrupt plugging in an external hard drive as well?
  9. jobeard

    jobeard TS Ambassador Posts: 12,205   +1,361

    don't think so, as HDD (even a USB attachment) is not an AUTOPLAY event - -
    they are MOUNTed devices.

    Even if a usb thumbdrive has an autoplay installed, the drive STILL mounts and you get control to Explore / Run anything on it :)
  10. jobeard

    jobeard TS Ambassador Posts: 12,205   +1,361

    PS: I just disabled the service, inserted my USB thumbdrive and got everything I expected :)
  11. Orinath

    Orinath TS Rookie Topic Starter

    Thanks for all the help. Hopefully someone else gets use out of this thread in the future.
  12. tonylukac

    tonylukac TS Evangelist Posts: 1,374   +71

    I had a problem with that same service and found uninstalling all ati software, not the drivers tho, helped. It was a type of tuner/video card that had such software. The card has since blown out due to a power blip. Also, try scanning with malwarebytes anti-malware which can be searched for, and a link occurs on Techspot's anti malware forum.
  13. Darth Shiv

    Darth Shiv TS Evangelist Posts: 1,875   +506

    Interesting. Will have to keep an eye out for that one. Thanks guys.
  14. tkelly62

    tkelly62 TS Rookie

    I seem to have the same problem wiht a Windows 7 machine and I followed the same approach but when I try to stop the Shell Hardware Detection service, it says Access is Denied. I am the administrator on this computer. I cannot get past this. Any ideas?
  15. Debojit

    Debojit TS Rookie

    I think this is your hard drive error related problem ...check HDD errors then re-installing windows. it will solved the problem also check for Heat related proublem..

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...