External HD Delayed Write Failed

By Ysman · 18 replies
Aug 5, 2008
  1. I own a Fantom Drives External Terabyte on USB 2.0 and have been using it without a hitch for about 6 or so months now. Just recently it has been behaving strangely. The drive sometimes randomly disconnects. Afterwards, more often than not, it will reconnect. You can hear the default Windows XP sounds for a disconnecting/reconnecting USB device. Along with this, I notice a bubbled message coming from my taskbar warning me of a "Delayed Write Failed" in the drive. It claims that it could not finish saving the data "H:\$Mft" or "H:\$Extend\...". Other times it will actually report data on the drive itself, like MP3 files or photos, as unable to be saved due to a corrupt device or network connection.

    All this happens more frequently when I try to scan the drive. For example, if I try to load up the data from the drive into Windows Media Player LIbrary, the "Delayed Write Failed" happens frequently with disconnects and reconnects of the drive itself.

    I tried a few things to troubleshoot the problem. First I tried powering down the drive and starting it back up. This only seemed to work if the drive did not reconnect after it disconnected. I also tried using Firewire instead of USB 2.0, did not help. I also tried using a different USB 2.0 cable, also did not help.

    I tried running Chkdsk. I tried using the traditional method of going to the properties of the Drive and selecting Tools and then Error-checking. I selected both options, but it would always tell me that the drive was being used by Windows and that I had to restart to perform a drive scan. However, every time I'd reboot, the scan would not commence upon startup.

    I tried running Chkdsk in SafeMode. In SafeMode the scan would commence immediately but would eventually say that the scan could not be completed. I tried running the scan a few times after and it just reported the same error.

    I then took the drive and tried it on another PC. It works fine, the data seems to be intact, just as it was on My PC. I then tried to run Chkdsk in the command prompt with the parameters /f /x /r. The scan would get to Phase 2 and then hang on 0% for several minutes. Then after getting to a certain point, it corrects an error in an index and then stops. After this, I'd run the scan again and it would do the same thing, stopping after seemingly correcting an error in an index, sometimes two.

    I have yet to see Chkdsk finish or even get to the point of scanning for bad sectors.

    The data seems fine, would this be a big indicator of a corrupting drive? Or is it just that the indexes are screwed? Purhaps backing up the data and reformatting the drive would help?

    Are there any diagnostics I can find that can thoroughly scan my drive without it hanging up and stopping on each and every index error? Fantom Drives doesn't seem to have any such diagnostic tools on their website...

    I'd appeciate any help you can give. Thanks.
  2. Justin

    Justin TS Rookie Posts: 942

    Is the drive supplied with its own external power source? If so, it sounds like the drive is losing power and turning itself off and on, which would explain the repeated disconnects/reconnects.

    To see if the drive itself is functional, understand that all USB drives are going to be plain jane IDE or SATA drives inside the enclosure. You can remove the drive from the enclosure and plug it directly into a machine to see how the drive behaves there.

    I'd suggest checking out the power supply as well as the internal power connection to see if it is loose, cracked, et cetera.
  3. Ysman

    Ysman TS Rookie Topic Starter

    I reconnected the external hd to my PC and ran Chkdsk successfully from cmd. However now it hangs for much longer on Phase 2 at 0%. Then it immediately says "Correcting error in index $0 for file 25" and then stops. I tried to run the scan multiple times and it keeps reporting the same thing with the same "Correcting error in index $0 for file 25" message.


    I just tried to run it again and it got to 18% and hanged there and then "Correcting error in index $130 for file 98448".
  4. Ysman

    Ysman TS Rookie Topic Starter

    It is supplied with its own AC adapter and is plugged up to my surge protector. The only thing that connects to the PC is the USB 2.0 cable.

    There are two different lights on the Drive enclosure, a blue one that indicates that the drive has power and a red one that shows the drive is connected/active. When the drive seems to disconnect, only the red light shuts off and the blue light remains on. In fact, the blue light NEVER goes off unless I power down the drive by hitting the switch on the back or unplugging the power cord attached to the enclosure.

    Also, the drive disconnect most often when the drive is active. Meaning, it will usually disconnect when I am trying to transfer data, running Chkdsk, etc. however I've heard it disconnect when I am away from my computer and the computer seems idle.
  5. Ysman

    Ysman TS Rookie Topic Starter

    I just tried using Chkdsk with the parameters /f /i /x /r. I used /i to bypass the indexing problem and get to Phase 4. However since the drive is very large the scan hung for a very long time at 0%. Then it finally gave me this error... "The disk does not have enough space to replace bad clusters detected in file 9xxx of name ."

    I have searched the net for this particular problem and it is generally reported that this means the drive is going up.

    Is there any hope for this drive? Are there any other more robust diagnostics I can use to scan an external hard drive? Does software like SpinRite work for external usb hds?
  6. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    I would recommend disassembling the drive and connecting it as an internal. Then running the diagnostic tool from the manufacturer of the hard disk itself (not the enclosure brand). If there are bad clusters as indicated by your last post the drive could be failing.

    I don't know what diagnostic tools work well with external FW or USB drives.

    Its a long shot but Soul could be right with the power source. I think all 3.5" external drives use the same power supply. Well not exactly the same as in make, but exactly the same as in voltage outputs. So if you don't want to open the enclosure you could use a power supply from another drive (or borrow one from a friend temporarly) to see if the problems still occur.
  7. Justin

    Justin TS Rookie Posts: 942

    As sngx and I both suggested, this should be your next step to see if the drive itself is faulty or the enclosure.
  8. Ysman

    Ysman TS Rookie Topic Starter

    There is only one problem, the drive itself is actually 2 HDs on a RAID built in to the enclosure as a single Terabyte total hard drive space. I heard from numberous sources that people had to call up Fantom Drive customer service and have a tech work them through taking the thing apart just to make it come up as 2 seperate drives, thats not even taking into account actually plugging them up or how the data is stored across both of those drives. The data on there is quite valuable to me and I would like to proceed with caution.

    The biggest problem is with Fantom Drives. Their customer service is almost non-exsistant. They don't have a diagnostic posted on their website...I've tried to google, but no luck. The only way to get in touch is to leave a message for them to get back to you in 1-3 days and from what I gather, people still had problems hearing from them.

    I tried using SpinRite6. My friend had a copy and he said good things about it. The process was slow due to the drive being on USB, but I had no problem with the wait. However, the program kept giving me an error only about 10 minutes into the scan, a "Division Overflow Error" which caused the program to halt.

    I also tried HDD Regenerator, but the scan would take weeks since it is a surface scan on an external. I gave up after seeing that the scan was only finished 5gbs after one night of scanning.

    I think the problem has something to do with the drive cutting off while windows was writing to the Master Table, therefore corrupting the indexes. I usually had the drive set as the default "My Documents" location and therefore Windows used the drive continually, however for the past few months I rarely added anything to the drive for storage.

    Now Chkdsk only gives me "Correcting error in index $0 for file 25" and then stops during Phase 2. Since it stops so early, I'm thinking it has to be the Master Table, especially from seeing "H:\$Mft" coming up on the bubbled warnings.

    Do you guys think transfering the data to another external and then reformatting might help? I could reformat and then scan the drive for surface errors...
  9. Ysman

    Ysman TS Rookie Topic Starter

    I've tried copying some of the data on to one of my internal HDs, but the drive keeps disconnecting during the process. I am hoping that somehow I can transfer the data to another drive and then zero-write the faulty external and try to do a clean reformat.

    Any suggestion on some software I can use to safely transfer data without these disconnects?

    Also let me reclarify that the drive does not power down. It simply disconnects, indicated by the red light on the enclosure. Also, I'm assuming that the Delayed Write Failed messages are coming from Windows trying to save data on the drive that is simply "not there" for it to save to, however it still appears in My Computer. When the red light is not present, I can access the folders in the drive, but no data is present. When I power down the drive and then power it on again, it takes a few moments, but the red light activates and I am able to access the data on the drive for a short period of time before the drive disconnects again (red light off).

    If I were to remove the drives from the external enclosure, how would I be able to directly connect them to my system while still keeping the RAID intact? I'm not too experienced with RAID.
  10. Ysman

    Ysman TS Rookie Topic Starter

    I tried using TestDisk, and the program reports that the Boot Sector and its backup are bad.
  11. Ysman

    Ysman TS Rookie Topic Starter

    Now it will not let me access the drive at all, saying "Device is unreable or inaccessable".
  12. Ysman

    Ysman TS Rookie Topic Starter

    I went over System events in the Event Viewer and it comes up with these repeatedly when I try to connect the drive to the system...

    Event Type: Warning
    Event Source: Disk
    Event Category: None
    Event ID: 51
    Date: 8/7/2008
    Time: 12:53:34 AM
    User: N/A
    Computer: DAVID-1
    An error was detected on device \Device\Harddisk3\D during a paging operation.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    0000: 03 01 68 00 01 00 b6 00 ..h...¶.
    0008: 00 00 00 00 33 00 04 80 ....3..€
    0010: 2d 01 00 00 0e 00 00 c0 -......À
    0018: 00 00 00 00 00 00 00 00 ........
    0020: 00 00 00 00 00 00 00 00 ........
    0028: 15 5f 01 00 00 00 00 00 ._......
    0030: ff ff ff ff 01 00 00 00 ÿÿÿÿ....
    0038: 40 00 00 08 00 00 00 00 @.......
    0040: ff 20 0a 12 4c 03 20 40 ÿ ..L. @
    0048: 00 00 00 00 0a 00 00 00 ........
    0050: 00 00 00 00 40 88 52 88 ....@ˆRˆ
    0058: 00 00 00 00 08 10 6d 88 ......mˆ
    0060: 00 00 00 00 8f 75 38 3a ....u8:
    0068: 28 00 3a 38 75 8f 00 00 (.:8u..
    0070: 08 00 00 00 00 00 00 00 ........
    0078: 00 00 00 00 00 00 00 00 ........
    0080: 00 00 00 00 00 00 00 00 ........
    0088: 00 00 00 00 00 00 00 00 ........


    Event Type: Warning
    Event Source: Ftdisk
    Event Category: Disk
    Event ID: 57
    Date: 8/7/2008
    Time: 12:53:34 AM
    User: N/A
    Computer: DAVID-1
    The system failed to flush data to the transaction log. Corruption may occur.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    0000: 00 00 00 00 01 00 be 00 ......¾.
    0008: 02 00 00 00 39 00 04 80 ....9..€
    0010: 00 00 00 00 0e 00 00 c0 .......À
    0018: 00 00 00 00 00 00 00 00 ........
    0020: 00 00 00 00 00 00 00 00 ........

    I was reading around, and some people claim that the second one listed is due to the removeable drive being disconnected before using Windows Safely Remove Hardware. However, I had the drive set to Quick Removal.

    Now when I connect the drive, Windows does not recognize the label I had set for the drive, "Storage", instead it sees it as "Local Disk". Also, and even more disturbing is the fact that it reports it as having the file system "RAW" with 0 bytes used and free space.

    Could this be a problem with some drivers? The problem with Chkdsk in Phase 2 also occured on the other PC I tried the drive on, however it did not disconnect or report any problems with $Mft or $Extend on that PC.
  13. Justin

    Justin TS Rookie Posts: 942

    Well, you've definitely pushed it over the edge. From what you are describing, that array is toast. One thing you should take away from this is that if you suspect hardware failure, especially with disk drives, don't try to push them over the edge.

    Sorry to hear that it has gone belly up on you. At this point I don't see you retrieving data without sending it to a data recovery lab.
  14. Ysman

    Ysman TS Rookie Topic Starter

    I tried powering the drive on and off, besides any diagnostics I've ran. I did not try to push the drive. I tried to copy data off the drive ONCE, but I gave that up when the drive simply disconnected as it always did.

    So lets say that powering the drive on and off pushed it over the edge. At this point the only thing I care about is recovering my data. I hear of some software that can recover data off of drives even if the partition is corrupted. Has anyone had any experience with any such software?

    I'd like to try some more inexpensive methods before consulting a tech or a recovery lab.
  15. Ysman

    Ysman TS Rookie Topic Starter

    Ok it has been a while since I added to this thread, but I found a program that lets me recover data off of the drive. It is called File Scavanger Version 3.2. The data integrity is 100% so far, however the drive is picky. Sometimes the drive will let me pull data off, sometimes it won't saying that the data can only be partially recovered. However, if I try pulling the same data off at a later time, it works just fine. This leads me to think that the data is not corrupted at all, especially since ALL the data I've recovered so far is uncorrupted and the partially recovered data was able to be fully recovered after repeated attempts.

    If I recover all the data, I plan on trying to reformat the drive and see if it remains faulty.
  16. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Out of curiousity - that TB with 2 drives has to be 2 x 500 in Raid 0.

    With all the evidence around that when Raid 0 fails on 1 drive you can lose EVEERYTHING why on earth would you put stuff you value there?


    Why wouldn't you use a 500 mirrored?

    edit: if you work for any Government agency anywhere then say so and I will completely understand. :)
  17. Ysman

    Ysman TS Rookie Topic Starter

    Well the Fantom Drive 1TB was the cheapest external available on Newegg.com, and most the data I put on there was mutlimedia. There is a way to take the drive off Raid 0, but I hear its kinda complicated for the average user.

    Anyways, I can basically recover everything off the drive, but the drive sometimes refuses to let me take stuff off using File Scavenger. Its completely random. One time I pulled off about 100 or so gigs of data. Took an hour or so break, tried to transfer again, and it wouldn't let me. I even tried to pull off data I already recovered previously and it wouldn't let me, which leads me to believe that there are really no bad sectors. Purhaps it is the enclosure which is faulty after all. I turned the drive off, turned it upside down and then it worked afterwards....
  18. Ysman

    Ysman TS Rookie Topic Starter


    I've successfully pulled approx. 95% of the data off the corrupted drive using File Scavenger 3.2. The drive would not format in Windows XP, so I tried using a program called G-Parted. I've used this program in the past when dual booting XP and Vista, and I would recommend it to anyone who wants to safely and easily set up partitions on their drives. The current version supports USB, therefore, the external drive was recognized without a problem. G-Parted deleted the partition and did a default quick format. However, when I tried to check the drive using the software, it would not pass the "Fill Partition" test.

    I'm currently doing a FULL format in XP, and so far it is looking good. I suppose the last tests would be to run CHKDSK (and purhaps SpinRite6) on the drive a few times and see if it passes cleanly.

    UPDATE 2.

    I tried doing the full format, but when the format reaches a certain point, the drive disconnects and then reconnects, canceling the format. Purhaps a certain part of the drive is bad? It's odd how G-Parted formated the drive successfully in NTFS, but the drive disconnects in Windows...

    Does anyone know if a Zero-Fill will correct this problem?

    UPDATE 3.

    Ok so after trying to format the drive, the drive reverted to the RAW format, reporting it as being 0 bytes. So I used G-Parted again, and after deleting the partition I selected the option to "Restructure Partition" and I selected msdos. I then created a new NTFS partition. Instead of trying to do the full format in Windows XP (since the drive is coming up as NTFS with the label I selected), I'm currently trying to CHKDSK the drive and it is about a quarter way through Phase 5.
  19. tkr3alm3r

    tkr3alm3r TS Rookie Posts: 29

    if the enclosure is faulty, then heat dissipation would be an issue
    try cooling/short of sticking the drive in the fridge and try do a reformat
    if that works, there has been known issues with the drive heatsink/controller board overheating and causing drive spin failure in Fantom manufactured drive, specially being in STRIPE RAID 0 configuration
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...