External HDD shows as local disk F & it cannot be accessed

By Starky
Oct 18, 2012
Post New Reply
  1. My iOmega 1 TB External hard drive stopped working after it was accidentally unplugged. I googled the problem & found the exact thread here for my problem.
    When plugged in, instead of being identified by it's name as before it's listed as Local disc (F).First I tried disabling write caching, to no avail so...
    I followed the instructions I found here to the same problem started by fish778 in Aug 2011, Mark56 replied several times giving good instructions which I have followed but my problem isn't solved. I downloaded Sea Tools for Windows & ran both Short & Long tests which both failed.
    The hard drive when dismantled is a Seagate Barracuda 7200.12 1TB & my PC is Windows Vista Home Basic, Service Pk 1.
    The HDD has much loved photo's of my kids & tons of video & music too is there any way to retrieve it now or is it a hopeless case.

    Any help would be very much appreciated, I think maybe if possible to get any data now, I would have to take it to proffessionals but don't want to get ripped off if the drive is totally broken.

    Thanx so much if u can help @ all :)
  2. Doctor John

    Doctor John TS Enthusiast Posts: 200   +15

    You could try going into disk management and deleting F: drive, while the External HDD is unplugged, then try reconnecting - OS might have just assigned the drive incorrectly?
    Also strongly recommend updating to SP2 if possible (probably not connected to this issue though).
    Hope this helps. :)
  3. Starky

    Starky TS Rookie Topic Starter

    Thanx for the help.
    F: Drive is only there when external HDD is plugged in to laptop.
    I'm going to download SP2 now, I need it!:)

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...