File recover C attribute lost - how can I restore attribute

By vizion
Mar 15, 2009
  1. Hi

    I am a newbie here and would appreciate some help. I had serious trouble with one of my hard drives due but managed to recover most of the files on an NTFS 1TB drive (win XP pro 64bit).
    However one directory appears to have corrupt files. Probing deeper each file is very slightly smaller than it should be(the files are are psd or CR2 which are already quite compressed). I then realised the files had been recovered from a folder in which the files were automatically compressed. (I have a few of the files duplicated elsewhere on the drive and they all recovered correctly but were in a directory which was not compressed.However the faulty recovered files do not have the C attribute set.

    My guess (and it is only a guess) at this point is that if I were to reset the C bit for each of the files in this directory I may have a chance of recovering them all. My problem is I do not know how to set the C bit without otherwise changing the file contents. Can anyone point me in the right direction so I can see if my guess is accurate.

    I tried using the attrib +C [filename] but the response was the +C switch was invalid. I believe I have seen it used but is that only from the recovery console? Do I need to do something to enable it to work from the command line?

    Alternatively how can I run decompression on a file that does not have the C bit set!!!

    Thanks in advance for any help

  2. vizion

    vizion TS Rookie Topic Starter Posts: 17

    Just to add to the information. I tried adding the C attribute by logging on from the recovery console after having put a few example files onto the root partition of a drive.

    attrib +c [filename] did result in the properties showing that the file was enabled for compression.
    When I tried to load one of the CR2 files that had had the attrib +c the file was still corrupt. I ran an expand command on the file. The size of the file did not alter but interestingly the expand command did not complain about the file.

    Now what I do not know is whether that proves whether the corruption is something other than a compression file recovery issue or I have taken the wrong route in trying to resolve a compression issue!!!!

    I feel I am poking around in the dark.

    Does anyone happen to know where I can obtain a definition of the *.CR2 file format?? That way I could at least see what may be missing!!

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...