1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Flash drives not being allocated drive letter and cannot access

By Jen1961 ยท 5 replies
Mar 31, 2012
Post New Reply
  1. Hi. I'm hoping someone can help as I've spent many evenings on this problem and getting nowhere!

    When attaching a flash drive:

    1. The autoplay pop up doesn't appear;
    2. The device does light up initially;
    3. The device doesn't show up in "Computer"
    4. The device doesn't show up in Disk Management - just Disk 0 (system reserved, C: and I:) and 0 (CD ROM)
    5. The device appears in Device Manager under USB controllers as a storage device but I can't access it.
    6. This happens with all memory sticks and occasionally with ipod etc.. but sometimes for no apparent reason they work! All devices works ok with other computers.
    7. 9 times out of 10 plugging in a device or turning on the USB attached printer will cause the computer to BSOD, usually with IRQL NOT LESS OR EQUAL 0X0000000A
    8. Devices are never allocated a drive letter.

    The only thing I can think of is that I repartitioned the external hard drive (which I attach to back up) which may have confused the computer with driver numbers? Possibly?! But this problem doesn't seem to have stemmed from then. And I did fiddle with the System Reserved drive as I had back up issues and one of the solutions was to rename it, then I renamed it back again (I think).

    Sorry if I'm vague on this but I'm not at all computer savvy and the kids are trying to access their homework on the memory sticks!

    I'm running Windows 7 Home 64-bit, Avira anti virus and the computer is about 6 months old, working ok until a month ago. Can't think that we downloaded anything about the same time as the problem started but possible. I've tried to update all drivers that I can think of but the only one that needed doing was the Nvidia GeForce 7025 which was outdated. All devices etc say they are working properly.

    Anybody got any ideas? But keep it simple if poss please! Thanks.
  2. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 376   +8

    Have you tried Uninstalling the Mass Storage Device that shows up in Device Manager? sometimes reinstalling it can fix issues like this.

    Do they work properly after a fresh restart?
    Do they stop working after being in standby/sleep?

    Other suggestion would be to reinstall Chipset Drivers and USB Drivers if your motherboard has seperate USB Drivers (Generally only for 3.0 boards)
  3. Jen1961

    Jen1961 TS Rookie Topic Starter

    Hi. I thought I'd solved it last night by uninstalling the device, rebooting and then plugging in the memory stick - it recognised it and assigned a drive letter! All ok! But then... tonight my daughter tried to plug in her phone and it wasn't recognised anywhere, Device Manager (under any of the drop downs), Disk Management or searching for plug and play devices. As it wasn't recognised anywhere there was nothing to uninstall.

    And I just thought I'd check the device that was recognised last night - plugging it in to the usb port just now caused the computer to crash with IRQL NOT LESS OR EQUAL.

    So - I seem to have got nowhere ..again!

    Not sure what chipset drivers are. I've updated the driver for the Nvidia GeForce 7025 which I think is the motherboard? And I have USB 2.0 ports.

    There seems to be no pattern to the usb ports not working.

    I think the computer is still under warranty, but only for parts and labour not "collect and return" but perhaps there is something majorly wrong do you think?

    I'm posting this now as I'm going to try and plug a usb device in again and see if it bluescreens after being rebooted and not in standby!!
  4. Jen1961

    Jen1961 TS Rookie Topic Starter

    Yup it blue screened again! This time after restarting the computer and not having been in standy or sleep mode at all. I did notice, just before the computer crashed that the device was in Computer as drive E: when usually it's allocated F: When I tried to open it that's when the computer crashed.

    Any ideas?
  5. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 376   +8

    If it is still under warranty for parts I would send it in. This could be a faulty MB, RAM, or Powersupply.

    MB: Blue screening when connecting USB devices, mainly storage devices. Could be blown capacitors on the MB, I had 2 motherboards at work where they would just shut down as soon as I plugged in a USB stick. Turns out they had blown capacitors and I assume it was this that was doing it as replacing every part (other then MB) didn't fix the issue, same with a reinstall.

    RAM: IRQ not less or equal is generally a RAM issue, just seen it many times, but you would have this happen more often then just when connecting USB Devices:

    Power Supply: The power supply is failing to supply enough power to the device when it gets plugged in, it requests a decent amount of power at first pluggin.

    OS: Could be a conflicting software/driver or something.. Anything new that got installed since this started happening?

    Lastly, BIOS: IRQ #'s are distributed to hardware devices that give it a request number. These numbers are used to tell the processor what hardware is requesting it's attention. Generally these are automatic and people do not have to worry about it, but it is possible that your USB Devices are requesting to have an IRQ # that is in use by another piece of hardware, or taking it automatically, and causing the computer to blue screen due to this, an IRQ number can not be separated by 2 devices, but it can happen>

    Your best bet is to bring it to a local shop, as it could be hardware, if you have warranty it is covered.. If it is windows.. They can't cover that, but at least you may know.


    Hey Jen, perhaps you've resolved the issue you were having, but just in case you haven't I came across something that I solved USB issues is was having. Although my problem was of a slightly different nature, it may help you out as well. In any event there is so little involved that it can't hurt trying it.


    Hope this helps, in the event that you are still circling to find a solution.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...