USB drive or flash problems? How to cleanup and remove old USB storage drivers


Posts: 6,429   +186
USB Drive or Flash Problems? How to Cleanup and Remove Old USB Storage Drivers

USB Mass Storage devices include:
* External hard drives and optical drives, including CD and DVD drives​
* Portable flash memory devices​
* Digital cameras​
* Digital audio players & portable media players​
* Card readers​
* Portable gaming systems​
* Mobile phones​
One possible cause of USB Mass Storage Device problems: Windows can get "confused" by all the old (and sometimes conflicting) USB storage driver data that tends to collect and remain installed on a PC

Here's why: By default, Device Manager only displays drivers of connected devices so the drivers you see in Device Manager aren't the only USB storage drivers that are really there! You probably still have drivers installed for devices you once connected then disconnected long ago!
  • Windows installs drivers for a USB Mass Storage device when you first plug it in to a port
  • Windows sometimes installs the same driver for the same device each time you connect it to a different port!
  • Problem is
    ==> These drivers aren't uninstalled when you simply unplug the device but only when you uninstall the device (or each device instance per port)
    ==> Driver data associates devices with drive letters and ports. Port and drive letter conflicts may occur as you start unplugging/replugging devices
You may be surprised at just how many old USB drivers are actually still installed on your machine!

Steps to Safely Cleanup and Remove old USB Mass Storage Drivers on your PC
  1. Shut down your computer. Unplug your USB storage devices: USB Disks, flash, cams, CD/DVD, etc. as well as your USB hubs
    ==> Other USB devices like keyboards, mice and LAN adapters can stay plugged in
  2. Boot computer back up. Click for how to determine whether you are running 32 or 64 bit Windows
  3. Download, unzip and save to your desktop. Move the 32 or 64 bit version of DriveCleanup.exe to C:\Windows\System32
  4. Open an elevatedcommand prompt window:
  5. In the command prompt enter: drivecleanup.exe
    ==> Your output should be similar to my example below.
    ==> If, instead, you get an error message like Command not recognized it means you didn't move Drivecleanup.exe to the right directory
  6. Reboot. Now just replug your devices for fresh clean device reinstalls! :)
DriveCleanup V0.7.0 (Win32)
Uninstalls non present storage volumes, Disk, CDROM, Floppy devices
and deletes their registry items
Freeware by Uwe Sieber -

removing USB device 'USB\VID_0000&PID_0000\7&2285BC2A&0&1'
removing USB device 'USB\VID_0411&PID_00A2\WDC_WD2500_____WD-WCANKE590248'
removing USB device 'USB\VID_0BB4&PID_0C02&MI_00\6&2DD32CD2&1&0000'
removing USB device 'USB\VID_1058&PID_0702\575845313037453632383432'
removing USB device 'USB\VID_1058&PID_0702\7274787265616E206C2E3132'
removing USB device 'USB\VID_1058&PID_0702\F53A39F2AB75F5CDC4B6ABC3'
removing Disk 'USBSTOR\DISK&VEN_HTC&PROD_ANDROID_PHONE&REV_0100\7&1012C922&1&HT9A2HF00558&0'
removing Disk 'USBSTOR\DISK&VEN_WD&PROD_1600BEVEXTERNAL&REV_1.02\575845313037453632383432&0'
removing Disk 'USBSTOR\DISK&VEN_WD&PROD_N_EXTEREXTERNAL&REV_1.02\7274787265616E206C2E3132&0'
removing Disk 'USBSTOR\DISK&VEN_WDC_WD25&PROD_00JS-00NCB1&REV_\WDC_WD2500_____WD-WCANKE590248&0'
removing volume 'STORAGE\REMOVABLEMEDIA\8&3152D400&0&RM'
removing volume 'STORAGE\REMOVABLEMEDIA\9&29B6E3D1&0&RM'
removing volume 'STORAGE\REMOVABLEMEDIA\9&BC53371&0&RM'
removing volume 'STORAGE\VOLUME\1&30A96598&0&SIGNATURE44FDFE06OFFSET7E00LENGTH2543150400'
removing volume 'STORAGE\VOLUME\1&30A96598&0&SIGNATUREC12C6F64OFFSET7E00LENGTH3A388A8400'
Regkey delete HKLM\System\MountedDevices\\??\Volume{91a9bc60-2535-11df-b96f-00256495135f}
Regkey delete HKLM\System\MountedDevices\\??\Volume{91a9bc61-2535-11df-b96f-00256495135f}
Regkey delete HKLM\System\MountedDevices\\??\Volume{dce40c14-30ad-11df-b973-00256495135f}
Regkey delete HKLM\System\MountedDevices\\??\Volume{d4227929-32c8-11df-b97c-00256495135f}
Regkey delete HKLM\System\MountedDevices\\??\Volume{9827b60e-34f1-11df-b983-00256495135f}
Regkey delete HKLM\System\MountedDevices\\DosDevices\Z:
Regkey delete HKLM\System\MountedDevices\\DosDevices\H:
Regkey delete HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2\H
Regkey delete HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2\Z

Removed 6 USB devices
Removed 0 USB hubs
Removed 5 Disk devices
Removed 0 CDROM devices
Removed 0 Floppy devices
Removed 5 Storage volumes
Removed 9 Keys from registry

Last edited:


Posts: 258   +2
mods move post to Guides and Tutorials

this was great just one small Edit though~
@ the command prompt type drivercleanup.exe otherwise you'll spend an hour and forty minutes like I did looking for the missing file :)
My USB stick modem, works so clean-n-fresh now thanks LookinAround great post :biggrin:_:thumbsup:


tidbit: the run->xxx feature relies upon the %PATH% variable to find xxx. That's why
moving xxx to system32\ works.

If you would like to keep your tools elsewhere, say Downloads\Tools, then here's how to
get any program to launch (assuming you've already moved xxx to that folder)

Using an admin login (or right-clicking on the command prompt shortcut->RunAS)
you can launch xxx with
cd Downloads\tools
the leading .\ says "find xxx" in the current directory :)
Ok I only joined this board to tell you
Thank you so much! I had been searching for a solution forever and every solution did not work until this one! Thank you!


Posts: 6,429   +186
Hi SgtCottonBalls :wave:

And welcome to TechSpot! And thanks for taking the time to post your good results! I'm glad to know the Guide could help.

Happy Computing!@
thank you

I have registered in this board to thank the autor of this post

i had an usb device malfunctioning ( a portable hard drive that powers only by usb )

it was working in all the computers except one of them and was some kind of corrupted driver file

thanks it solved my problem now (windows 7 32 bits)
Hi there, I have had a similar problem to this. I bought a Sandisk Cruzer blade 4Gb flash drive, and it works on my home PC, but not on my work PC. Both are runnning Win 7 Pro 64bit. When I plug the flash drive into my work PC, Autoplay pops up with all the same options, and the drive is visible in My Computer (showing the name that I gave it on my home PC), but I cannot see any of the files on it, or copy files to / from it. When I open properties, it shows Capacity: 0 bytes, used space: 0 bytes, free space: 0 bytes.

I have tried your solution, and 25 old usb drivers were removed, whereafter my flash drive re-installed its own drivers, but its still not working.

I have tried the flash drive in 3rd PC, and it works fine, so it must be something wrong with the USB ports on my work PC (HP laptop) Any ideas?


Posts: 6,429   +186
Hi Jeffrsnapln

Wish i had a good answer for you as you've already tried the drivecleanup tool.

Just a general comment: While those SanDisk flash drives are handy (I have a couple Cruzr's myself) they also seem to be fragile/problematic as many people post problems with them online. So best be aware and just use it for temporary storage and file transfers and not rely on it for backups.

That said, only other things i'd suggest (and these are just guesses/things to try). There's sometimes a power issue with these SanDisks (which must draw their power from a USB port)

1. Is your laptop plugged in when you plug in the SanDisk?
2. It's a long shot but this trick has sometimes helped: Shutdown laptop, unplug the USB, remove laptop battery and unplug laptop AC power cord. Let the machine sit for an hour. Then plug things back in and boot up and retry
3. Try using a "self-powered" USB hub (buy an external USB hub that has its own AC power supply)
4. You might also see How to Reinstall USB Controllers and Motherboard Chipset Drivers

Sorry can't be more helpful. But let us know if you should find any solution

/* EDIT */
You might also try unplugging any other USB devices from the computer you don't really need attached - just to see if it makes any difference
Just found this forum discussion yesterday. My problem seems to be related to a generic volume driver that was somehow corrupted when I tried to download pictures from a Samsung camera recently purchased. Have run the Drivecleanup but the same message error "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)" when I plug a device in again. I have 3 flash drives all of different manufacture, so I am pretty sure it is not a drive problem. The Disk Manager sees the drive but not allow access to it- calls for a refresh or reboot which doesn't solve that issue. Any suggestions??
Found and removed a lower filter. Problem still exists--attached. Am I correct in thinking that doing a system repair will not drill down to these drivers?


  • scrn4.jpg
    96.1 KB · Views: 24
Don't recall how or where I found some driver sets that appeared to have been installed late last year. Unfortunately my restore points do not go back that far. Have been talking to Samsung, so far they are not able to tell me how just connecting their camera to my computer is causing this problem, altho the first contact said this particular camera was not compatible with Win 7 64bit.
Is there any way to access the software that controls the Storage volumes and replace them?


Posts: 6,429   +186
This is just a guess but let's see where it takes us.

There may also be filters installed for "Storage Volumes". (The Guide you followed before was for "Disk" filters). I'd like to see what is listed in your registry for Storage Volumes but do NOT delete anything yet. If you could just take a snapshot i will look at them first.

If you follow the same procedure you did earlier to open an elevated command prompt. Then this time copy/paste the regjump command below into the elevated command prompt window
regjump HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{71a27cdd-812a-11d0-bec7-08002be2092f}
Don't delete anything, just take snapshot please. (p.s. It may take me a couple days before i have a chance to reply back to you again)

/* EDIT */
btw.. i just happened across your post in the Windows Sevenforums HERE which was also helpful. I can explain what i'm looking for in your registry list of Storage Volume filters. The question is if you have an upper or lower filter appear in the registry which is NOT also listed (and/or not found) when you view the Generic Volume in Device Manager->Driver File Details. Because if the driver filter filename appears in the registry but the file doesn't exist on disk you can get the code 39 (because Windows then can't start the driver because the file is not found). But, again, for this case don't delete anything on your own. Let's just check first


Posts: 6,429   +186
registry shot attached-hoping this may get us somewhere!!
Based on your registry snapshot, I found one more thing you can try. It looks like you have (or had) Acronis True Image installed?

The two Lower filters (fvevol and rdyboost) in your registry are from Microsoft. (And i find them on my Win 7 system as well). The Upper Filter (tdrpman) is part of Acronis True Image. Try this

1. Create a System Restore point first
2. Delete only the UpperFilter from the registry to remove the Acronis filter driver
3. Reboot and retest

In any case, after reboot/test i'd also uninstall then reinstall your Acronis True Image since we removed an Acronis filter (which might have been corrupt/still needed if you use Acronis). I'll keep my fingers crossed!
THANK YOU, THANK YOU!! I was wrongly ignoring the possibility that Acronis was the culprit being unsuccessfully uninstalled a few months ago. Strange it seems, that a problem showed up now. However all seems well now and I really appreciate your help.
Thanks again


Posts: 6,429   +186
THANK YOU, THANK YOU!! I was wrongly ignoring the possibility that Acronis was the culprit being unsuccessfully uninstalled a few months ago. Strange it seems, that a problem showed up now. However all seems well now and I really appreciate your help.
Thanks again
You're most welcome! Glad to hear the good news and happy to have been able to help :)

I just wanted to say thanks for this walk through. I was having the same issue with my flash drives where Win7 docks them but doesn't install them. :confused: My WD external HDD, Rosewill Webcam, Wacom Intuos4 tablet all installed without issues on a new install. Win7 just wouldn't recognize my flash drives. Now everything works great. Thanks again. :D
To LookingAround


I have exacrly the same problem with Windows7. My problem is interesting because I could never get any imaging device working on my laptop since I upgraded my machine to Windows7. While iPhone syncs with iTunes, I can never see the Pictures folder in iTunes on my computer. Nikon D60 apprears as "Nikon D60" under "Other Devices".

Your postings interested me as I think there are some ghost imaging drives on my machine.


Posts: 6,429   +186
Hi Pankajsingh

And welcome to TechSpot!

I’ll take a look and see if i can help. But when you reply next, could you please start a new thread for your specific problem in the Software and Utilities forum? Click HERE to go to the forum then click Forum Tools->Post a New Thread (Tho your symptoms sound similar I suspect you have different issues then those in the current thread so I prefer to keep your issues in a separate thread. Thanks! :) )

So. in the new thread

1. Could you elaborate on your statement
While iPhone syncs with iTunes, I can never see the Pictures folder in iTunes on my computer.
> Can you see pictures in other folders? Or is viewing pics only a problem with your iTunes folder?
> What happens and what error message occurs when you try to see pics in the iTunes folder?
> Are you just not able to view pictures? or you mean you can't see the folder itself???
> Have you tried uninstalling then reinstalling the latest version of iTunes?

2. What's your computer make and model?

3. List any Problem Devices
  • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
  • Click Problem Devices. Anything appear?
  • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
  • On the other hand, if no devices are listed, tell me so

I'll look for your reply in the new thread

/* edit */
P.S. For background for anyone else who may also read your new thread after you create it, it would also be good if you copy/pasted the info you supplied in your first post as well
Hey Lookingaround,
I googled this problem and found this post. I have the same problems; however I'm on a computer at work and the admin has locked me out of the system registry and the disk manager. We have networked drives mapped and the external hard drive wants to take one of the mapped drive letters. I used the drivecleanup tool and it can’t remove the old usbs. Do you know if there is a way to rest the usbs? The drive at one time mapped ok, but since then I have plugged in a flash drive and my phone which took those drive letters. I would ask my admin to assign a drive letter but this is government work and don’t want them to know. Thank you for your help.


Posts: 6,429   +186
Hey Lookingaround,
I'm on a computer at work and the admin has locked me out of the system registry and the disk manager.
I would ask my admin to assign a drive letter but this is government work and don’t want them to know. Thank you for your help.

Hey antantaeus75

1) I don't know how one would try to circumvent their sys admin's controls
2) But even if I did know, i still couldn't help you because someone shouldn't be trying to circumvent their system admin's control

Admins are there for a reason. Plus the computer belongs to the employer. Employers limit control/access to admins for a reason. You need to talk to your admin