freaky chkdsk..

By NeoION ยท 90 replies
Mar 30, 2003
  1. One of my mates drives was giving him loads of jip about not being able to delete files cus it wasnt there or the folder was empty etc etc, he ended up reformatting which sorted the problem but its happening again. I have sorted his NTFS permissions out so thats out of the equasion but everytime you run chkdsk it comes up with this error. I had a quick scan on google and it didnt come up with anything usefull so thought I wud post here. Im unsure what a orphan file record segment is ;)

    Any help wud be apreciated :)
  2. Tarkus

    Tarkus TechSpot Ambassador Posts: 621

    He's getting data corruption on his drive(s). What motherboard, drive configuration and drives?
  3. NeoION

    NeoION TS Rookie Topic Starter

    Abit KX7-333 Raid Mobo Bios version B6 Raid 2.32

    on the Raid IDE ports Primary is 2 x 120 Gig IBM Secondary is 2 x 200 Gig Western Digital JB drives
  4. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    It is very important you check your memory before you run chkdsk again. I've had smiliar things happen, and every case has been the fault of memory.

    You can download a thorough memory tester at The direct download link for the Windows version is

    It makes a bootable floppy disk (May appear to be blank if you view it in windows). Basically, just boot from the floppy and it will run the default tests on your memory. It might take a half hour to 2 hours, depending on how much RAM you have and how fast your system is.

    If you have the time and the default memory tests come up okay, I recomend the full tests. They might take a few hours to complete though.
  5. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    I've had this problem before, and it was corrupted IDE drivers. But the RAM being at fault is also a possibility.

    Basically, chkdsk is mistakenly finding what it thinks are problems. But instead, its actually causing data corruption. One sweep with that will be enough to destroy the entire partition if you are not lucky.
  6. Mr BooM

    Mr BooM TS Rookie

    OK here is the latest update.

    The board in question is mine and has been workin fine for some time with 4 x 120 GB IBM Drives on the Highpoint 372 Raid Controller.

    I have recently purchased 2 x 200 GB Western Digital JB drive which have been put on the secondary port of the raid controller.

    Both drives are only a week old the the Secondary Slave keeps wanting to rubn chkdsk on boot.

    I have the latest Bios for the Mobo and have changed all the IDE / Power leads.

    I have also ran the Western Digital HArd Disk checkin program which says that both drives are fine and do not have any errors.

    Still get the same problem. I ran the memory checkin program for about 8 hours today and it got to test 18 before i turned it off. I hasten to add that it passed all the tests so far.

    Really have no idea what else it could be. I have a new raid bios which I ma gonna install.

    Any other suggestions would be appreciated.

    Mr BooM
  7. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Located in Master File Table, references to files or directories that no longer exist.

    Have you (accidentally) deleted some thousands of files from the partition? Just wondering because in that chkdsk log, it's deleting references to files / directories 17784 to 18687, yet there are only 16758 files. Do these numbers vary when booting?
  8. Mr BooM

    Mr BooM TS Rookie

    No m8 those seem to be the same everytime the PC boots. Deletes the same fiels exactly.

    Mr BooM
  9. Justin

    Justin TS Rookie Posts: 942

    Adding to what was stated earlier, most people don't realize that software error repairing utilities mean nothing if the hardware itself is to blame! If you are consistently getting anomalies for no real apparent reason, before continuing slews of repairs on your system, ensure that your hardware is operating perfectly. It is very worthwhile to invest in hardware stress/test utilities, and most of them can be obtained for free.

    One in particular I like is the FixIt Utilities Suite which comes with a very thourough hardware diagnostics utility... they recently were purchased by a different company, but the last version they release, 4.x smth, was quite effective in helping me isolate bad hardware.
  10. Tarkus

    Tarkus TechSpot Ambassador Posts: 621

    four drives plus ? CD, DVD and or CDRW? I hope you have a stiff PS to run that all.
  11. WibbleFish

    WibbleFish TS Rookie

    hello, i know this thread is very old, and i know im very new here :) .....

    but its so similar to my problem, i am praying for the miracle of this thread starter still reads the forum, or others have had (and solved) similar problems..... this has been annoying me for months now, and i have lost well over 500 gig of data so far trying to fix it many times :(

    anyway, here goes......

    i have a highpoint RocketRaid 133 controller and several WD hardrives used in it, in the following config:

    1) 2 X 120 gig WD drives at raid 0 plugged in primary: master and slave as a system drive

    2) 1 X 180 gig WD drive plugged in secondary master as a storage drive

    i consistenly get lots of orphaned files every few reboots wen chkdsk kicks in (wether it runs on its own or i schedule a check)

    i have narrowed the problem down to being *SOMETHING* to do with the LBA support for large drives, +137 gig barrier, as smaller drives dont do this. but i have tried everything to try and stop this... hundreds of hours of googling etc, but to no avail, everytime i think its sorted, because no files gets corrupted, it just happens again, sometimes the files orphaned are saved to the "found" directory but often its a few chunks from .avi's etc, so the whole files are lost forever :(

    i dont know what details to give, because i have no idea wot the problem is , but i will list the obvious things i have tried, from various google results.

    1) the raid card bios is the same version as the drivers

    2) i have windows xp with sp1, and have checked my atapi.sys version is correct, from from this article

    3) i have enabled the reg key for testing, just in case it helps, also from

    4) the hard drive and raid card seem to be 100% ok, as i have tried the drive on someones elses PC, that has LBA support on his motherboard IDE controllers.
    and smaller drives (under 137 gig) work on all ports.

    therefore im sure its something to do with windows, i use XP with sp1, but i cant for the life of me work out what the problem is.... next system format, im just going to partition the 180 gig drive to 120 gig, and forget it ever happened... but it has stopped me buying any more big drives, which i can really do with.
    i want to use 4 X 200 gig drives on this machine eventually as its my server

    anyway as i said, i just stumbled across this forum and post today, so its kind of my last hope before i give up and take the easy way out, partitioning a 1/3rd of drive out...

    i apoligise for dragging an old thread up, but as you can tell, im desperate

    *EDIT* typo's and gibberish removed
  12. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Does this happen if you install Windows 2000 (sp4) on the machine as well? What I mean is, have you tried other operating systems?
  13. Nic

    Nic TechSpot Paladin Posts: 1,549

    Go to the HighPoint website and download the latest bios/drivers for you card ...

    HighPoint RocketRAID 133

    Revision 2.35 is the latest and the bios update is included with the drivers.
  14. WibbleFish

    WibbleFish TS Rookie

    hi there...... thanks for the replys

    i havent got any other O/S to try im afraid, spend all my penny's on XP wen i upgraded from 98se last year.

    and i have the newest drivers installed (i have tried all versions as they come out)

    apparently its important to make sure the bios version and driver is the same version number, so i have made sure that was the case with every upgrade as well :(

    im sort of beggining to suspect the something else dosent like the raid card, and is casuing the problems but the fact the its only on large drives (over the 137 gig LBA barrier) that really says its the card or the drive to me...... but no-one will RMA them as they dont show any faults :(

    i have all the updates installed to XP as well

    thanks again for the feedback
  15. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Have you checked your memory? I'v had the exact same problem before and it was because one of my memory modules went bad.

    If you have multiple memory modules, try each one and see if the results differ. This may be quicker than running the memtest.
  16. Nic

    Nic TechSpot Paladin Posts: 1,549

    If he had bad memory, then everything would be affected, and not just writing to hard drives larger than 137GB.

    Check your mainboard for the latest bios, and download hard drive test tools from the manufacturer's website. Run all the available tests. I would tend to suspect a defective hard drive, or IDE cable, at this point.
  17. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Its possible that you have found a problem with the device drivers that hasn't been fixed by the company's development team yet. If possible, you should try to report this to them somehow. They might suggest a fix, by sending you updated files or something. Believe me, this can happen. But its more common in an open source universe like in Linux.
  18. Nic

    Nic TechSpot Paladin Posts: 1,549

    I'd have to say that this would be unlikely, as the same drivers are used to write to all the hard disks on that controller, regardless of hard disk size. If only one drive is showing problems, then the issue is most likely due to the hard disk itself, or its connection to the controller/cable. Just my opinion.
  19. WibbleFish

    WibbleFish TS Rookie

    thanks for the continuing help :)

    right , i never actually thought of my mobo bios, as i wasnt using the onboard IDE ports, but i will now go and hunt around for an bios update, and see wot happens.

    i have downloaded that memtest and will run that overnight, to check for errors, i havent had any blue screens are bombs though, so i *think* the memory is fine, but cant hurt to check it.

    i have run several drive diagnostics programs on this drive before now, and it always comes up as fine, and the currpted files are so wide ranging (a few chunks out of like 30 files at a time)i cant see how it is the drive as it always runs chkdsk fine (well physicaly anyway)
    also i have lent the drive to someone eslse who's motherboard supports large drives, and he didnt come across any problems, of course that could be co-incidence, i have run it for a *few* days with no probs... .then i lose yet more data :(

    i was thinking a while ago that is was some sort of virus, but no anti-virus or trojan programs detect anything

    i have been into contact with highpoint before, via email, and explained the problem, they suggested several things which i have tried, but it was mostly basic stuff, like runing the WD diagnostic tool, and scandisk, etc, nothing came up with any errors, nor did it fix it.

    i have swopped the 2 IDE cable over (between IDE 1 and 2) but same problem, how likely do you think it is that it could be the cable, even tho i have tried one other from the ame batch) becasuse they are quite cheap so i could buy one to try, i never considered that before either, i have to admit, as i had tried the other one, but i spose it could be a bad batch??...

    i havent felt keen to spend more money on this, as its wound me up quite enough already, but a few quid if its a reasonable chance is ok.

    wot do you think?

    p.s thanks again :) . is the desperation obvious?
  20. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Since it only happens with the 137GB thing, I doubt it is memory. I overlooked that bit of information. :) Worth a shot though!

    Be careful when running chkdsk, as it is deleting your files.
  21. Nic

    Nic TechSpot Paladin Posts: 1,549

    That is exactly why you are not finding any faults when you run diagnostics - you have an intermittant problem that isn't playing up when you are running the diagnostics. The only way you will catch that error, is when it becomes a hard failure, and remains in the fail mode.

    I am still inclined to believe that your hard drive is the issue here, so I recommend running the maker's diagnostic tools (run all tests) several times in succession, to see if any errors show up. I can't think of much else you can do right now, but maybe stressing your drive by repeated testing, will cause the errors to become more apparent. If you can get hold of a SMART monitoring program, and leave it active in your system tray, it will record any errors reported by you drive while in use. Then you can look at the history logs to see if any issues cropped up.
  22. tokr

    tokr TS Rookie

    I have the exact same problem with the same system... been trying to fix this for six months without luck...

    I have both a 200GB WD PATA and a 200GB WD SATA drive... both have the same problem... I also have a 120GB (Seagate) drive and two 80GB drives (WD) who causes no problems

    I have tried everything... and nothing works... tempted to buy a new motherboard... since the drives work fine on another motherboard.
  23. justkiddin

    justkiddin TS Rookie

    Check out this MSKB article, it sounds like your problem and has a fix.

    331958 - Hard Disk May Become Corrupted When Entering Standby or Hibernation or When Writing a Memory Dump
  24. tokr

    tokr TS Rookie

    sorry Had a look at it... but it does not really address my problem...
  25. tokr

    tokr TS Rookie

    I fixed the problem ... or at least I think so.. cannot force the error anymore...

    well the solution was simple enough... I wiped my harddrive clean and reinstalled windows... but this time I pressed F6 during setup to install the raid drivers before it installed windows at all... I also got Abit to make me a new bios (!?) with the newest HTP374 bios included... so after both the motherboard and windows started running on version 3.03 of the bios ...everything is sweet.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...