freaky chkdsk..

By NeoION ยท 90 replies
Mar 30, 2003
  1. Rick77

    Rick77 TS Rookie

    Man this is the problem I'm having exactly. And I also have 2 WD 200GB drives that are doing it. I have the latest Bios for the Motherboard and the Latest Hard Drive drivers and windows updates. I've Checked both drives repeatedly and they check out fine. Memory has been checked and it's fine. Bought new motherboard, power supply, video card, cables, and case, still same problem. No other drives (80GB or 100GB) have this problem, just the big ones. Sure could use some help here if anyone has any. I found this thread doing google search. This seems like a great forum. -- Rick
    I did find some info that might have something to do with this about folders with frequent file adding and deleting having this problem - but this is an older Windows NT post - not sure how this works with XP.
  2. tokr

    tokr TS Rookie

    do you have a via chipset? have you tried a different controller... maybe the two motherboards you had used same chipset?

    my problem has well and truly gone away...and it seems to be due to the bios for the chipset having having to be the same version as the drivers in windows.... and the drivers in windows (that were the same version as the latest bios) had issues... whilst the newest drivers (which had no bios equivallent) was ok.

    so they had to make a new bios... go figure.
  3. Jameson653

    Jameson653 TS Rookie Posts: 23

    we have established that it was not a memory problem...have we established that the windows itself is not corrupted. I have been wanting to go back to windows 98 because on 2000 and XP home and pro i have experienced problems similar to this. I have tried and tried and have now resorted to repartitioning and reinstalling windows on my computer every 6 months. I hate windows :( it seems like it is meant to corrupt after a year.
  4. Rick77

    Rick77 TS Rookie

    I think it might be an NTFS related issue

    I did try a different controller card. Have one drive on a controller card and the other drive on the motherboard. Both failed. The motherboard chipsed is intel. This is an ASUS board. There shouldn't be any problem with that. The previous board was a Dell. I never had this problem with 98 or with XP when I was using FAT 32. I coverted all my drives to NTFS because it seemed to be so much more efficient (512 culsters instead of 8k and 16k) but now I loose data all the time :-( I'm trying to recover some right now with Stellar Phoenix but a lot of files come out corrupted. Has anyone had this trouble with non Western-Digital drives? Seems to be a common denominator. WD large drive and NTFS. I have both Windows 2000 and XP dual boot system and have re-installed both from scratch after re-formatting. I didn't do raid driver install because I'm using IDE on board and IDE promise controller card TX 100.
    No - I don't have a via chipset. I remember reading about that. I wonder if it could be a similar problem though. I was wondering if it could have anything to do with windows 2000 using different file ID's than XP in the MFT. Anyone know anything about this? When recovering I found two files for each file and one had an ID in the 4k range and the other in the 8k range. Don't have a clue what that's all about hehe.
  5. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Sounds to me like NTFS has problems with over 137 GB IDE hard disks when not using RAID - or does it happen in RAID configurations too? Or like Rick77 said, only with WD disks?

    Somehow I guess whatever the reason is, Microsoft won't admit it's NTFS's fault :p
  6. tokr

    tokr TS Rookie

    I had the problem whilst I was running it of the RAID controller...

    I don't think it is anything to do with the 137GB barrier thing... cause I started corrupting the WD harddrive once I passed 100 or so GB... but the 120GB harddrives I had could be filled to the brim... but they are not WD.... hmm.

    .. it would be interesting if you could borrow an external cabinet, and place the drive inside there... and connect it to the USB port... that way, if it works... we should be able to conclude it is not a NTFS problem, nor it is a WD problem.... if it doesn't work on the other hand... we can conclude it is not a controller problem.
  7. Rick77

    Rick77 TS Rookie

    Question for Rick

    Hey Rick - when you were having the same problem was it also with only large WD drives above 137 GB? We all seem to have that in common. Also could a memory problem only affect large drives ya think? Man that memory check program takes a long time! hehe
  8. tokr

    tokr TS Rookie

    Re: Question for Rick

    Not me... cause it happened as soon as a drive reached about 100-110GB... not 137GB
  9. Rick77

    Rick77 TS Rookie

    Thanks Rick, tokr

    Thanks Rick, for that url for the memory test program. I ran that today for 10 hours but no errors were found. I guess that's good news and bad news hehe. And thanks tokr for that info. Interesting. I have two 100GB drives (WD) that never had any problems. It could have something to do with too many files maybe. Did everyone who had this problem have a lot of smaller files in the directories that got lost? I did find some interesting things on microsoft site about XP having a problem with large drives when computer goes into power management modes, I also found some interesting info about folders where files are frequently added and deleted in NTFS. But no solutions yet. Do you think simply partitioning the 200GB in two would help? Still researching.
  10. Rick77

    Rick77 TS Rookie

    Update - think I got it licked

    Again thanks for the suggestions guys, I thought I'd do a follow up post of what I did so any others who might be having this problem might solve it too. My setup is intel chipset and promise ata tx2 100 controller cards - I partitioned my 200gb drives in half- not sure this was necessary but figured it couldn't hurt, I edited the registry to increase the MFT reserved space on the drive - (this only takes place after you reformat however) here's the url for this info:;en-us;Q174619. I did this because the MFT reserved space is real small (16%) by default and increasing the size does not make you lose disc space - it just uses that space last. This keeps your MFT from being too fragmented when you have a lot of files or do a lot of deleting and moving. I then copied all the data from each drive one at a time to another drive and then formatted the drives using 4096 sector size NTFS. I also downloaded and installed the Intel application accelerator driver which seems to take place of the Atapi sys driver - So far no problems at all - Rick
  11. frawress

    frawress TS Rookie

    I thought I was the only one to have this issue. Thank God for the internet.

    Anyway, I just purchased a new 250GB Western Digital SATA drive last month. I have had nothing but problems with it. From the installation to the unusual sounds it makes booting up, to the problem of the checkdisk, it has been one nightmare after another. Here is my system configuration:

    WinXP Pro, SP1, fully updated
    Abit MB
    2GB PC2700
    ATI Radeon AIW 8500DV
    Sound Blaster Audigy 2
    120GB SATA (Seagate) *boot drive
    250GB SATA (WD) *storage drive

    When I originally setup the new WD drive, I partitioned it into a 120GB (F) and 130GB (G) drive. While I have RAID capabilities on my system, I am not using it. I move files back and forth between 3 different physical drives in 2 different systems because I do digital editing. I ran a full checkdisk recently, and got the "deleting orphan files" message during the procedure. At first, this didn't seem to be a problem. My files were still on the G drive (the 130GB partition). For some reason, every time I boot up, checkdisk runs on that partition. My guess is that it never actually finished, who knows? However, yesterday it ran checkdisk again, and when I went into My Computer to access the drive, there was nothing there. The drive showed that 50GB of it was used, but there was nothing in the drive!!! I tried exploring the drive; there was nothing there. And yet it shows that space is being used. I have not really backed up this drive, because this IS my backup drive. I have 6 months worth of video projects on this. My first concern is data recovery. My second concern is what to do about the drive. Any help is greatly appreciated.

  12. Errata

    Errata TS Rookie


    I just ran into this problem today. I have a brand new Maxtor 160gb HD. I'd just filled it up to about 110 gb and started having problems so I rebooted. Chkdsk starts running and starts deleting everything. The drive was formatted as a single partition using NTFS.

    I was wondering if anyone has recovered their data and what programs they used. I was also wondering if anyone has run into this problem using Fat32 or if this is an NTFS problem only.

    This is strange because I've been using a 120gb with no problems and this drive is only three weeks old. Anyone got any solutions?

    I'm using Windows 2k Pro Sp4 with an Intel P4 system.

    Any help would be greatly appreciated.
  13. semi

    semi TS Rookie

    I got same problem as most of us here...

    I bought new 160 Maxtor less then month ago. Today morning I started to have some problems with it, one directory said "Directory is corrupted and cannot be shown" (or something like that).
    I started to browse if other directories are also corrupted, yes some were but some was working.

    I thinked if reboot would fix it. I rebooted system and answered NO when Windows wanted to run ChkDisk on my system.
    (Btw, that disk was my H:-drive, so no system on it)

    Well, windows didn't saw any filesystem on it, windows just told me that filesystem was "RAW", so it was unreadable.
    I was forced to reboot, and I did allow chkdisk to check it.

    Can someone guess what happened? Yep, "Deleting orphan file ....." And 7GB of data is left of 130GB ... Can someone guess if I have any backups? Correct again, no I don't.

    Well, I was quite pissed because that really is not HARDWARE failure, I'm REALLY sure about it. I called to Microsoft support today.

    Microsoft opened new case, and after few hours they called me back, we was talking over and hour.
    He (tech guy from Microsoft) was friendly (I really was bit supriced), but didn't had any recovery solution for me. We was browsing net together, and even readed all messages from here (I'm really sure that problem is in windows filesystem, but they don't want to admit it). He said that there is no other cases with this similiar problem,
    so am I only one who is brave enought to contact Microsoft with this problem? :blush:

    I like to know if people has found out more of this problem, so we can point out this really is Windows (NT, 2K, XP and 2K3?) problem! Every symptoms and reports seems to point that problem is PARTITION over 137GB (NTFS), and is not really related to ATAPI driver.
    Has anyone got this problem corrected without resizing partitions to be less then 137gb? Or does someone have problems even with those small partitions and big disks?

    I have Windows XP PRO SP1 and 3*80+120+160 drives, and only that 160 is having problems now.

    Well, here is some other links about this problem (some are from here):;EN-US;Q169404;EN-US;Q303013;EN-US;Q331958

  14. Rick77

    Rick77 TS Rookie

    Still no problems yet...

    I posted earlier that I re-formatted my drives specifying that they reserve more space for the mft. The link to what that's all about is in my post. So far no problems anymore but it did take a long time to do all my drives. I had to buy another drive - this time I got a 120GB and made back-ups of other drives using Norton Ghost, then reformatted the drives with the 4096 sector size in partitions of less than 100GB after I put the entry in the registry to reserve the extra space. My suspicion is that the current large drive/driver/file system/operating system's capabilites have a breakdown when you have a lot of small files, or several real large files, or even a mixture possibly, and/or your drive is almost full, the MFT becomes so fragmented it fails. This is just my theory however and I am NO tech whatsoever hehe. I just wanted to share that I have still had no problems since I did this and I was having problems about every other day before.
    As far as recovery, I have not been able to get all of my data back but I was able to get a lot of it. I was able to recover some data with a program called Stellar Phoenix NTFS/FAT32, but a lot of the files were corrupt. The program was $150 and has only a year license then you have to buy it again :( I didn't realize that when I bought it. I also bought another program called Restorer 2000 and it seems to work pretty good but probably not as good as the Stellar-Phoenix but it was only $50 - a much better price, and seems to work pretty well. Good luck.
  15. BrownPaper

    BrownPaper TS Rookie Posts: 407

    if you guys are running windows xp or 2k, did you guys enable large system cache? that corrupts hard drives with radeon and nvidia graphics cards.

    i got the same orphan file deleted chkdsk crazy stuff happening when i enabled large system cache with windows xp pro. chkdsk would keep running chkdsk over and over again, ruining my data. do not use large system cache.
  16. Errata

    Errata TS Rookie

    To anyone who was able to get their data back:

    Was the data recovery software, you used, able to retrieve filenames for your data? If so, I'd appreciate the name of the software. Kind of dreading renaming all of my mp3 files.

    Also, was everyone who lost data using NTFS? Did anyone encounter this problem when their HD was larger than 120gb but had partitioned their drive to less than 100gb partitions? Does anyone think I'll be safe repartitioning the drive to FAT32?

    Thanks in advance.
  17. semi

    semi TS Rookie

    I was able to collect filenames from my corrupted drive with GetDataBack. I configured GDB to make logfile of all it done to another drive, after it has scanned all files, I done some manual job and collected filelist it did find.
    It printed filenames, even it was not able to add those names on the rescue "tree".

    ... And answer to BrownPaper. No I didn't enabled LargeCache, this problem seems to be 48bit LBA related, even I don't know how.
    I don't know all other people configuration but mine is:
    OS: Microsoft Windows XP Sp1
    MSI K7T Turbo - Bios v3.6
    Promise Ultra100TX - BIOS .15
    Drivers: Latest from WindowsUpdate

    I had that 160GB drive connected to that Ultra100TX IDE card, but I "couldn't" use drivers from Promise, because Microsoft drivers had bigger version number so windows didn't find newer one.
    Now I have that drive connected to MOBO and I had installed latest VIA 4in1 drivers. Now I should start "copy testing" to find out if this corruption happens again.

  18. semi

    semi TS Rookie

    Testing confirmed that problem was Promise drivers provided with Windows (original version 1.43.0603, Microsoft version 5.1.2600.1106). Old drivers are not 48bit LBA compatible.

    I just posted message to Microsoft support, that they should apply newest Promise drivers in Windows Update, with "tampered" version number so users could upgrade drivers ASAP.

    People with Promise card and big drive, should dump Microsoft drivers as soon as possible, and switch to new promise drivers:
    (Ultra TX Series Drivers: 133_100 tx2 )

    I made test system with working drivers, partioned that 160GB HD to 120GB+40GB ... Copied full of data. Then I rebooted, restored OLD system (working just fine, but has Original XP drivers). When windows was starting it was asking for chkdsk again (only for that 40GB drive)... I denied, didn't want to see those orphan deleting again.

    After system was up. I upgraded drivers (not as easy as one would think, because it was "downgrading"):
    1) My computer/Properties/Hardware/Device Manager
    2) Select "Update driver..." of "Promise Technology Inc. Ultra IDE Controller" (with right mouse button)
    3) "Install from a list or specific location (Advanced)". Next.
    4) "Don't search. I will choose the driver to install.". Next.
    5) "Have Disk"
    6) Enter path of NEW drivers here. Driver version should be AT LEAST (Dated: 28.3.2003)

    ... If you use "update driver" or something like that. It will use XP Drivers! XP Drivers is: 5.1.2600.1106 (1.7.2001) ... Seems to be Ultra66 drivers, original version is 1.43.0603
  19. lukemh

    lukemh TS Rookie

    Looks like I have the same problems as most of the people in here! Has anyone got a stable working system yet?

    I get the "Directory is corrupt please run chkdsk" message and I also get the same orphaned file messages when chkdsk runs at bootup and then find half my files are missing.

    My hardware is :-

    Asus P5GD2 Premium Motherboard
    Intel P4 550 (3.4Ghz)
    2x Corsair Value Select 512meg DDR-2 running dual chanel
    128meg Gigabyte X600 Pro PCI-express
    Seagate Barracuda 7200.7 SATA 160Gb
    Western Digital JB2000 SATA 200Gb
    Pioneer 108 DVD-RW
    450Watt Psu (known good with very stable voltages)
    OS : Windows 2000 Pro SP4
  20. Hewk

    Hewk TS Rookie

    Same here

    Damnit!@# Got the same problem today.

    System specs:
    -Windows XP Pro
    -Mobo Chipset: Intel i845PE
    -Ati RadeOn 9800 Pro
    -Seagate 7200RPM 160GB
    -Seagate 7200RPM 200GB
    -no raid controller installed
    -The two error partitions are both NTFS on seperate HD's. One is 105GB, the other is 183GB. Both contain a lot of small files.

    Before the problem:
    Had I no problems until I reinstalled Windows XP. My previous XP installation was Windows XP SP1 and SP2, with no HD problems.

    Just before the first bad partition:
    Today I did a reinstall. I installed Win XP Pro (without SP's) with almost no drivers installed other than the default XP drivers. Then I installed the Ati drivers of Intel Chipset drivers. I don't remember which one I installed first and don't remember if I rebooted between or before these drivers. After installing one or both of these drivers, I rebooted and got the first Chkdsk problem during the startup. An error with index $0 or something like that. Because the test was taking a lot of time, I did a cold reset during the test. (I know this is usually a bad idea, but I didn't trusted the test because I couldn't see any cause which might have caused those index problems.)

    The first bad partition:
    The index errors were on my 200GB HD, on the 183GB NTFS partition, which contained a lot of small files. Some directories on this partition where not accessible, Explorer gave the error:
    There wasn't a clear pattern in which one was accessible and which one was not. I also hadn't used this partition yet, in the new XP installation.

    Just before the second bad partition:
    I backup some files on the bad partition to another large partition the other drive (G:). After backing the directories which could be saved, I did a Chkdsk.exe /F J: in the command prompt. I took a lot of times (3 hours?), and thousands of thousands files where "orphaned". After Chkdsk, the directory structure was recovered. Files were assessible and OK, but some files were corrupted!@#&*!@&.

    Here some of the last (of the tons of lines):
    The second bad partition
    After this, I installed some other software and drivers on my new XP installation. Also SP2 and a newer Intel chipset driver. After this, I rebooted and again, a corrupt partition!#@!@& This time it was on the other drive, the other large partition on which I backupped some files of the previous bad partition. This second corrupt partition contained large files (>100MB) instead of small files, but since I backupped files from the previous bad partition to this partition, I did contain a lot of small files. And only the Backupped directory on this second bad partition, is corrupted.

    What I think what might be the cause:"
    -If it's a hardware problem, than it might be because I moved the PC a bit (only 30cm), while it was running. But I doubt it.
    -I think it's a software problem, because my previous XP installation never showed a problem like this before.
    -I think it might be a driver (IDE?) problem maybe in combination with large NTFS partitions.
    -Maybe I copied the problem (bad MFT atributes?) from the first bad partition to the second partition.

    More info about MTF:;en-us;Q174619
    "How NTFS Reserves Space for its Master File Table (MFT)"
  21. rturner

    rturner TS Rookie

    still freaky in '05

    Like many, I found this board through Google. In my case it's three different computers with varying sizes of hard drives. All have the MFT problem, all running Windows XP, SP2. One has a 40 gig Maxtor, another has an 80 gig WD and another has a 120 gig WD. None of them are repairable with chkdsk /r upon boot or from the Recovery Console. At any rate, I'm working over email with a Microsoft tech. I suspect he's going to tell me to format my hard drive(s) and start over. If I actually solve it without that I'll post all details.

    Question: I backup my entire drives to second hard drives with Ghost, but I've never restored any of them. If I restore from a complete Ghost backup, will I just be restoring the same corrupted MTF? Can you restore data files selectively from Ghost? Would I be better off using something like MS Backup to just backup my data files and do clean installs of WinXP? From what I'm reading, within 6 months I'll be doing this again.

    Coincidentally, the 2 computers running linux have no file corruption! :D
  22. rturner

    rturner TS Rookie

    Update - Not as freaky

    It took a while, but I think I have this figured out. Thinking my drive was trashed, since I couldn't get rid of the chkdsk bitmap errors, I put a new hd in and ran a clean install of Windows XP Home. I put no third party software on the computer, just updated Windows to all the security patches and finally, SP2. I ran chkdsk at that point to make sure I had no problems. Well, I did. The same "MFT is reporting space as used that isn't, bitmap errors, etc." At that point, it had to be BIOS, right? I went to the Asus site and flashed the newest BIOS (09/04) for my A7V8X-X motherboard. Uh, wrong. Then I ran chkdsk /r from the Recovery Console, chkdsk /f from boot, etc., all to no avail. The Windows defrag utility finished with no fragments, but strangely enough, it reported the Master File Table was in 21 pieces! On a brand new install!

    Ready to give up and format/reinstall the OS and *not* upgrade to SP2, I tried installing Diskeeper Pro 8.0 on it. (MS escalated support had told me Diskeeper was the source of all my problems). I set Diskeeper to run at boot and to let chkdsk run, optimize the free space and defrag the MFT. Bingo. It ran successfully, reported the MFT in one piece and when I ran chkdsk again, there were no errors!

    I installed all my apps and restored my data. I ran chkdsk again and the errors were back. I then ran Diskeeper and it reported a heavily fragmented drive (I just installed about 15 large applications). Set it to run at boot again and correct the MFT. It ran successfully and chkdsk later reported no errors again. The only caveat I can think of here is, if you already have Diskeeper, and you upgrade to SP2, you might have to uninstall/reinstall Diskeeper. And the only versions that will do this are Pro 8.0 and 9.0, which cost around $50.

    I'm no engineer, but this is my theory. In Windows XP, the MFT just doesn't clean up after itself very well. When a lot of software is installed (at 90 megs compressed, SP2 is a lot of software) the MFT gets very fragmented. Over time, most people don't notice that their computer is running slower. The only reason I started checking my disk was because the computer crashed and could no longer see my c: drive. I'm not sure this is just an SP2 issue; I think it's adding a lot of software in general. Diskeeper Pro 8 (and most likely 9) can keep the MFT in good shape. I don't know of any other way to fix this problem, and I hope this helps anyone else out there Googling to find an answer. Because at this point, my sole help from Microsoft has been phone support telling me, "you need to take the computer to a repair shop". And escalated MS email support telling me to never run a 3rd party disk application on a Windows OS.
  23. hall

    hall TS Rookie

    Amazing how this thread started two years ago and we are still having problems with this issue!

    I have just read the three pages of this thread and am adding my two cents.

    I created a boot floppy for MemTest32 as someone mentioned earlier and ran it from start up. It went through it's 8 levels of tests and then started the 8 test over again. This is probably normal, but I wouldn't know, because I didn't really read the readme.txt file. :p

    My PC Specs:
    Win2000 Pro SP4
    1x512 DDR-266Mhz
    AMD XP1600+
    1x30GB (boot disk w/out problem) Seagate
    1x60GB (file storage w/out problem) Seagate
    1x200GB (file storage WITH problem) Seagate
    Albatron KX600 MB

    I received the "Deleting Oprhan file record segment" messages for the first time tonight and I almost went insane. After a few seconds, I was able to calm down and think smart enough to turn off the computer.

    Tried unsuccessfully several times different ways to ever get the 200GB drive to work. Every time I canceled the file deletion messages it would load windows, but during start up of the desktop it would restart the machine. puke:

    I am going to try using Diskeeper here in a minute as it's 3:30am and I'm going to sleep.

    What I cant seem to understand is that I monitor my system (home office main computer) very tightly with Norton SystemWorks and allows update Windows as necessary. Now I will admit it's been nearly 4-6 weeks since I last ran SpeedDisk (Norton's Defragger). Also, the 200GB drive is always have data moved to/from and around it all the time, but usually not more than 50GB of data at a time.

    Also, I am able to use the computer right now, because I have the 200GB drive unplugged and thus I cannot run DiskKeeper to diagnose that drive...damnit! This makes me mad! :mad:

    I am so sick of computer problems, but as a web developer there is no other option! ha! I would change careers (still pondering this topic), but I am not sure what I would do instead...

    I'll post again if anything new happens. auuuuuuuuggh!


    I installed this program called, Get Data Back for NTFS, but of course it does not recognize my drive as it is not hooked up to the IDE cable. However, when it's hooked up it tries to delete my files and IF i skip the process the computer reboots itself at startup of windows desktop and loading of programs in the background. *groans*

    I went through msconfig and deleted a bunch of unnecessary crap in the start up section...still no luck...

    *cries uncontrollably*
  24. hall

    hall TS Rookie

    I am going to go buy a USB hard drive enclosure for the 200GB drive and try access it that way, since SUB technology allows devices to be added while the computer is running.

    This theory should then allow me to be able to run GetDataBack program on it and back up files as well.

    I'll keep you informed.
  25. hall

    hall TS Rookie

    Well, the USB harddrive enclosure theory didn't work...

    Going to try something back
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...