Front mic on laptop cq70 not recognizing 3.5mm jack

By barnineffect · 7 replies
Apr 3, 2011
Post New Reply
  1. Not sure if I posted this in the correct section?


    bit of a problem I have.

    I have a compaq cq70 presario laptop runnning vista basic, the front mic jack doesnt seem to work, I have tried lots of suggestions, checking device manager, check if mic muted, check conflicts, etc but even when I plug in a mic (that works, has been checked) the built in mic still picks up the sounds and the plugged in mic picks up nothing. device is conexant smart audio 221

    I even prised open the front part of the laptop to see if there was anything there just incase it was broke/missing

    any ideas?

    many thanks
  2. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    Obvious answer is that your external mic is faulty...but you say it has been tested and does work. I would test it further, on another pc, or can you plug it into an audio recorder mic socket and make a recording? Also some (electret) microphones need a 1.5 Volt cell to power the element inside them, so does it need a new cell?
    But failing all that and your mic is ok as you say, I would think it is the 'switch-over' mechanism in the socket that is faulty.
    It is a very common fault on audio equipment with headphone socket.
    When you plug the mic into the socket a small contact should move over and disconnect the pc's internal mic, and connect the external one. This can fail over time and use, it can be repaired, but really means a new socket to be fitted to the motherboard.
    You might be able to prove it, by starting a recording on the built-in mic, then push in the external one, very slowly. Then play back what was recorded. Did the external mic pick up anything?
    ( In your 'recording devices' options, do you have the microphone set as 'default'?)
  3. barnineffect

    barnineffect TS Rookie Topic Starter

    Thanks for the reply, I wouldnt have though that the mic is broken but it could be, it hasnt been used at all and I only found out that the jack wasnt picking up the mic last week, previous to that it hadnt been used at all.

    I'll do another test with the mic on a PC to double check it.

    I'll also try the suggestion of starting a recording then inserting the ext'mic

    In the recording devices it shows only one option and that is set to default (conexant) I would have thought when I push the ext'mic in it should show another option but it doesnt. I have clecked to show all enabled and disabled option but nothing is there. Have pluged in a USB recording device and this showsd as an option when inserted.

    failing that it looks like a trip to a PC repair shop to have a look and maybe replace front input jacks?
  4. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    Microphone issues

    Yes I would start with proving what really is working. I do a fair amount of recording with my pc, and it should be so simple but often isn't.
    I use various inputs, DVD, VHS and several Mics, and it could even be that you are trying to use a stereo mic in a mono socket (maybe), or other way around.
    If you can plug your mic into something simple, such as a cassette tape recorder (!) or a digital one, or video camera, and pin down if it really works. If it's a 'dynamic' mic then it won't need a 1.5v cell ('battery') inside, if it's 'electret' type then it usually will, could be a single AA or watch type silver cell.
    I guess you know this, but if you right-click on speaker icon, in taskbar, choose 'Recording devices', you should get a list with an icon for each device.
    You should have a microphone icon at the top of the list, right-click on it and choose 'set as default'. Then it should show a green tick on the icon.
    About the 'stereo/mono' issue, if your mic has a 3.5mm plug, does it have 3 chrome bands on the plug,(stereo) or 2 (mono)?
    Check if your pc can record in stereo, as mics are normally mono, and the connections won't work in the wrong socket. (Hope this helps!)
  5. barnineffect

    barnineffect TS Rookie Topic Starter

    got a few things to check which I will do when I get my dinner break.

    I also have a similar laptop that someone else uses, this is running windows 7 and the mic jack works on that one, we have a head set that has a mic on, for talking on vent etc, have plugged that in to the laptop and same thing, no mic detected.

    got the green tick for default but its the internal mic that is default.

    will check the mic plug for the bands, not checked that and didnt realise about the mono / stereo recording. how do I check to see if my laptop can record in sterero?
  6. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    Microphone issues

    Not easy to be sure if you can or cannot record in stereo, might be mention of it the manual, but wouldn't bet on it. Your pc can no doubt playback stereo sound, but that has no bearing on recording at all, (as far as 'live' microphones go.)
    One simple way of finding out, is to push the mic plug part way into the socket,till it 'clicks', and make a recording, ( I use, and see what you get recording, 1 channel most likely.) Then push the mic socket fully in, make another recording, and see what happens. Could be nothing, or stereo, or 2 channels with same waveform on both.
    You will only really know if you are using a stereo mic (plug is same as on mp3 headphones, i.e. 3 chrome bands), AND your pc has a stereo input socket.
    If you are using headphones and boom mic, you may have a USB plug, plus a 3.5mm plug (for mic socket), would think that will be mono only.
  7. barnineffect

    barnineffect TS Rookie Topic Starter

    Hi Mike,

    well checked it all out, both mics are exacrty the same jack as the headphones. chrome, then a band, chrome, then a band, then the front part point of the jack.

    still nothing being recored through the mic when pushed in halfway, slowely all the way, same result, looks like things are pointing towards the solder being a bit dodgy on the mic input, had a quote to repair at about £70.00

    as long its not software issue or anything like that I reckon this thread is closed unless you think otherwise?

    really appreciate the time and input, will be back if I have other problems :)
  8. barnineffect

    barnineffect TS Rookie Topic Starter

    ok final update

    jack was was fine, seems to be a problem with motherboard connection, not gunna go too deep into that, managed to get a linksy 2.0usb external sound card and I can now plug in the 3.5mm jack into it, perfect

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...