Gaining access to external hard drive

By Reckoning · 10 replies
Jul 2, 2011
Post New Reply
  1. I have an external hard drive I was trying to cut off permissions to view it under any account but mine.
    I went to "security tab" and must have done something wrong because then when I would look at "My Computer" it would show my external hard drive but wouldn't give any information all it said was NTFS. If I'd try to open or anything it'd say access denied (although i am administrator.)
    I went back to security tab and the 2 users it shows is "SYSTEM" and "ADMINISTRATORS" both say full access but I can't view the hard drive files. I went in under safe mode and tried to view it and it let me open the hard drive to view all folders in it.. but I could not open any of the folder beyond that point.
    Now back in normal windows mode when I view "My computer" I see this

    Computer management -> Disk management now shows this

    Before I mess this up more, can someone please help!
  2. Reckoning

    Reckoning TS Enthusiast Topic Starter Posts: 96

    I tried opening command prompt as administrator and typed
    cacls “Path to folder\folder name” /E /T /C /G Administrators:F
    all still says access denied
  3. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    try this:
    • mount the drive
    • open My Computer
    • right click on the Drive letter of the external
    • ->Properties->Security Tab
    you get a list of NTFS Permissions for every 'user/group' specified for this device

    create a Notepad document and
    list each entry in the Group or user names in the upper portion
    click on each one at a time and notice how the lower window changes
    the permissions [x] enabled;

    report your findings . . .
    You are looking for two kinds of things
    1. Who has Full Control?
    2. Who has anything [x] denied (and what is it)
  4. Reckoning

    Reckoning TS Enthusiast Topic Starter Posts: 96

    As far as mounting. when you get to "Mount in this NTFS folder" and you browse.. do I choose my C: drive or my D: drive? The D: drive is the 1 I'm having probs with. Sorry not too familiar with mounting
  5. Reckoning

    Reckoning TS Enthusiast Topic Starter Posts: 96

    Well when I go to security tab to look at permissions.. the only 2 user/groups is "SYSTEM" where everything including full control is checked as "allow" the second user/group is "Administrators (Matthew-PC\Administrators)" which has the same exact thing. Everything including full control is "allow"
  6. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    then that's the issue. Your login is not in the System group nor the Administrators group.

    Login as the Admin, get to that Security Tab again
    • click the Add button
    • in the box, you can enter one of two kinds of things,
      a group name
      or a specfic user login-name
    If you wish ALL users of your system to have access, then enter EVERYONE (a group),
    or only the login name desired
    Click the Check Names button to be sure you got it right
    Click OK

    While the new entry is still selected in the upper area,
    chose the permissions you want for this new entry

    Click Apply and your good to go
  7. Reckoning

    Reckoning TS Enthusiast Topic Starter Posts: 96

    I only have 2 accounts on this computer: Matthew and Guest. Even when I am logged on Matthew which is the admministrator I can not view or do anything with this drive. I still tried to add an "everyone" user to the group but when I clicked apply it grabs the first folder it tries to change permissions on and says "Access is denied"
  8. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    the Mathew account may have full control and yet NOT be an admin account,
    AND every windows systems has a login ADMINSTRATOR.

    Boot into Safe Mode, login on the administrator account, and repeat the Add Everyone sequence.

    btw: which version of windows are you running {XP/home vs pro, Vista, Win7} ?
  9. Reckoning

    Reckoning TS Enthusiast Topic Starter Posts: 96

    Windows 7.
    I logged in under the actual administrator account and still was unable to view the contents, it still said "access denied"
    I made a new user "Everyone" and gave full control and when I'd click apply it'd say I don't have permission to change.
    However I figured out that I can go to each individual folder on the external drive and go to the security tab and I can "Change owner" to the Matthew account and can then view that folder. Will be kind of a pain having to do this on every folder but I'm happy I can at least access the info on this drive somehow.
    This pic shows what I see when I go to the security tab for an individual folder "Backup-External". It says under current owner "Unable to display current owner." And allows me to change to 1 of the 2 options listed. I don't know why it gives me permission to change these (this is even just logged in on the Matthew account now - not the administrator) but change NOTHING else for this drive.
    I might backup everything on this drive somewhere else and reformat this drive and just start over.
  10. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    Great! If you can give ownership of any folder to Mathew, then here's how to do
    it ONCE and get control

    • 1) Click the Security Tab -> click the Advanced button
    • 2) Make sure the 'new owner' you wish to use shows under the Permission Tab
    • (add it if not)
    • 2) click the Ownership Tab
    • 3) change the owner to the desired Login
    • 4) [x] Replace Owner on subcontainers and objects at the bottom
      (this will modify EVERY folder and file below the one being modified)
    click Apply and let it run :)
  11. Reckoning

    Reckoning TS Enthusiast Topic Starter Posts: 96

    Ok awesome.
    Thanks a whole bunch for your help! :D

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...