1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Hard disks passing SMART tests but still giving problems

By matav
Jan 16, 2012
Post New Reply
  1. I have:
    > Windows XP Pro SP3 (x86)
    > 1x1000gb sata hd
    > 1x500gb sata hd
    > 1x80gb sata hd

    Note on 80gb HD
    my 80gb is the one having the Windows OS and does not report any errors in the event log.

    Note on 500gb HD
    i think my 500gb has failed :(
    sometimes it does not show up in the bios. a controller issue i presume.
    but when it does get detected and i run SeaTools for Windows, the 500gb will pass these tests:
    1. SMART - Pass 1/15/2012 03:52:46
    2. Long DST - Pass 1/15/2012 03:55:29

    The event log would show same errors as it does for the 1000gb (below) so i have just disconnected it for now.

    Note on 1000gb HD
    but my issue here is with the 1000gb which is even more weird.
    this is what happened on Friday the 13th after midnight:
    > HD started making those annoying clicking noises.
    > Playing music files from this drive would loop about 0:01sec of the track like as if scratching the disc.
    > Event log has:
    >>> source: atapi
    >>>>> id: 9 - The device, \Device\Ide\IdePort2 did not respond within the timeout period.
    >>>>> id:11 - The driver detected a controller error on \Device\Ide\IdePort2
    >>>>> id:15 - The device, \Device\Ide\IdePort2, is not ready for access yet.
    >>>>> id: 26 - The driver has detected that device \Device\Ide\IdePort2 has old or out-of-date firmware. Reduced performance may result.
    >>> source: disk
    >>>>> id: 11 - The driver detected a controller error on \Device\Harddisk1\D.
    >>> source: ftdisk
    >>>>> id: 57 - The system failed to flush data to the transaction log. Corruption may occur.
    NOTE: i think, this (above) was for the 500gb hd
    >>> source: i8042prt
    >>>>> id: 12 - The ring buffer that stores incoming mouse data has overflowed (buffer size is configurable via the PS/2 mouse properties in device manager).
    >>> source: cdrom
    >>>>> id 7 - The device, \Device\CdRom0, has a bad block.
    NOTE: this (above) is when i tried burning SeaTools for Dos on CD.
    I saw this error so burned it multiple times and when i tested the CD, it had burned fine and was bootable.

    Running SeaTools for Windows, the 1000gb hd passes these tests:
    1. SMART - Pass 1/15/2012 03:00:09
    2. Long DST - Pass 1/16/2012 02:33:46
    3. Long Generic - Pass 1/16/2012 14:02:31

    NOTE: tests were run after the problems occurred.

    The thing is that today... now, music is playing properly and at the same time i was running the Long Generic test.
    Event log has not reported any problems for more than 24hours.

    This is all weird cuz both the HD's pass the SeaTools tests on multiple occasions and are fairly new (1000gb is a year old while the 500gb is kinda new)
    I am wondering if the motherboard is at fault or the cables need replacing or something.
    I will later be testing the motherboard and chipset by running Hot CPU Tester.
    but in the meantime, could someone please help me figure out if there are other problems i need to look into?

    Also, can the clicking noise occur if the hard disk is very close to a strong electromagnetic field?
    like... it was close to an old AC Servo Stabilizer / Voltage Regulator, that i use to supply power to the computer.

    Now, it doesn't make a click when the HD is idle or even when in use.
    I have rebooted the computer several times to hear for any HD clicks.
    I have even tried unloading and reloading the HD via Disk Management but it does not click anymore.

    Any insight would be appreciated.
  2. wrt54gs7

    wrt54gs7 TS Enthusiast

    In my experience i hear clicking sound with my external usb hdd, when it has problem getting enough power (too many devices installed and with lower power supply rating 300W). Have you tried dis/reconnecting the data and power cable of your hdd or reseting BIOS setting to default?
  3. matav

    matav TS Enthusiast Topic Starter Posts: 143

    before i created this topic, i had disconnected the data and power cord and aired it to remove dust.
    after reconnecting, the 1000gb started functioning well again.

    but i am unable to point out the main cause of my problems.
    whether it is HD or Cords or Motherboard or Power Supply or EMI ?
    reason for my confusion being that the HD's pass SeaTools tests yet event log reports errors.

    luckily the 1000gb does not report a paging fault error like my 500gb so i know the 1000gb is not failing but then again the clicking i heard from the 1000gb that night makes me wonder.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...