How do I enable USB ports without mouse or keyboard

By kayvaanshrike · 4 replies
May 28, 2011
Post New Reply
  1. Hi all, I have a bit of a problem my usb ports are disabled and that means my mouse and keyboard don't work so how do I enable the usb ports without a mouse and keyboard? please help...
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    When you say they're "disabled" do you mean Device Manager shows their status as Disabled? Or do you mean they just don't work (i.e. no USB devices get recognized/ no USB devices will work).

    If they just aren't working, try this trick. It's a long shot but sometime it really does work! (e.g. see HERE)

    Unplug computer power cord from the wall. If a laptop, remove the battery also. Disconnect all devices from all ports. Let the computer sit for an hour or two. Then plug everything back in and try again

  3. kayvaanshrike

    kayvaanshrike TS Rookie Topic Starter

    Yes I did disable the usb ports in device manager on my pc sorry I didn't make myself clear
  4. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    If this is a desktop, I suggest borrowing a PS/2 mouse and keyboard (if you don't already have one) and then you can use them to re-enable your USB ports.
  5. kayvaanshrike

    kayvaanshrike TS Rookie Topic Starter

    yeah it's a desktop and no it don't have ps/2 ports. I bought a usb pci card and it works perfect. Lol when I asked about how to fix my pc at pc world they wanted £250 to fix it lol... I only paid £11 for the usb card works like a charm ;)

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...