How do I use CAB SDK?

By Andros_Forever · 141 replies
May 28, 2008
  1. Batqul

    Batqul TS Rookie

    i got everything done except those INF files...
  2. Batqul

    Batqul TS Rookie

    i get the line zero error to

    does it have to do with the fact that when i save the usbboot.inf file
    is says its a text file?

    I am using XP pro for this BTW.
  3. orkodan

    orkodan TS Rookie

    maybe, I converted mine right as they said inf files but still got the line 0 error; may have just not copied the files right somewhere.
  4. Batqul

    Batqul TS Rookie

    I fixed my line Zero Error i think..i figure out the .inf situation.
    I know that I can boot from USB on my laptop. HP pavilion tx1000..Still cant seem to get a good instal but i get this wierd thing.

    Manifest Parse Error: Invalid at the top level of the document

    Error SXS.DLL: Syntax error in manifest or policy file

    eeek it goes in to the windows start up install screen

    Doing XP Pro
  5. Batqul

    Batqul TS Rookie

    Also to note on that.. I am using ..nero 7 premium to burn the files... i tried the ISO and the BIN images..its bootable and all but same error..i tried burning it from 2 seperate computers and waisted about 8

    I tried also using 2 different computers to do the install and pulled my HD out and all.

    Should i try a different program? If so any suggestions?
  6. Batqul

    Batqul TS Rookie

    Here am where i am at now... I redid the project from the begining with a different ISO of XP pro sp2. I edited the usb it said... It appeared like everything worked.. Windows went throught all the install steps.. However when i go to start it like normal. At the xp start up screen while its loading it flashes a blue screen error... but it does it so fast and then restarts i cant read it.. It does this on a loop too.

    I dont know... I know this can work its soo close. yes i tried plugging in the HD to another machine but same issue.
  7. orkodan

    orkodan TS Rookie

    inf files

    can i have your inf files to try here?
  8. Batqul

    Batqul TS Rookie

    sure i would love to give them to you..but i cant PM until i have 15 post or more...
    Also i did find and easier way to extract and repac the .in_ files.

    I will wright it all out once i can postivly verify my installation is working well
  9. Batqul

    Batqul TS Rookie

    Oh and yes here is the the error i finnally got it.. I can start in safe mode...wich i think will get me to the point where i can rescue the files i needed from my old hard drive...but i would like to get this to run normally ...In safe mode it says i have 0mb allocated to the pageing file..I tried fixeing that but same error
    if i start normally i get this error
    ***STOP: 0x0000007b (oxF917524,0xc0000034,0x00000000, 0x00000000)
    on the blue screen
    then i have to restart
  10. orkodan

    orkodan TS Rookie

    Hmm strange.

    I don't need the files now, I got them off nobardrin, thanks anyway.
    I'm curruntly into the installation stage so I'll wait and see
  11. orkodan

    orkodan TS Rookie

    I'm getting pretty much the same error message

    STOP: 0x0000007B (0xF7C7B528, 0xC0000034, 0x00000000, 0x00000000)

    Had to skip two files durig set-up too, one said plugin.ocx and the second was

    ...and I can't get into safe mode either, comes up with the same message
  12. nobardin

    nobardin TS Rookie Posts: 256

    Odd that the files worked for Andros but not for you all. They were not made for any specific brand/model, desktop/laptop. I will look over everything in the next week or so and see what I can come up with.

    I do not have a lot of time to sit around on the computer as of late, as my wife and I are hopefully moving to the UK soon. Between that, work and everyday life it leaves me very little time to help you all through this how I normally would. For that I do apologise. However, I am doing what I can for you all at the moment.

    I hope we can get these issues resolved for you all soon!
  13. orkodan

    orkodan TS Rookie


    No problem Nobardin, I really appreciate whatever help you have and can give :)

    Where do you live at the moment? I lived in the UK until 2007 and am now in Norway with my GF and 2 kids, I miss the UK though.
  14. jimijamesk

    jimijamesk TS Rookie

    PLEASE help me make my external boot disk!!! I'm stuck on the cab sdk. I got the executables working from the \bin folder in the DOS command line. I can't get the syntax on the commands right im soooo lost and feel helpless. I'm trying to extract usb.in_ usbport.in_ usbstor.in_ .no luck yet. I started out with the
    cabarc x c:\documentsandsettings\amber\goodiers\usb.in_ <-----but that throws me error

    I even tried putting my goodiers folder in in my bin folder to no avail
    I suck at cab sdk. I also can't believe you have to hack a boot disk just to use an external hard drive.
    I read all previous posts and downloaded the 2 guides posted but the guides i got were corrupted.......HELP!?
  15. kenling86

    kenling86 TS Rookie

    Hi ... can someone send me the files that work for Andros to me...

    I'm also trying to get my OS running on external... tried editing all those .. but don't know how to use the cab sdk to change the files back...

    Thanks a lot again ...
  16. whattheduck

    whattheduck TS Rookie

    i had the same problem, but then i got creative and tried this :

    ( a lot of infotext, seems to be working fine )

    d:\cabarc.exe x usb.in_
    operation succesfull

    Both files ( cabarc.exe and usb.in_ ) where located on d:\ in this case, otherwise try the command 'cabarc.exe' in stead of 'cabarc'

    so try this in your case :

    "cabarc.exe x c:\documentsandsettings\amber\goodiers\usb.in_" ;)

    I hope this information helps with using cabarc
  17. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    You mean "cabarc.exe x %userprofile%\goodiers\usb.in_" ofcourse
  18. frazinraf

    frazinraf TS Rookie

    when i open the zip files posted by nobardin , it says it's just a "file" cause there is no file extension. i tried adding my own but still, random letters. can someone repost the zip files with the files within with a proper file extension that can be opened with Microsoft Word o Wordpad please. i don't understand how t extract the in_ files.
  19. whattheduck

    whattheduck TS Rookie

    Try using notepad instead of wordpad, wordpad didn't work for me eather ;)
  20. maidu1191

    maidu1191 TS Rookie

    Someone just upload these .inf files? That expl. doc is still arabic. in cmd nothing works.
  21. lemonbellz

    lemonbellz TS Rookie

    could you possibly post the inf files from the cab sdk??? it would help a great deal!!! Thanks
  22. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Just add .Zip to it again, and try extracting again

    here's the first page to this thread again:

    I agree it would be much easier that others should just upload the INF file
    I find it strange they don't :confused: (like it's only theirs no one else can touch ??)
    Anyway I haven't got it, or made it
  23. salcott

    salcott TS Rookie

    preparing usb drive for WinXP

    I've been watching this thread and also trying to make it work...

    Any chance of getting that second set of files that worked for Andros?

    Also, what is the proper way to setup the external drive for a windows install? I've reduced the partitions down to ONE, NTFS, marked the drive as "active" in disk management, and then attempt the install.... but windows setup can't access the drive- still. Do I need to add boot sectors or something of the sort?

    Thanks for help, much appreciated.
  24. kalendren

    kalendren TS Rookie

    Repacking the CAB

    i am having trouble with repacling the CAB files it keeps throwing out an error

    can you detail better how the reapcking works

  25. sinthem

    sinthem TS Rookie

    hey can anyone help me out here? I'm having trouble with the step that goes like this:

    If you have not already deleted your extracted .IN_ files, do so now. They need to be replaced. Open a DOS shell again, and navigate to the folder with your changed files. Then exceute the following commands:

    cabarc n USB.IN_ usb.inf
    cabarc n USBPORT.IN_ usbport.inf
    cabarc n USBSTOR.IN_ usbstor.inf

    The three IN_ files should now exist again.

    Congratulations. All out modifications are done.

    I keep getting the file with the name USBSTOR.IN_ usbstor.inf instead of just USBSTOR.IN.

    Anyone knows why?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...