How to repair Windows XP/2000 if you are unable to boot into Windows

By Rick · 374 replies
Oct 20, 2003
Post New Reply
  1. wiseoldman2185

    wiseoldman2185 TS Rookie

    More of the same

    Hello I am new and as everyone before me I've bene reading this post for hours. And I got nothin. I've seen a lot of similarities but none are my problem or I havent seen my solution. One day, I was playing music and songs started "skipping" I guess due to too much cpu usage. So I tried to restart and I got a blue screen error. It said your computer is being shut down.....blah blah....physical memory dump. I think we've all seen it. I restarted and when I did; before it got to the windows screen with the green bar, i got a small message on a black screen that said "disk read error press cntrl+alt+delete to restart". I tried restart again and got the same message. So I used the windows cd like in the tutorial on the 1st page. I first did recovery console (like a tard) and it ran fine, I even was able to type ckdsk and run a check disk and it said everything was fine. So then I tried to repair an existing windows install, identical to the tutorial. However after I press F8, it goes to the next screen but I do not have c:\windows. I have a partition and again as I've seen before it says I shouldnt install 2 OSes to the partition, it could cause errors. So like others before me I pressed esc and quit. This is where I am now. If i try to boot in safe mode it starts but then goes to a black screen and then automatically restarts, it will continue to do this for any type of windows boot (normal, safe mode, last know good config). So as of now I have tried everything I've seen so far and I am lost as to what to do next. I really dont want to have to reformat or lose any files, but it doesnt look good.

    *I have to mention this is my 2nd hard drive on this laptop. My first one apparently melted or fried or something. Im hoping this is not a re-occurence.

    Dell lattitude D600 Laptop
    40g HD
    512 mb ram
    pentium M processor
    or check for specs
  2. DarnComputer

    DarnComputer TS Rookie

    I need help too...

    Well I turn on my darn computer and everything appears fine, then it asks if i want to start computer in safe mode, safe mode with networking and so on but none of those settings work... when i select any of them windows "pretends" to be loading and then there's a flash and the computer restarts and I go through this process all over again. When i try to press F10, which is system recovery nothing happens and i get an error and they ask me to press f1 to setup and f2 to resume... i resume and the same thing happens. It's a compaq computer and xp home OS, i have no cd's for it... but my hp laptop came with an XP operating cd, and an application and driver recovery dvd... can any of these help me...

    I want to try and fix it myself of course, I mean it's not like my computer can get any worse, it's already not working. Any help would be greatly appreciated. Thank you.
  3. TS Rookie

    javeed iqbal

    I have some problems
    1> In my outlook express a sender send me a email but one email i received
    multiple times so how to stops and close perticular email ID.
    2> I loadown a file name unknwn.unk it does not open hopefully you will
    help me.
    javeed as
    andheri, Mumbai.
  4. spytrdr

    spytrdr TS Rookie

    Say the user has administrator privileges and is password-protected.
    Either external enclosure or you install the hard drive (ntfs) as a second one in another computer with another XP Pro installation. How do you access his documents and settings in order to back them up?

    SIRwILLETT TS Rookie Posts: 31

    not to be sarcastic

    but how are u going to read that if u cant get into windows. I know what ur going to say but my question still stands
  6. spytrdr

    spytrdr TS Rookie

    Are these instructions (the ones that initiate this thread) current and up-to-date?
    With a Windows XP Professional with SP2 cd trying to perform a "repair-install" (also known as "in-place upgrade") on a SATA/150 hard drive (in perfect condition, just the OS was damaged after a power outage) I get slightly different messages and a few more steps, until I reach the step where one has to choose:

    -format (of course not)
    -leave current file system intact

    What comes AFTER that step/screen? It detected before that a Windows installation is on the disk, but until that screen I am not yet given the option to REPAIR C:/WINDOWS. I don't want to continue until I have 100% certainty that my documents and settings on that disk won't be deleted after that.

    Could someone advice on this?
  7. becher03

    becher03 TS Rookie

    thank u Rick
  8. LNK

    LNK TS Rookie

    I'm having a problem. I had Windows XP SP2 and Fedora installed on my laptop as a dual-boot. I repartitoned my hard drive and it had the partition with XP as the boot drive so I thought it would be fine if I got rid of the Fedora partition. Now when I boot, I am sent into GNU Grub version 0.95. I'm not sure how to get into Windows. I have tried using the Recovery console, but after I was done using the repair of boot.ini or the process listed on the first page of this topic it would continue to boot into GNU Grub. I'm using the original cd that came from Dell which is a Reinstallation CD of Microsoft Windows XP Pro (w/ SP1). I'm guessing that I might need a CD with SP2, but I'm not sure where to get it. Any help would be greatly appreciated.
  9. blackskimmer

    blackskimmer TS Rookie

    wont boot error code.......

    Hi guys im looking for a tad bit of help from some of you who know your error codes.

    In short here is what happened

    1)PS blew up

    2)Surge took out mobo as well

    3)replaced mobo and PS (Enermax 350w +asus p4p800mx with exsisting 1.7ghz P4

    4)Once powered up wont boot into windows, not in safe mode not with XP disc not with custom boot disc (on CD rom) -note gunna try maxtor HD boot disc on floppy tomorrow see if that helps.

    5)I get this error code shortly after choosing one of the safe mode/with networking/command prompt etc.

    STOP:0x0000007B (0xf8A9A528,0XC0000034,0X00000000,0X00000000)

    *SIDE NOTE: would like to recover data if i could off of HD (maxtor 40g) Its father in laws HD and he didnt back up anything :(

    Any help would be appreciated thx guys!
  10. blackskimmer

    blackskimmer TS Rookie

    update tried the maxtor tools, scanned all sectors, everything back good. Hmmm, maybe my Winxp boot disc is gonzo going to borrow friends today see what happens
  11. iwario

    iwario TS Rookie

    If the sytem is badly infected, reinstall win xp ?

    I have really had it with this trogen . I spent hours running virus scans .Now the computer keeps locking up. I want to just reinstall win xp. Here is my problem. The computer had windows ME originally. I purchased the XP upgrade and installed . Some time ago I deleted the windows ME off for more space. Now, I have the windows ME cd`s to reinstall but it won`t reinstall. I keep getting messages to restart computer.So I restart and it still won`t install windows ME so I can then use my upgrade windows XP . I need to get rid of the viruses and trogens and just want to reinstall what I had. I really need some directions to get a clean install without those nasty files (trogens and viruses) being saved. My XP cd is the upgrade and I don`t have money for new full xp. Thanks in advance. iwario
  12. Spazeman85

    Spazeman85 TS Rookie

    Hello... After attempting to install a pci usb 2.0 card I cannot boot into windows, even after removing the card. The computer freezes if I try to go into safe mode or the most recent configuration that worked. I would like to do the repair install, but my pc runs into a BSOD when attempting to boot from the cd (one about an ACPI incompatibility with my bios). Hitting F8 while loading from the cd has allowed me to get to the XP setup options, but "Repair Install" is not an option. I cannot get into recovery console to run tests either. When I try to do that, I got BSODs about "A driver corrupted pool memory used for holding pages destined for disk" (Stop: 0x000000DE (0x00000002, 0xE111C00C, 0x00000000, 0xD15598D4)) and "BAD_POOL_CALLER". Before going through the hassle of a complete reformat and reinstallation of XP, I was hoping to see if anyone had any ideas for what to do...


    -- I have: Iwill KK266-R mobo, 1 GB pc133 Kingston ram... yes, I know it's old, but it works (worked) for me.

    --Oh yeah, my install cd is SP 1, but my install has been upgraded from SP 1 to SP 2... don't know if that would cause any problems...
  13. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    You can press F5 in the beginning of text-mode setup to select a different HAL, choose "Standard PC" from the list (or something else if that doesn't work for some reason).
  14. SingleBullet

    SingleBullet TS Rookie problems never end

    and here's mine :

    -I have this HDD wich has all my files and windows instelation folder...

    -I can't boot into windows even safe mode..

    -I can't repair it using Windows XP repair feature Becuse my OS doesn't appear in this screen to perform repairing !


    - But when I choose to install a fresh copy it indicates that I have OS installed !

    -I've installed windowsXP in other partition (different HDD) and here are the OS's


    -I don't want to install new windows and loosing 150GB of data I just want to get it repaired and keep all my personalized settings and installed programs as they originally were..

    please help me out !
  15. JemKillKillKill

    JemKillKillKill TS Rookie

    Maybe you guys could help me out before I burn my PC :(

    Everything was fine with my WinXP Pro SP2 installation for the past couple of years, I haven't changed hardware (in about 12 months) but on Thursday when I turned on the machine it got to the logo screen and sat there with the blue bar moving away and refused to go any further.

    I booted up into safe mode no problems, checked out the ntbtlog file (fat lot of use that is - lists what it loads then lists what it doesn't load but doesn't tell you if it hasn't loaded it for an error reason or not???).

    I repeatedly tried to get into the system - I even had a system restore point from the day before (and the day before that) but neither of them made any difference. I then decided to go back to my original Win XP install disks (pre-SP2) and repair the installation folder.

    It started out ok, then when it went to reboot it did the same thing - hung totally at the starting up screen. So back to safe mode again - except now of course I can't get into safe mode because it gives me a dialog saying Setup can't run in safemode, click OK to restart.... useful Microsoft!

    So... by this stage I was a little errr disappointed :D and installed a new XP (no SP's) into a new folder on the same drive figuring if I could get it to boot I could swap back to the other install and try and suss out what's wrong. So I got that installed but got flumoxed by the Windows Update site refusing to upgrade my windows unless it was genuine - when it checked for genuine it crashed out with an error code and said it was unable to work it out... another useful Microsoft error...

    So I tracked down an SP2 upgrade disk and manually upgraded. I then found a full SP2 install disk and tried to boot from it and again repair my original install. This time it got to entering the product key and got to 34 mins remaining before starting to complain about missing DLL's (started with cmprops.dll then about 100 more!!!).

    The DLL's were all on the CD - I could even copy them to my Hard Drive and tried to point the installer at this folder but it still insisted it couldn't see them - what's that all about? I cancelled through the errors and of course when it rebooted it got to the logo and froze...

    I thought it might be folder permissions so I booted into my good XP and gave ownership of the folders to Administrator and gave Everyone full control... re-ran XP2 setup... same problem. This time I noted down all the files.

    I rebooted, deleted all the original files in case it was a write permissions thing and tried again - same stupid damn error about not being able to find the files.

    So has anyone any ideas? After many many years of PC usage, but all my free time used up for the past 4 days, I am seriously a few hours off throwing this all out and buying a Mac :D :D I just can't work out why the setup won't copy the files :(

    I really REALLY don't want to work from a fresh install - gawd knows what apps I can't replace.. plus I have 4 user accounts to re-configure for the family etc etc...

    Any help at all would be appreciated!
  16. rubennunes11

    rubennunes11 TS Rookie


    i need help my laptop is a windows 200 and it doesnt boot properly what can i do i haven got the windos 2000 cd- rom either
  17. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    What exactly do you mean by it doesn't boot properly?
  18. rjmc27

    rjmc27 TS Rookie

    Rick's advice failed

    I'm peeved about following Rick's advise to repair XP on my computer because the entire operating system was reinstalled. Lost all my previous settings and software registry files. Now my PC boots up but years of work customizing and installing software will have to be redone.

    Why was there so much reluctance to avoid the Recovery Console? Slogging through that application would have been much better than re-installing dozens of software applications.
  19. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    I don`t know how running a Repair would reinstall the OS and wipe your data.

    All I can say is I`m very surprised that would happen. Are you sure you followed the instructions correctly?

    I`ve run a Windows repair on lots of systems without that ever happening. I don`t recall it happening to anyone else either.

    Of course, as with any major undertaking, it`s wise to backup important data first in case something goes wrong.

    Nontheless, I`m sorry you lost your data.

    Regards Howard :wave: :wave:
  20. BrendanK

    BrendanK TS Rookie

    Well, this problem looks new

    I've been reading through the posts, and I don't think I've found my particular problem, so here it is:

    Today at about three, high winds caused a moment when the power fluxuated, causing the house's computers to turn off. However when my father's rebooted, he got the message:
    Windows cannot start because the following is missing or corrupt

    The screen also suggested the Recovery system, which made perfect sense to me. I'm not sure where my father's origional Windows Install disk is, but I
    knew exactly where my own computer's disk was (Had to install to a new system drive when my origional was damaged several months ago.)

    I loaded the disk into my father's machine, rebooted from the CD, and it
    loaded to the blue screen with the Windows Setup header, but the gray bar with "Press F6 if you need to install a third party SCSI or RAID driver..." did not appear. The system showed no response to anything except Ctrl,Alt,Del which rebooted the system.

    Initially I suspected that there might be a hardware problem with the 3.5 floppy drive (Which has been on the fritz for years) because the last apparent thing that happened was the floppy drive briefly spun up. Cutting the power to the floppy initially seemed to block the setup from reaching the blue setup screen at all, but replacing the drive with one that worked did not solve the problem.

    Afterward I searched and mannaged to find my father's Windows XP Install disk and tried it, and got the same error. I am completely baffled needless to say.

    Update: After a long series of attempts I couldn't get the Setup started, so after checking procedures online, I pulled the systems harddrive and loaded it into an external drive enclosure. I then plugged it into my system, went to the problem directory and moved the files system, software, sam, security and default to the temp directory. I then set up temperary permission to access the System Volume Information folder, found a recent backup, copied the backed up system, software, sam, security and default files to /windows/system32/config/, and edited the backups to their proper name. I then disconected the enclosure, took out the drive and put it back into my father's computer, and the system booted up with no problems.
  21. roypage

    roypage TS Rookie

    Hi everyone. I have decided to register and join this forum because of all the explanations that I have heard on how to reinstall xp, this was the best. I am one of those that have to press F6 to have xp see my SATA drive. I have had a succesful reinstall. However, I have one small problem. When I turn on my machine I get a beep and the following on a black screen:

    Drive 0 not found
    Drive 2 not found
    Drive 3 not found Serial ATA
    Drive 4 not found Parallel ATA
    Strike F1 to continue, F2 to run the set up utility.

    When I press F1 the system boots into windows with no trouble but I have to do this each and everytime. It is irritating because I use a wireless keyboard and mouse but have to keep a wired keyboard connected to the computer just to hit the F1 key as the wireless keyboard is not enabled until windows loads. Also, would anyone know how I can skip the user screen and just have xp load. I am the only user and sometimes I walk away as it loads and dont hit the Andrew Sr log on. Thanks in advance and I look forward to enjoying and hopefully helping others on this site!
  22. Whitey7787

    Whitey7787 TS Rookie


    Hey guys major problem. 1st I am experiencing the BLUE SCREEN with a fatal stop error. I've tried to boot the reinstall cd but the burner won't read the disc. The cd works in other computers and the burner also works in other computers but for some reason it won't work for me. I was also told that by the computer that the Hard Drive was dirty ( no idea ). Any support on how to even get started would be great. Thanks. Brian
  23. orkarn

    orkarn TS Rookie

    Yes, I have read the sticky post about not posting computer problems, but mine comes with a suggestion. This guide is lacking a solution to what to do if the "Repair" option does not appear in the list of installed OS's. Ideas?
  24. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    This is a quote from the first post in this thread.

    If either of the above is true, then you`re only option may be to format and reinstall from scatch.

    Regards Howard :wave: :wave:
  25. Cuzer

    Cuzer TS Rookie

    XP SP2 Installation issue, can't now use PC in any capacity, HELP! :-(

    Hi all

    First post to this forum and I'm calling a savior.

    Going back to 2004?? This was posted on this forum, page 2 from memory.........

    I tried to repair of my windows XP O/S and it got 3/4 of the way thorugh and hit a fatal error.
    It says,
    "An error has been encountered that prvents setup from continuing. One of the components that Windowes needs to continue setup could not be installed. Incorrect Function"

    So I press OK to see the log and I get this.
    Fatal error could not register OLE control C:\Windows\system32\rsaenh.dll because of the following error Load Library returned error 193(cl).
    The signature for Windows XP Home edition Upgrade is invalid. The Error code is 800b0100.

    This all happens on the Installing Windows part of the repair. I then press ok and the computer restarts and continues to do the same think.

    Can any one help.



    This is exactly where I'm at now and despite ploughing through this forum I'm stumped! I had XP with no SP's installed on my PC, got a CD from our IT department at work which was XP with SP2 on it, with a key code. I've attempted to install this and all is well until it gets to around 75% of installing the files for Windows, the computer then crashes, reboots, restarts setup and does exactly the same thing over and over and over etc etc

    I've tried safe mode etc but it appears no windows OS is installed now as I was 70% odd percent of the way through putting a newer version on. So reading this forum I lgot my PC to boot up the OS from the CD Rom option, got to the repair or install a fresh copy and repair fails to work, the only option left to me at the moment is to install a fresh copy, am I right in saying if I do this I will lose all the data on my hard drives? We're talking so many important documents, loads of money spent on itunes etc this would be a disaster of major proportion to me. What can I do?

    Could it be I've got a bad copy CD of the XP SP2 from my IT dept? If I inserted another CD of XP may it get me past this 70% problem? And if it did would I still have my folders on my hard drives?

    Any ideas would be soooooooooooo appreciated, this is an old PC I've updated over so many years and the information on here is bloody priceless frankly and just attempting a standard upgrade has knackered, potentialy, everything. Here's hoping somebody can help me in some way. I do have my original CD for XP by the way with NO SP's installed

    Thanks in advance, lifesavers, all of you!


Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...