I bought a dodgy laptop. Let's figure out what's wrong with it

By childofthetao ยท 6 replies
Feb 15, 2011
Post New Reply
  1. Hi, I'm looking for some help figuring out what is wrong with a laptop I bought.

    It is a Cybercom MD5958, it had Windows XP installed but it wouldn't boot, I would get the BSOD.

    I booted up from the Windows XP disc, I get to the part where I am to create a partition ( I previously deleted the old one in Acronis Disk Director), when I press C to do so the computer reboots.

    If I boot into Acronis Disk Director and manually create an NTFS partition, set it active, then boot from the Windows XP disc, I press enter to install onto that partition and it gets stuck almost immediately after that at the part where it says "examining disk id <numbers> bus <numbers> MBR . Sometimes it will reboot instead of freezing.

    I have also tried installing several Linux distros, they all freeze early on and I can't tell what part it is that it freezes at.

    I have scanned the entire HD thoroughly with HDD Regenerator and it says there are no errors.

    My thought is maybe the HD is dodgy? But HDD Regenerator said the thing is squeaky clean. Maybe it's an MBR problem?

    What I plan on trying tomorrow (it's bed time now) is creating a FAT32 partition and installing windows 98.

    I also plan on deleting the MBR, to see if that makes any difference.

    does anyone have any ideas on what this could be, or any suggestions for me to try.

    I'd appreciate any help I can get.
  2. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    Have you got any spare RAM to try in it? Any amount will prove the point--even 512MB.
  3. childofthetao

    childofthetao TS Booster Topic Starter Posts: 159

    No, I have no spare RAM. I did run memtest86 but it said everything was fine.

    EDIT: I have removed the HD and ran The Troubleshooters memory test, the computer rebooted immediately.

    I think I'll just have to take this to be repaired, if that's even possible.

    EDIT 2: I just ran memtest86 again, it reboots immediately. I'll have to plug the HD back in and re-test this.
  4. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    Ok, I just see replacing RAM as the easiest test of an unknown pc, takes 5mins and might well be the fault. I would use a 'live' Linux disc next, so you could at least use the pc, so then would point to the hard drive being the culprit in some way, failing sectors, seek arm etc. and would prove stability in the motherboard.
    I guess you would know, but if you try the Linux 'live' disc, the DVD drive needs to be be 1st in boot priority.
  5. childofthetao

    childofthetao TS Booster Topic Starter Posts: 159

    No live CD will boot, not even bart pe, they just freeze at some point.
  6. childofthetao

    childofthetao TS Booster Topic Starter Posts: 159

    OK so I replaced the HD and took out the RAM, I then replaced it into the second RAM slot and now memtest etc is working fine, I'll do some more tests, then test installing an OS.
  7. childofthetao

    childofthetao TS Booster Topic Starter Posts: 159

    Damn thing still doesn't work.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...