I/O error (1117)

By 19giugno ยท 8 replies
Oct 14, 2008
  1. Hi there,
    the hard disk of a friend of mines (with years of pictures on it) suddenly crashed and there is no way to access it.

    When starting the laptop it says "missing operating system".
    I put it into an external USB box, connected to another pc, windows shows the device among the USB devices, but it does not show it under my computer or disk management.
    I tried already at least 30 different recovery utilities, none of them could find any partition or any file on it, altough they are able to show the disk configuration (number of sectors, size, etc.). Some of them gave the I/O error (1117).
    I tried also to mount the disk under Linux, no success.
    Latest temptative was to start the laptop with a DOS cd to run the DOS version of unerase, but it failed too. It simply says that the space under the disk is "unallocated" and that it can read any partition or file.

    What else can I try before taking it to those very expensive recovery companies?

    The file system should be NTFS, there was WIN XP Home installed.

  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

  3. 19giugno

    19giugno TS Rookie Topic Starter Posts: 18

    Hard disk locked

    Hi there,
    I have tried using the Hitachi Drive Fitness test, which I am not able to run because it seems that the disk is locked! Yes for some reasons (virus? hw failure?) the disk is not accessible, there is a user password preventing read/write functions. Well, at least this is what I think. Now the problem is... who set this password? I was using the pc, it suddenldy crashed and after the first reboot the disk became unusable. Is there a way so that I can get rid of that password?

    I am quiet concerned...

  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    I'm pretty sure that you need some type of system (ie NTFS) on the HardDrive for this to run
    How did it go with ZAR recovery ?
  5. 19giugno

    19giugno TS Rookie Topic Starter Posts: 18

    Hi there,
    a quick update. I wrote to Hithachi support and this is what they replied to me:

    "The password function of a drive is a powerful Security Feature. If a
    password has been set on the drive, and you now no longer know the
    password, then you will be unable to access the data or the drive.

    As this is a Security Feature designed to prevent unauthorised access to
    the drive, Hitachi will be unable to assist you further with this request."

    I am lost!

  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    There's always an option, have a look Here (on the live CD option)
  7. 19giugno

    19giugno TS Rookie Topic Starter Posts: 18

    Hi Kimsland,
    the password is the ATA security password, it is on the disk itself, not the WINXP one, so that solution won't wor.

    But thanks,
  8. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Oh !

    Well that's it then

    New HardDrive?

    Actually, maybe post a new reply here, you might get the password for free, if you're friendly enough :) (not from me though, as I don't have this generator (yet!)
  9. 19giugno

    19giugno TS Rookie Topic Starter Posts: 18


    Great news!

    I solved the issue. What I did, after thousands of attempts, I entered the BIOS, inserted a new user password, enabled the disk locking feature, rebooted the machine, re-entered the BIOS, removed the disk locking feature, rebooted the machine and... got the WINXP logo! And the disk works like a charme! How satisfied I am!

    Before yesterday I didn't even know that a password can be set at disk level!

    Thanks for your help.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...