Imation HDD not recognized

Hi , I have just change my PC and my Imation Apollo 2.5 Portable HDD 250GB is not recognized when i plug it in. It only shows unknown device when i go into the device manager.

My motherboard is Gigabyte P61A-D3 currently running on Windows XP SP3

Other external HDD works fine on my PC expect for Imation Apollo. My Imation Apollo definately is not faulty as it can run on other computers, laptops EXCEPT on my new PC! I'm also using it with the correct USB cord as I'm using the same cord to try it on other PC and laptops and it works.

I have tried the following:

1) uninstalling the driver, scan for hardware changes, still the same.

2) Tried changing my OS to windows 7, still the same, read as unknown device.

3) Went to Disk Management, the HDD is not shown there.

4) I have tried plugging my Imation Apollo into every differnt USB port, USB 2 port show it as unknow device, USB 3 ports totoally no response as though i never plug anything in. (All my USB ports, whether USB 2 or USB 3 are working fine as I've tried other devices and external HDD)

5) I have tried going to Bios and disabled my USB 3, still shows unknown device

6) I have tried updating my motherboard with the lastest Bios from GIgabyte server, still shows unknow device.

7) I have tried installing Mass Storage Device Driver from third party, still shows unknown device.

8) I have also tried installing USB 2 drivers, still shows unknown device.

9) I have tried shutting down the PC, plugged off the power supply and waited more than an hour and try, still shows unknown device.

Can any kind experts help me on this? PLEASE! I'm desperate!


Posts: 378   +9
Only thing I could recommend is maybe it didn't install the driver for the hard drive properly once. Try uninstalling all USB Root Hub's and anything left under USB after that and restart. you may need to download the chipset drivers or USB 3.0 drivers from Gigabyte again to reinstall, but they should reinstall after a reboot. Try again then.

If it is still not working on your computer then I see it as a power issue through USB.

Check your power settings, it is usually only an issue with Laptops running on battery, but make sure there are no power settings that would stop it from reading properly (Put it on Performance if it is set to Balance)

Hope this helps.