Web Internet Explorer and Windows Live Messenger and Windows Media Player failing

I seem to have a unique problem, that I've been searching for hours for a solution on. Anytime I try to load Internet Explorer and WMP, the window will appear for a brief second then disappear entirely. I look in to the task manager and it says neither are running. The computer I'm using was riddled with viruses and malware, which I took care of, although it seems that the damage done couldn't be fixed. Windows Live Messenger is giving me error 80040154, and I've followed the solutions, none of them worked. I think that ultimately, something is preventing ActiveX from working, which is stopping all three, because I've noticed one thing in common for all three applications, that Internet Explorer is absolutely required for them to work. I tried uninstalling and reinstalling up to IE8 or 9 and it still won't start up. Games such as Anarchy Online, that have an ActiveX control on the login screen, do the exact same thing, a flicker of a window then it shuts down immedietly. I can find no work around, no repair utility, or anything. My OS is Windows Vista Home Premium x86. Also, a few things I've noticed that I think are related because they came up at the sime time, anytime I install something and it tries to make a link on the desktop, it comes up with an error. I can put one on myself, but Windows Installer can't seem to do it. On top of that, whenever I'd bring up something that would let you say, search for a file through Windows, like if you're installing and it asks for a folder, it comes up blank. I don't know what any of these problems are caused from, but they all started simultaneously. If anyone has seen ANYthing like this before, please tell me so I can attempt to fix this cursed thing. They're relatively minor problems, but it occasionally makes some things impossible to do.

Follow up, what I mean by the searching for files through Windows, is take installing City of Heroes. At one point, it asks where you'd like to install it, the default directory or one of your choice. Whenever the screen comes up for the one of your choice comes up, it either appears blank or force quits the program or installer or whathaveyou. I have nothing but vague terms to google this problem, because it's not coming up with an error or anything, just either a blank window or forcequit.


Posts: 12,015   +81
There is a good chance you are still infected so if you haven't done so already go to our Virus & Malware Removal forum read the UPDATED 8 Step sticky, follow the steps as given and on that forum post with the required logs attached.