Iomega external hard drive not detected but there as USB Mass Storage

By Mandy78
May 18, 2016
Post New Reply
  1. I have read threads and help and have tried everything in the book, for weeks/months, to save my external hard drive. I believe the drive is working just fine and needs re-formatted.
    At one point, when plugged in, it would say it needed re-formatted. I tried to get around this to save my data and now, it only registers as USB Mass Storage under Device Manager and nowhere else.
    I tried USEase Data Recovery and can see my old files but not access them.
    I slightly remember changing something in the command prompt but can't remember what exactly.

    At any rate, at this point, I would be just as happy to somehow erase my data and start from new. (Of course I would rather keep my old pictures but if I can't, it would be just as nice to refresh my hard drive and save what I was able to gather.)

    Any suggestions would be much appreciate before I throw it in the trash!! Thanks in advance.
  2. Cycloid Torus

    Cycloid Torus Stone age computing. Posts: 3,003   +656

    As it is, I imagine it is connected by a USB cable and it is managed by that connection and by some electronics inside the box which tells it how to be read from an IDE or SATA drive into the USB connection.

    If it almost works, maybe the drive is 'ok'. Maybe just something loose.

    If it were mine, I would determine if I could remove the drive and mount it as a second drive on my desktop. First I would look up the drive at the manufacturer's website (Western Digital, Seagate, etc). Then I might try the several ideas about the structure of the drive that are offered in BIOS - particularly IDE and ACHI.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...