IPconfig, TCP/IP, failure?

By kingair_six ยท 6 replies
Apr 5, 2008
  1. Hi,

    recently, while trying to put an old baby on my wifi network, I have encountered several problems when setting the IP adress, or in general trying to configure the network device, a Atheros AR5006X pci wifi card.

    After installing the card, and having it set up according to my network (WPA2 did not work with it, so I had to dissable it for the sake of getting a connection), the Atheros software, as well as windows confirmed a positive association with the AP, however, neither did I get assigned an IP adress nor was any traffic existing from the client side.

    I did some troubleshooting and it turned out that it said, that ipconfig.exe was not working properly.So I went to the command prompt and tried
    ipconfig /all
    to see whether or not my device was at all recognized. It turned out, that the pci card was not even recognized as a network device with ipconfig!

    After than trying to configure an IP in the Properties window, a prompt came up telling me that I had to restart the computer in order for the changes to become active. Did this... Well, and still, the changes were not adapted after the restart (stupid also, I have never been asked this anywhere before in relation to IPs).

    I am kinda hopeless with this, since I have tried several adaptors now, and every single one of the wireless devices had the same problem.

    After this long explanation: does anybody have any experience with this issue?

    Help would be greatly appreciated!

    Thanks, kingair_six
  2. rf6647

    rf6647 TS Maniac Posts: 829

    What does 'device manager' say about this device? Is it listed as a network device? What OS are we working with?

    'Positive association' - probably signifies that the configuration software communicates with the card and detects the 'essid'. Is this close?

    The mobo may place restrictions on the location of the pci card depending on the interrupt handling needed.

    'ipconfig' does not acknowledge this connection; yet there was a network connection / tcpip property sheet?

    Yes, this is a perplexing problem.
  3. kingair_six

    kingair_six TS Rookie Topic Starter

    OS: XP Home SP2

    Device manager recognizes the device as a network device, says it's working fine.

    Properties Tab etc all in place the way it's supposed to be.

    The problem does not seem to be the mobo, I took out the old ethernet and put the wifi card in the same slot, also tried different slots.
  4. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    can you disable the WiFi and try a cabled connection which will allow us to
    get TCP configured for your environment.

    here's some basic tests for TCP (wired or otherwise)
  5. kingair_six

    kingair_six TS Rookie Topic Starter

    yes, I could get a wired configuration set up.

    in addition, here is the report from the trouble shooting utility that is included with the adaptor

    Atheros Troubleshooting Utility
    Troubleshooter report...
    Report date: Sunday, April 06, 2008
    Name: Driver installation test
    Description: This test is to check the radio driver installation.
    The radio's registry keys are OK.
    Nic name. . . . . . . . . : Atheros AR5006X Wireless Network Adapter #2
    Driver name . . . . . . . : Atheros AR5006X Wireless Network Adapter (Microsoft's Packet Scheduler) 
    Driver path . . . . . . . : C:\WINDOWS\system32\DRIVERS\ar5416.sys
    Driver version. . . . . . :
    Active Profile Name   . . : Playroom
    Test Done: The radio driver has been installed.
    Name: Card insertion test
    Description: This test is to check the radio insertion.
    Test Done: The radio has been inserted.
    Name: Card enable test
    Description: This test is to check if the radio/driver is enabled.
    Test Done: The radio has been enabled.
    Name: Radio test
    Description: This test is to check if the radio is turned on.
    Test Done: Your radio is turned on.
    Name: Association test
    Description: This test is to check your client adapter's association to an access point.
    Link Status . . . . . . . : Associated
    AP Name . . . . . . . . . : unavailable
    AP IP Address . . . . . . : unavailable
    Test Done: Test passed
    Name: Authentication test
    Description: This test is to check authentication.
    Test bypassed: Authentication test bypassed, because authentication is not in use.
    Name: Network test
    Description: This test is to check your network settings.
    Fail to execute ipconfig.exe
    Test bypassed: Network test aborted
    Test completed.
    the first of the tests, pinging localhost is doing fine, I am running apache on the computer as part of a web developement environment, that is working as should.
  6. rf6647

    rf6647 TS Maniac Posts: 829

    This topic posted here and google for "ar5006" tend to indicate device driver issues are common for this product.

    The topic noted above successfully used substitute drivers.
  7. kingair_six

    kingair_six TS Rookie Topic Starter

    alright, so I tried the sub drivers and they did not work either. I have one driver at least giving me access to the config utility, the others did not. I don't know the version atm, so I will check that later. Even with this driver though, I cannot connect, now that I reenabled WPA especially it does not even show "Associated" any more... very confusing.

    appreciate the help!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...