Issue with Steam update

By Dawn1113
Feb 20, 2013
Post New Reply
  1. I've been trying to fire up Metro 2033 again for the better part of the day but have been unable to run the game due to a problem with Steam, apparently. When I click on the game's shortcut, Steam attempts to install an update, but is interrupted. I then get a message that says, "Unable to open SteamTmp.exe for writing."

    Steam support insists that it is either my anti-virus software or Windows Defender. I've tried disabling both -- and the firewall, too -- to install the update. No go.

    This is the first time I've encountered an issue with Steam for which I've been unable to find a solution online. Does anybody have any suggestions? I'd really like to avoid the hassle of uninstalling everything at this point.

    Any help will be greatly appreciated.
  2. Dawn1113

    Dawn1113 TS Booster Topic Starter Posts: 322   +65

    Problem solved, finally! I did some deeper digging and found a solution.

    If you ever run into this "Unable to open SteamTmp.exe to write" error and Steam is unable to install updates, just go to your Steam folder (I have mine installed on a drive separate from my OS, but by default I think it's "C:\Program Files (x86)\Steam") and scroll down to the "SteamNew.exe" file.

    Run the executable and Steam should begin updating -- even faster than the usual route, I might add. Cleared up the problem for me in a matter of seconds.

    Though I'd post the fix. Might be helpful.
    Gunner87, cliffordcooley and St1ckM4n like this.
  3. LNCPapa

    LNCPapa TS Special Forces Posts: 4,276   +461

    Thanks for the info Dawn! Always helpful when people post the solutions to problems even if they fix it themselves. :)
  4. Gunner87

    Gunner87 TS Member Posts: 32

    Thanks for the info Dawn. Helpful.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...