Laptop not functioning

By vivin.uppar ยท 8 replies
Jul 29, 2008
  1. hi, my name is vivin
    i have a toshiba laptop (satellite A135-S4527). it's not working.
    the power indication light is on when i press the 'power button' but computer doesnt start.when i connected it to the dc supply.the battery indication light(when working normally is orange if not fully charged and blue if fully charged) is not lit only. i tried takin off the battery from laptop and running it from the dc supply alone, still its not working.
    please help.
  2. BAW

    BAW TS Rookie Posts: 16

    Sounds Like the graphics card or connection between the screen and the unit! But im not 100% sure i dont do laptops :)
  3. mscrx

    mscrx TS Rookie Posts: 310

    does that laptop do anything that sounds like booting up behind the black screen? hdd or fan(s) spinning? you could try alot of other things. remove memory bars, battery, dc, any pcmcia cards, if posssible the dvd drive and hold the power on button for like 15 seconds to get all power out of the circuits.. then attach every part you took off one by one and retry to switch it on again.
  4. lamo

    lamo TS Rookie

    try to reseat memory sticks. another issue may be connected with broken BIOS ROM.
  5. vivin.uppar

    vivin.uppar TS Rookie Topic Starter

    thnx..... i tried using a new memory sticks... wat's the olution for the broken bios rom....i mean should i consult a technician to do it..or can i do it myself...
  6. vivin.uppar

    vivin.uppar TS Rookie Topic Starter

    thnk u very much for the reply.....
  7. vivin.uppar

    vivin.uppar TS Rookie Topic Starter

    thnk u.....
    the fan does run, i can feel the cool air coming out.. but that's for a very small time... not even 3-4 seconds... i get some weird sounds..something like a dvd running in the drive(but there's no disk in the drive)'s a very mild sound... and that also is only for a second or two.....
  8. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

  9. lamo

    lamo TS Rookie

    you need to reflash the bios chip... i think, it will be better to consult with some technician who knows what to do
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...