Leopard update breaking simple access to Windows shares?

Not open for further replies.


Posts: 10,592   +453
This is an interesting problem and unfortunately I don't know the cause (or solution). Its fairly longwinded and I'm not sure how to describe it easily, so if you can try to struggle through my description and provide any advice I'd appriciate it.

My Powerbook G4 came with Tiger, and I have an old G4 PowerMac that has Panther on it. In both of those OSes if you double clicked networking in the sidebar of the Finder you could see the computers on your Windows network. When Leopard came out, in the sidebar of the Finder was a list of computers on your network, making access to them quicker. It was really slick because you only had to log in once, ever.

Basically what would happen is you'd single click on your Windows machine in the sidebar, and then a list of shares would come up in the main window of Finder. Then you'd double click whichever one you wanted to mount (no asking for password after your first access).

I was so impressed by this I also put Leopard on my Mac Mini (intel). It also worked great, for a time..

Now both my Powerbook and Mini no longer see Windows computers in the sidebar at all (they still see their Mac brothers though). And now the only way I can connect to one of my Windows machines is to go to the Go menu -> Connect to server -> then enter the smb address (smb://Athlon64 for example).

Somehow I lost that cool sidebar functionality to connect to my Windows machines and I'd like it back. Since this happened on my Mini as well as my Powerbook I don't believe its any configuration I changed on the Macs themselves because I would have had to have duplicated my changes on both machines (and I'd remember doing that). So I'm thinking maybe an update did this. Googling produces some results, but the severity of people's networking issues with Windows and Macs varies widely. Digg had a submission with several comments on problems browsing SMB shares, some of the comments are similar to my problem, but I didn't find a solution. And its not that I can't browse smb shares, I can still get to them manually, its just an inconvienence to do so.

Another interesting but probably unrelated oddity is that on my Athlon64 system I have a complete drive shared. From Windows I can see and access everything on that drive, if I try to connect to that from a Mac (Mini 10.5, Powerbook 10.5, or PowerMac 10.3) I get a blank directory. As in it mounts, but I don't see any files or folders, the Macs (all of them) do correctly report the amount of free space on that drive (bottom pane of the Finder window).

The Athlon64 machine is running XP SP2.

I have a Vista SP1 machine that also used to show up in Leopard as described above, it no longer does. I can still connect to it through the manual method I outlined above (same as how I get to the Athlon64 machine).

There should not be any permissions issues, but that brings up something interesting. If I connect to the Vista machine, I connect as Dave, which is the same account I use when using the Vista machine. I have several dirs shared on that, and when you connect through the Go menu (typing smb address) you have to choose a dir to mount. Once that dir is mounted though Main (the vista machine) shows up in the sidebar like it used to. If I click on that, it shows me all avaiable shares and I can connect to any of them without problems. If I try and connect to my Athlon64 machine for some reason (probably how I connected the first time) I'm always logged in as Guest. If I click on Connect As... as seen in the pic below

The window disappears, athlon64 also disappears from the sidebar, and I'm not presented with a login screen. If I specify the user in the smb address (smb://sngx1275@Athlon64) it still logs me in as guest. This probably has nothing to do with the main problem of the Windows machines not showing up in the sidebar anymore, and I'm not all that concerned with fixing it at the moment.

The real problem is I would like to get my Windows machines to show up in the sidebar again.


Posts: 13,810   +3
I realize you're quite thorough in analyzing these problems.
But it may be as simple as a cacheing error.
With the amount of logs and temp files moving around, my first options are always start clean, even rebuiding the network clean (ie remove all settings first)

Just a simple thought, that has worked before


Posts: 13,970   +1,778
Vista is known to have such issues :( (due to the new Network Discovery Service)
Vista FS: http://technet.microsoft.com/en-us/library/bb727037.aspx

you do NOT 'need' NDS as SMB sharing works fine; recommend disable this service; just open ports 135,138,139,445 in the firewall

even Smb Sharing can be a problem to non-windows systems
(see https://www.techspot.com/vb/topic101142.html and kb299656

With Windows NT, which was the first Business Class Operating System, Microsoft developed NTLM ("New Technology LAN Manager") Authentication, and added Kereberos. And with NT V4.0 SP4, they developed VTLM V2 Authentication. Computers running Windows 2000, and Windows XP, will negotiate individually with every other computer, and use either LM, NTLM, or NTLM V2 Authentication, the best protocol that's mutually usable, in all conversations with that computer.

Vista, by default, only uses NTLM V2 Authentication. If you have Windows 9x computers, this won't work out of the box, since Windows 9x is limited, in default, to LM authentication. If you're networking Windows 2000 and XP with Vista, they will all use NTLM V2, with no problem. If you add a computer running Windows 9x, or an NAS device with an unknown operating system, into the discussion, you have 2 choices.

* Downgrade Vista. Let it use LM Authentication, when necessary. Microsoft doesn't recommend this. To do this, edit the registry, and set value LmCompatibilityLevel, in [ HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \Lsa ] to "1". If you're having a problem with your NAS device, this may be your only solution, since not all NAS devices can be easily upgraded.
* Upgrade your Windows 95 / 98 computer, to (KB239869): use NTLM V2. Microsoft recommends this solution.


Posts: 10,592   +453
  • Thread Starter Thread Starter
  • #4
Kimsland, I may give that a shot, just redoing everything on the Mac end. I never configured anything before aside from entering my wireless password to connect to the network. The windows machines showed in the sidebar on the first connect to the network.

jobeard - I can access both the Vista and XP box if I do the smb://computername.. But there may be some differences in how Leopard connects or at least sees the Windows machines in the sidebar compared with forcing an smb connection. I don't understand networking enough to know if the authentication types are related to my problem.

Again, the problem can be summarized as: I no longer can see Windows machines in the sidebar of both of my OS X 10.5.2 machines.
Not open for further replies.