Limited or no connectivity help

By carlos315
Oct 1, 2008
  1. i have a dell dimension c521 that was given as a gift, when i got it it didnt have a OS but i was given a CD with windows xp w/sp3 after installing it i tried to go online and my network connection only gets limited or no connectivity i ran the diagnostic that comes with IE and it says "Error attempting to validate winsock base providers :2 not all base service provider entries found in winsock catalog" , this is a home pc not connected to any network, i know the isp is working because i'm on another pc connected to the same modem, bare with me as i have to keep switching the monitor and wires, i ran the winsockxpfix but it didnt help i dont know whats going on, the pc used to work until i put in the new hard drive and installed xp, if you can guys can help in any way it'd be deeply appreciated.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

  3. carlos315

    carlos315 TS Rookie Topic Starter

    i did them both, i also tried disabling network adapter and then enabling, i tried lspfix , xtpcprep, i uninstalled then reinstalled the network adapter, i did the netsh winsock reset catalog, i did the netsh int ip reset reset.log, i'm just at wits end i dont know what to do ......could it be the adapter itself is bad, because when i plug in the cable the orange light comes on, but if i lower the speed from 100 mb to 10 mb the light is green, but it doesnt help,...oh and the OS came already activated on a CD, so when i installed it was ready to go when the installation was complete i hope any of this helps
    ....i have comcast high speed and it works fine on the pc that i'm on, but when i hook up the other one i get limited or no connectivity
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Could be your CMOS settings (Network disabled)

    When you first start your computer, you should notice a prompt (like DEL or F2 or some key!) to get to CMOS
    Once in CMOS locate "Set Defaults" (label may be different) then select it
    Save and exit CMOS

    Or it could be your Antivirus or Firewall (please uninstall both fully) not just disable!

    Or it could be a faulty network card, as you said

    Also have a look at:

    Viruses/Spyware/Malware Preliminary Removal Instructions
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...