Hardware Logitech Rumblepad detected, but doesn't work

So a few months ago, I borrowed a controller from my friend and it was a Logitech Wireless Rumblepad F170. It worked fine and dandy, I used this controller to play games as well as make some in Godot.

However, I stopped using the controller for a while (2 weeks) but it was still plugged into my computer. Then I decided to try out Rocket League today so when I tried using my controller, nothing worked. I tried using it on other computers, still no use. I use Linux Mint 20 and jstest-gtk shows that it is detected but when I press any button, it's not detected.

This is what shows in that utility:
Screenshot from 2020-09-29 20-32-23.png

When I try to calibrate, it still doesn't find any movement from my controller. Also, it doesn't light up or anything when I press the center button of the controller. Batteries are fully charged too.
 

Cubeputer

Posts: 146   +16
Try to go into device manager, then find your controller, and update the driver. Here is a how-to video.
 
  • Thread Starter Thread Starter
  • #3
This is not exactly the issue, that is what I had done in my windows dualboot. The problem is with the controller itself. It usually blinks a green light even when not connected to any device. There are no problems with the drivers in linux too.
 

Cubeputer

Posts: 146   +16
Hmm. That's really weird. Do you have any other computers to test it with? And do all the usb devices on your working correctly?