1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Many MP3s/podcasts don't play in Chrome, but do in IE/Firefox

By AJM ยท 4 replies
Mar 17, 2012
Post New Reply
  1. Sorry if wrong section, or if this has been discussed previously, and for my poor tech knowledge.

    OS: Win 7 64-bit

    I have noticed that Chrome wont play certain MP3's/podcasts in-browser, when IE & Firefox play them fine.

    For example [apologies for kooky subject matter]:
    I was going to post link but wont let me as I'm < 5 posts. So if you google:
    Naked Scientists Podcast Was Swine 'Flu Man-Made?
    Should be top link, then click 'Listen Now'

    The player appears in Chrome but greys out, fails to upload MP3

    Firefox & IE use Quicktime to play it fine, but Chrome uses HTML5video ? which seems more fussy about what it'll play.

    Is Quicktime even available on Chrome? If so how can I make it the default player?

    If not, is there another way to play MP3's / podcasts in-browser, in Chrome? A plugin or extension perhaps? or a setting?

    I've got used to Chrome now, have switched from FF, as it seems faster on my PC and I like the stripped down, basic look and functionality. However, I'd rather not keep switching to other browsers when coming across an MP3 it doesn't like, and I'm too lazy to download the MP3 manually.

    Any advice or solutions would be appreciated
  2. Rabbit01

    Rabbit01 TS Evangelist Posts: 787   +58

    I just tried the Naked Scientists Podcast site. Like you, it worked in FF but not in Chrome. Not sure why, but the simple work-around is to change the User Agent setting of Chrome to something like Fire Fox 7, then reload the page. Worked for me.

    On the podcast site, press ctrl-shift-i. Then click on the gear icon at the lower right corner. You'll see options for Elements, Styles, Network, etc. Check the box next to Override User Agent under the Network settings. From the drop-down list, pick FF 7. Then reload the page.

    As for QT plugins, my Chrome browser uses the QT plugins in my FF's plugins folder.
  3. AJM

    AJM TS Rookie Topic Starter

    Thanks for the tip, I changed the user agent, as suggested, clicked reload, and had the same issue. I tried it with all the FF/IE options. The default player just greys out, MP3 fails to upload.

    I suppose there could be any number of reasons why it works on yours but not mine, but thanks anyway.

    btw, how do you get Chrome to access FF/IE plugins/extensions, if thats what you meant?
  4. Rabbit01

    Rabbit01 TS Evangelist Posts: 787   +58

    Darn, was hoping that would work, since it also worked on my work laptop running Win XP Pro.

    I didn't do anything w/ the plugins. FF is my default browser. I think when I installed Chrome, it searched my hard drive for compatible plugins. These are the plugins Chrome is using from FireFox's plugins folder:

    Windows Media Player
  5. Rabbit01

    Rabbit01 TS Evangelist Posts: 787   +58

    Strange, it's working in Chrome now. I clicked on Listen Now, then the browser window turned gray, and the player showed up on in the middle, the progress bar began moving and the podcast started.

    I like the interface in FF better. A small window pops up and there's a play list. You can bookmark that URL in Chrome and have the same effect.


    Or subscribe to the RSS feed. You can pick your RSS reader from the Chrome store: https://chrome.google.com/webstore/search/rss

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...