MAXTOR SATA 300GB HD not recognized by BIOS...

By PRELUDiCON ยท 91 replies
Dec 20, 2004

    PRELUDiCON TS Rookie Topic Starter

    OK...with nothing running in the background, here are my best results from the 300G drive...

    For comparison's sake, here is the results from my 120G drive...

    One thing I've noticed, is that the higher the Access time, the higher the Avg. Read rate, and vice versa. Should it not be that the lower access time would yield the higher Read rate??

    And what's up with the BURST speed!!??
    These are both SATA 150 drives!! Shouldn't they be @ leasting hitting 140?

    EDIT: You think I should send these results to Maxtor and see what they have to say about them?

    Or it won't be of any use as they will probably try to make excuses why the results are probably not accurate...

    PRELUDiCON TS Rookie Topic Starter

    BTW...I booted my machine with the flash upgrade tool, and was only able to see one drive ... the 120G [6Y120MO]...

    Is there a way you can choose drives???

    The 120G drive is connected on SATA-1, and the 300G on SATA-2. Does it just locate the first one in sequence and that's it?
  3. LA Fred

    LA Fred TS Rookie

    I'll have to redo the upgrade firmeware to be sure, but I thought it gave me the opportunity to reject the drive showing and move to another one.

    I forgot to mention the burst speeds shown on my three drives. This is with the quick test and with whole system running. The results may be a little skewed because of that, but at least they are all compared with the same background.

    WD Raptors RAID, Stripe 0 = 116.0
    WD 250 ASTA = 79.1
    Maxtor 300GB SATA = 135.3

    I ran all test twice, to be sure I did not get confused on what the Maxtor showed.

    Another point I'll not go into here. To help me on this, I bought Noton's Partition Magic v. 8.0. Yesterday, I decided to download the upgrade to make it v. 8.1. The upgrade wouldn't take, telling me that my Install software was corrupt. One thing led to another and another, etc. It seems that Service Pack II for Windows XP screwed up something in the Install software that affects the newer upgrades. I have been working all yerterday afternoon and night removing EVERYTHING on my computer, including the Registery, having to do with Symantec (per Symantec's instructions). This morning, I tried the big reinstall, and now find another screwup I don't understand concerning PARENT.MSI.

    We didn't have all of this mess when DOS was king.

    PRELUDiCON TS Rookie Topic Starter

    Well, looks like the our 300G drives are performing more or less consistently. Good sign I guess. Still well below Maxtor's spec of "<9.0 ms Average Seek Time". I think I will definately bug the hell out of Maxtor on this one, this is very unacceptable. It's not like we bought these @ Joe's Fish And Chips And Harddrives. :monkey:

    BTW...I did all my tests using the LONG 32MB setting...found I got slightly better results that way.

    PRELUDiCON TS Rookie Topic Starter

    LA Fred...

    After you upgraded to the new firmware...what firmware does it show you have now??

    Is it like the filename BANC1BMO or what ??
  6. LA Fred

    LA Fred TS Rookie

    Yes - it's BANC1BMO.

    PRELUDiCON TS Rookie Topic Starter

    I sent my HD Tach results to Maxtor and got the following response...
    Apparently it's 'normal' for a drive to have nearly double the access time as specified.

    As far as the firmware is concerned...I sent them also another personal complaint and request for a firmware upgrade to which I got the following reply...
    I then replied that I'm not satisfied with the response and they quickly followed up with this...
    The file I got from them is the same as the one you [LA Fred] sent me...
    I'm confused why in #7 they mention that the new firmware code should be BANC1B10...when that is my current firmware version and the filename is BANC1BMO...this is why I asked what is your new firmware showing.

    I would also want the original firmware from them which I requested and they just sent me that one... It's so difficult to deal with these people, I should just leave my system as is. Only thing that bothers me is that I'm using BETA bios version to hold my system together...and unsure if it's doing more bad than good....just sent another email to ASUS 2 days ago, the still haven't replied as to why they don't have this revision on the US website...since they have a section for BETA downloads...urgh
  8. LA Fred

    LA Fred TS Rookie

    I would almost bet that I saw the firmware as BANC1BMO when I did the install. I had better be sure. Tell me how to find it.

    - - -- - -

    That's OK -
    I looked it up in Device Manager. Here is what it shows:


    (20 was written 12 times)
  9. Cumbria

    Cumbria TS Rookie

    Ok, I have 2 x Maxtor 10 250GB/16MB drives that would not be recognized on my MSI Neo 4 Platinum and after sending the board back as defective and getting it cross shipped and replaced (Thanks MWave.), then flashing the MB and NVidia RAID Bios no luck, even with the latest BIOS version meant to specifically address this issue. The drives run fine in RAID 1 on the SiL RAID5 controller but not on the Nvidia, anyway after much research I found a BIOS flash for all of these Maxtor 16GB drives that fixes the problem absolutely. Rebooted cold and they are now always seen on the NVidia RAID so tomorrow I will be moving off the SiL to full NCQ goodness at last... Oh yeah the fix.. well I am afraid you are not going to like it, this flash will not work on the controllers you probably all have, basically the same limitations as the Maxtor Powermax utility. If you are running on any type of RAID controller the flash utility will not run, or worse partly flash and kill your drive, you need to find find a Motherboard with just a plain SATA controller, such as on the SOYO Dragon KT 600 that I happened to have on my spare computer... If you can find / beg / borrow or steal such a beast then go here MSI Forums and download the Sabre 1B Code Zip File It might be a good idea if anyone can host this so there are multiple places it is available.

    Here is the text from the original post in case it disapears also

    Anyway, the general process involves

    1. Unzipping the files to a boot floppy
    2. Boot to floppy
    3. At the A prompt type g.bat
    4. Dont touch it until it says it's finished.

    Finally once again.. DONT DO THIS IF YOU ARE ON A RAID CONTROLLER!!!! I could not get it to recognize the drives on the NVidia or the SiL, my guess is, if you can use the Powermax Util you are fine, if not DONT RISK IT...

    Good luck.. This finally does really once and for all fix the issue....

    One final note, if you guys and Gals can cross post this on any other Forums you frequent we might finally get this issue put to bed once and for all.

  10. LA Fred

    LA Fred TS Rookie

    Now that you have them up and running, why not download HD Tach and see what the average access time is.

    With the 6B300S0, they advertised <9.0. Both of us posting here found it to be >16.0. Maxtor said that was "within normal operating range."

    I'd like to see what you get as opposed to what they led you to believe you would get.
  11. Cumbria

    Cumbria TS Rookie

    I'll do that tommorrow or Sunday. As I am moving from the SiL RAID 1 to NVidia RAID1 it is redo time...
  12. LA Fred

    LA Fred TS Rookie

    NOTICE -

    ASUS just posted an new BIOS for my MB. It is #21, a number higher than the BETA I downloaded.

    Better check and see if yours has just been upgraded.

  13. mixmastaroberto

    mixmastaroberto TS Rookie

    Asus P4P800 Bios does not detect Maxtor SATA HD on cold boot.

    Hi, I've been reading various posts about Asus bios not being able to detect large Maxtor SATA HDs on cold boot, but being able to detect (sometimes) upon reseting.

    So far i've seen 3 types of fixes.

    Update Maxtor HD Firmware
    Update Asus Bios from Germany ftp - Beta
    Ground plug on SATA power cable

    Before i try any of the above i just want to say that i've noticed a pattern in my set up...

    I have an external USB HD. When i cold boot with the USB HD turned off, the bios will not detect the SATA HD. But if turn the USB HD on first then cold boot, the bios will detect the SATA HD!

    I think the bios is too fast or not waiting long enough to detect all HDs and the SATA drive takes too long to power up. When the USB HD is plugged in, the Bios takes extra time to detect it, and that little bit of extra time is enough for the SATA drive to power up and the Bios can see it.

    I just discovered/hypothesize this on accident and still need to 'prove' a few more days to really confirm.

    Has anyone really 'solved' this problem? i've seen links posted on this forum for updated Bios and Firmware but i'm not sure if those are for my specific models.

    Here are my specs:
    Asus P4P800 running bios 1019
    Maxtor SATA 250GB HD (6B250S0 BANC1B70)

    No RAID - my bootdrive is IDE and works fine, the SATA drive is for extra storage space.

    Right now my bios is set to SMART enabled and auto detect. I increased the HD detect time to maximum 35.

    i will try to put my bios settings to defaults and try again to prove if the USB drive being turned on is really doing the trick.

    If it proves, then i don't need to install the German Beta bios, but let me know what you think about updating the Maxtor Firmware...

  14. LA Fred

    LA Fred TS Rookie

    Try the new ASUS USA BIOS before you go any further. I don't know the number of the P4P800 BIOS, but for the P4C800-E Deluxe it is 1021. The little write-up they post with it (if you press "more") says it addresses SATA problems.

    Also, it would be very interesting if you downloaded and ran HD Tach before you applied a new Maxtor driver (and let us know what it shows). They seem so reluctant to give out that driver that I suspect it might a generic type of driver and not necessarily the fastest.

    Two two of us posting here who have applied the new driver are getting an average access time of >16ms, far slower than the <9.0ms they advertise.
  15. Cumbria

    Cumbria TS Rookie

    Yes.. The Maxtor BIOS update fixed the problem and since flashing the drives they are detected 100% of the time. This unequivocally fixed the problem.

    I don't think I can be clearer than that.
  16. Cumbria

    Cumbria TS Rookie

    I think you are taking the access times into consideration without allowing for rotational latency which is how they are spec'd by the manufacturer. Take for example the WD800JB specs from Western Digital:

    Buffer Size 8 MB
    Average Latency 4.20 ms (nominal)
    Read Seek Time (Average) 8.9 ms
    If you add the Average Latency to the Average seek time you end up with a random access of 13.1ms

    I chose this drive because I have it on the same system as the Maxtor 6B250S0 I had problems with. So I ran HD Tach (Quick) on this drive and end up with:

    Random access 13.4 ms
    Average Read 41 MB/s
    Burst Speed 96.4 MB/s

    Well within the average

    So now I ran HD Tach on the Maxtor, bearing in mind I have 2 drives in RAID 1 so this might skew the results slightly.

    Maxtor's site reports the following
    Average random access <9 ms
    Average latency 4.17ms

    add these together and you get 13.17ms

    My HD results are:

    Random access 14.5ms
    Average Read 46.4 MB/s
    Burst Speed 138 MB/s

    Ok it is off by 1ms but That is within 10% which is the best you can expect at these speeds and close enough that I am not complaining.

    Both of these were on the NVidia 4 Controller, the Maxtor on the SATA in Raid 1 the WD on the EIDE port.

    CPU AMD64 3500+ 90nm
    Memory 2 GB G-Skill CAS 2
  17. mixmastaroberto

    mixmastaroberto TS Rookie

    Hi, thanks for reading my post.

    Asus bios version 1019 is the most recent for my model P4P800 motherboard on the US Website. Ther German ftp link does have 1021_02Beta.

    i ran HD Tach and attached the results as jpg to this post.
    I've read here that the Maxtor firmware update may cause the drive to be slower (longer random access time). My random access time is currently 14.9ms.

    I set my current mother bios (version 1019) to defaults and only changed the "HD Dectect time" setting from 'Quick' to 'Normal'. Turn on my external USB HD first then cold boot my computer and have been able to detect my Maxtor SATA HD!!! I've done this a few times and it has proved to work consistently.

    What do you advise?

    Fix Part1 = use Asus beta bios

    Fix Part2 = use Maxtor firmware (does anybody have a link and instructions for this firmware??). Plus, if it does slow down my drive's access time then how do i revert back to my current firmware?

    Use method described in Part3. If it continues to work, why fix something that ain't broke.


    Also want to mention that i've had burning CD's when the data is being read off the SATA HD (i would get buffer underrun errors). When i copied the songs to my C:\ drive, which is a regular IDE HD, I was able to burn CDs just fine.

    Other than that, reading and writing to my SATA drive has been fine. I Ran HDTach on my IDE HD and the results show average performance for IDE. I compare that to the HDTach report for the SATA and see the obvious benefits of a SATA HD. so other than burning CDs off a SATA HD, it's all good. I even ran the Maxtor HD Utility that runs on off a Floppy on DOS. It does a diagnostics test on all my HDs and said they are all working fine, no errors.

    Do you think the CD burning buffer underruns are related to my Bios not being able to detect the SATA HD?

    thanks for reading about my computer drama.
  18. LA Fred

    LA Fred TS Rookie

    Mixmastarobereto -

    Just to see if ASUS - USA had come up with anything new in the last hour, or so, I went to the web site. When I entered P4P800, it came back asking me with of the 11 versions of that MB I wanted. Acting under the assumption that they all used the same one, I went ahead with just P4P800. (I think there is a difference in the various P4C800 MBs.)

    In the P4P800 BIOS Beta section, they show 1020.002 as being available. Some of the other posters here assured me that the they have had no problems with ASUS' Betas. I went ahead and did it. I also had no problem with the Beta.

    As far as getting back to the original Maxtor firmware, forget it. I asked them about it and they didn't even have the courtsey to reply. So, it might be wise to look into this a little more before you do it.
  19. mixmastaroberto

    mixmastaroberto TS Rookie

    i just checked the Asus website and the newest P4P800 bios they have is version 1019

    that other file is Afudos 2.11 is a file that is used to update the actual bios.

    I will try the German version 1021_02BETA.
    if any problems i can always revert to the current mother board bios version 1019.

    i'll run HDTach to see if there's any difference and post back results.

    Regarding Maxtor firmware; Without a way to revert back to my current version, i prolly won't try it.

  20. LA Fred

    LA Fred TS Rookie

    If you go to the USA ASUS BIOS download page, you will see two boxes in red up at the top, middle of the page, just to the right of the name P4P800. One says RELEASE and the other says BETA. The default page that pops up is the release one. Click BETA and you will see the one I was speaking of.
  21. mixmastaroberto

    mixmastaroberto TS Rookie

    doh!, i didn't realize the Asus website had the beta button to access the beta versions.

    Anyways, I updated to the beta bios and it still does not detect my SATA drive on cold boot. I tried with the bios settings to default and also tried it with it set to increase HD detect time but it won't detect.

    i just turn on my USB HD first then all is well.

    Can someone please post the link and instructions to the firmware for the Maxtor SATA HD model 6B250S0. Also, let me know if the drive's performance was affected by updating firmware.

  22. djvga

    djvga TS Rookie

    No Upgrade

    Hi, I decided to try Sabre 1B Code Zip File from the MSI site. This should be firmware upgrade for all Maxtor drive models starting with 6B or 7B. Mine is Maxtor 6B300SO, but this update tool, told me that my HDD is not supported by this version of firmware. There was an option to press some key to upgrade it anyway. I try this, but the same error comes up no matter how many times I try :( , just wanted to try... no luck
  23. LA Fred

    LA Fred TS Rookie

    You have to contact Maxtor Support on-line. I don't know why, but the "first level" of support cannot download the upgrade. The "first level" will then get you in touch with the people who can download the fix.

    The patch they gave me is BANC1BMO. There is some concern that the new firmware (or driver, I don't know which) causes the average seek time to slow down.

    It might be a good idea to download HD Tach and test your drive both before and after the fix. If you don't mind, post your results.
  24. mixmastaroberto

    mixmastaroberto TS Rookie

    well, turning on the usb HD first is not working 100% of the time for me anymore.

    so i will contact Maxtor and ask for 2 versions of firmware (the update and my current version incase i have to revert back).

    i've already ran HDTach and had about 14 seek time.

    i'll update firmware and re-run HDTach and will post results.

    PRELUDiCON TS Rookie Topic Starter

    Just curious which BETA did you use...German or U.S. ?

    And just to update again...

    I was entertaining the idea of flashing the drive, but decided against it after all the trouble I've been having trying to get the original firmware from Maxtor, I don't want to chance it when I really don't need to. The BETA BIOS update (1021) from the German ftp site is working perfect 100% after dozens of cold boots.

    I was informed that the Maxtor SATA drive requires a longer detection time for it to 'shake hands' with the BIOS. On cold boot, both drives are read instantly now, I find this odd. No delay @ all.

    My personal opinion is that the MoBo is older than the drive, if anything needs to be flashed it's the MoBo.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...