MAXTOR SATA 300GB HD not recognized by BIOS...

By PRELUDiCON · 91 replies
Dec 20, 2004
  1. StiebZ

    StiebZ TS Rookie

    i think it's ok when it doesn't show up in the bios

    just install your XP and press F6 (during installation XP) when asked &
    install the SATA driver ( from the ASUS cd ? or dowload it upfront )

    that should do it
  2. sram

    sram TS Rookie

    Thanks Stiebz. I hit F6 while loading Windows XP and it is expecting a Floppy disk labeled Manufacturer supplied Support disk. I got a CD from ASUS which had some drivers for different O/S and copied them on to a floppy disk and inserted that when asked. But, it still keeps asking me to insert the floppy disk over and over again or quit. Wonder what could be wrong??
    Pl. advise. Thanks much.
  3. sram

    sram TS Rookie

    OK. The link below has very good instruction on how to get Windows XP setup and have your HDD be recognized. This is exactly what I was missing (and needed). Just thought would post it in case it might come in handy for someone.
    Thanks again for the initial guidance...that pointed me in this direction.
  4. trex_dk

    trex_dk TS Rookie

    Same problem, but this time:
    Asus A8N-SLI Deluxe motherboard
    Again: Maxtor 300gb SATA disk (6B300S0)

    Whenever I power my computer down for a longere period of time, it won't detect ANY of my other drives at all (including the 300gigs)!
    My other drives is:
    2x Maxtor 80gb IDE drives
    Plextor DVD drive and a NEC DVD writer (can't remember the model nr., but it's brand new!

    I usually try to disconnect all drives and then reconnect them, and after a couple of tries, it will probally work - not every time tho :suspiciou

    edo075, I would like to hear more about your solution to the problem! What bios update did you exactly use?

    Best regards
  5. sram

    sram TS Rookie

    Have you tried/followed the process laid out in the link that I had forwarded? What OS are you using?
  6. trex_dk

    trex_dk TS Rookie

    I think it's working now, I have just flashed the bios to a new beta. I found it on the german ftp that PRELUDiCON linked to!

    So thx everyone! It helped me a lot!

    PRELUDiCON TS Rookie Topic Starter

    Glad it helped !! :grinthumb

    To system has been working flawlessly ever since I upgraded my BIOS to the beta version found on the German ftp site.

    I remember seeing stuff on that site for other ASUS boards as well.

    And I cannot believe that the North American ASUS website STILL does not offer this version for download!! WTF!? :unch: (makes me wonder if there is any particular reason for this or they're just being overly anal)
  8. djvga

    djvga TS Rookie

    Maxtor SATA 300GB Bios detection SOLVED!

    Applies to all Maxtor DiamontMax & MaXline SATA drives! (Mine is 300 GB, 7200 rpm, 16 MB Cache SATA on Gigabyte 7N400 Pro 2 rev. 2)

    Many people including me, can not recognize this drives or their motherboards are recognizing them hard, and mainly have problems with detecting them when cold boot.

    All this drives have feature calld "Staggered Spin-up Detection". This feature is for servers &/or more than 2 drives to power up one by one, this makes the power supply's work esier when turning on such a system. This also makes it possible to run machines with multiple HDD's with lower power supplyes. They are cheaper also. Anyway this feature must bi off (Disabled) on PC's, or when there are one or two HDD's on the system.

    By the SATA specifications the SATA HDD power cable is with 4 pins on the PSU side & 15 pins on the HDD side. By this specifications, Pin 11 is reserved (not used), and should be grounded or pulled low.

    These series of Maxtor SATA HDD's are using this pin 11 for turning that feature on & off. When it is on, the HDD is waiting for more initializations more time that any standard Sata controller, Bios & motherboard will wait. So when it is off, the HDD acts like normal PC SATA drive.

    Because this pin 11 is reserved for future use by SATA specifications, many SATA power cable manifacturers leave this pin going nowhere instead of grounding it (because it is not supposed to be used), but in our case it automatically enables the feature. So this drives auto sense if pin 11 is connected to power, not connected or grounded.

    IMPORTANT: If Pin 11 is not connected or connected to power supply, that means that "Staggered Spin-up Detection" is enabled, & your HDD will NOT be recognized or not recognized all the time by the bios!

    SOLUTION: Pull ot the power cable from the PSU & the HDD, and count 11th Pin, start counting from the side with the adge. Ground this pin to your case for example (to some screw)

    More Info:

    Hope it helps everyone, sorry for the long POST & for my english, remember... I'am Bulgarian
  9. LA Fred

    LA Fred TS Rookie

    I am having a similar problem with my ASUS P4C800-E Deluxe. It will not cold boot with the MAXTOR 6B300SO hard drive. I had been going round and round with it for two weeks. I was glad to see that a solution exists. I am talking about the new BIOS, not drilling the hole.

    I checked all of the ASUS sites. The Beta BIOS they have for the P4C800-E Deluxe is the 1020.001. Unfortunately, it does not solve the problem for me.

    I'll just resign myself to waiting for the next Beta upstep. In the meantime, I have told both ASUS and Maxtor about both the problem and the solution you people found. (The Maxtor people claimed that this was the first they had heard of the problem!)

    PRELUDiCON TS Rookie Topic Starter

    Very interesting indeed that they would say that, and not surprising since they really haven't provided any fix...and I'm still wondering who's more to blame, Maxtor or ASUS?? Either way, one or both of them should provide some sort of solution for this compatibility issue. Below is a copy of my email to/from Maxtor support...

    That's how it started and they did NOT provide any help or leads as to where I might get help. The emails stopped when I 'thought' I figured it out by changing a setting in the BIOS, this was a false alarm and eventually found the German ASUS ftp site. These companies suck for service...

    As for your situation, I believe you really have to wait for ASUS to come out with another update that is compatible with your drive...maybe try contacting them ?? Although, I had similar email exchanges with ASUS as the one above with MAXTOR, to no avail. Either the companies are really clueless, or the people answering emails are. :hotbounce
  11. LA Fred

    LA Fred TS Rookie

    I just got an email from Maxtor, telling me to call them Monday. I think what got them interested was my telling them to Google "6B300S0 problems."

    My email from ASUS was a generated one telling me that thay would contact me in 48 hours, plus or minus. From what I have read, it will be at least a week and be of no value.
  12. LA Fred

    LA Fred TS Rookie

    Well, I did hear from ASUS within 48 hours. Here are their words of wisdom:

    For your problem ,please try the following doings :
    #1 Clear the cmos
    #2 Reflash your bios to the latest version
    #3 Change another memory to have a test
    #4 Change your VGA card
    #5 Change another power supply
    #6 Reinstall your OS
    #7 Scan for virus at last.
    If All of the above have done and still the problem ,then please contact our local service for the motherboard testing.

    I guess they also want me to change to another brand of MB.

    PRELUDiCON TS Rookie Topic Starter

    Wow! I love how they see our concerns as 'generic' issues, and try to put the blame on every other component they can think of. Seems like they just assume we're braindead and think our CD-ROM tray is a cup holder. They might as well just scrap the support section from their website and direct you to the useless FAQ.

    You would expect a huge company like ASUS to do product compatibility testing with every single product out there, and especially once prompted by customers that a particluar product seems to have compatibility issues.

    Another thing is that when I wrote my email to ASUS regarding the BIOS update [German BETA 1021] that I found, asking why it's not available on the North American website for download, they didn't even respond.

    On top of all this, even though my drive seems to be functioning properly, over the past few days I began noticing slight tapping/ticking noises coming from it! :confused: ... I don't see any difference in drive performance or any lag what so ever, but this does raise concern.

    Does anyone know how to effectively test a drive's integrity/performance without first wiping it clean?
  14. LA Fred

    LA Fred TS Rookie


    My phone call to Maxtor resulted in their sending me a firmware patch. After reading the instructions on installing it, I think I had better wait a little longer until I can get some more input from others. Here is what they said:

    - - - -
    Attached is a file called BANC1BM0.txt Please rename this file to *.exe and then double click. This will create a bootable floppy that You can use to update the firmware on your drives. (Note: This update Has only been tested on standard SATA controllers. This may not work on SATA Raid controllers!)
    1. Boot to the floppy it will load a program called "dload".
    2. Once you are in this program after a few minutes you will see a menu.
    3. At this point all you have to do is hit enter on the default selection in that menu which is "Download all code (Disk & Boot)".
    4. It then goes out and searches for the drive and updates the firmware on it.
    5. Once this process is finished it will prompt you to hit any other key to exit.
    6. Do so. This will leave you at an A:\ prompt.
    7. Type in "dload" at the prompt. Once it scans the drives look in the upper left hand corner of the screen and you will see the new firmware code of "BANC1BM0". If this is what it reads the update was successful and you
    can power down the machine and install the next drive.
    8. Repeat this process until all of the drives have been updated.
    - - - -

    My concern is that my other 3 drives are Western Digital. I'm concerned that this patch might try to fix them. They are not causing any problems. Also, my main two drives are set up RAID Stripe 0. I don't want to end up with NOTHING working. My MB is a P4C800-E Deluxe. It has two set of SATA connectors. I know the first two are RAID. However, I never did know if the second set of SATA connectors were raid or not.

    PRELUDiCON TS Rookie Topic Starter

    I doubt the HD firmware upgrade will help, it doesn't make sense for a brand new drive to immediately require this in order to be recognized by a MOBO.

    But if ASUS isn't helping you, and this is what MAXTOR recommends you do...and you're willing to try it on the MAXTOR, why don't you, if possible, disconnect all other drives during this process to ensure that the upgrade doesn't try to 'fix' anything else...

    MAXTOR should recall these drives for all the headaches they're causing with their premature product.
  16. LA Fred

    LA Fred TS Rookie

    I can disconnect the 250GB Western Digital with no problem. However, my OS is running on the two RAID HD's as a Stripe 0.

    By the way, in Googling Maxtor 6B300S0, I happened upon some sites that restore/rebuild dead drives. They don't have much good to say about Maxtor, in general. They apparently have had a lot of problems.

    I'll wait another day or two to see if anyone else comments before I become the test pilot.

    PRELUDiCON TS Rookie Topic Starter

    Well if you're booting from a floppy disk, why do you need your OS?

    And I've also heard less than great things about MAXTOR...I just wanted the drive because it's 300G and 16M buffer :blackeye: lol ...

    I have Sandra 2005, wondering if you know how to use it to test the drive?
    I ran a file system test on one of the partitions and it resulted in 21ms avg. Access Time :dead: WTF!?

    Ran the same test on a partition of my 120G Maxtor, and resulted in 9ms avg. Access Time...
  18. LA Fred

    LA Fred TS Rookie

    These people don’t know that they are dealing with the lowest common denominator when it comes to computers.

    After several tries, I realized that when he was telling me to rename the file “BANC1BM0.txt” to “*.exe,” he meant “BANC1BM0.exe.”

    The PC would not boot without the SATA RAID drives hooked up, so I reconnected them and took a chance. The patch went right to the Maxtor drive.

    It showed this information on the disk: Driver: I82801EB_SATA, Maxtor 6B300S0, SN: B60JED3H, Firmware Ver.: BANC1B10.

    I tried to run the patch and got this message:

    - - - -
    Updating DISK Code
    File FW Code: BANC1BMZ

    --- WARNING –
    The Firmware you are trying to download doesn’t match this drive type. Press ESCAPE to abort this test or any other key to continue the download.

    Error Condition = FILENAME MISMATCH:
    Drive Code does not match named file code.
    - - - -

    Needless to say, I aborted the attempted upgrade.

    I then sent another email to the Maxtor rep concerning this and he promptly came right back to me and said to ignore the message and tell it to go ahead, anyway.

    I did and NOW IT WORKS!!

    However, I’ve got to try the Sandra test you were telling me about to see how well it is doing. The rep never did tell me if the new patch killed the Native Command Queuing that was supposed to make this disk fast.

    PRELUDiCON TS Rookie Topic Starter

    Glad to know it worked @ least somewhat...weird how the filename didn't match though...

    Do you think you could post that file on here?

    I wouldn't mind downloading it and storing it just in case I need to try something with the drive in the future. you know if the drive has to be empty in order to upgrade the firmware? Or if it isn't, will the upgrade process delete all data?
  20. LA Fred

    LA Fred TS Rookie

    The rep just assured me that the drive is now as it should be.

    It didn't do anything to the data already on the drive.

    Now, I'll see if I can attach the patch.

    No, I can't. Tell me how.

    PRELUDiCON TS Rookie Topic Starter

    After clicking on REPLY or QUOTE, on the REPLY screen underneath the REPLY box, is a section titled ADDITIONAL on MANAGE ATTACHMENTS...should work. [makesure it's the *.txt format :grinthumb]

    Interesting how you have to upgrade the firmware on a brand new drive for it to function as it 'should':knock: lol...
  22. LA Fred

    LA Fred TS Rookie

    I followed the steps, but got this error message:

    The page cannot be displayed

    I followed the instructions listed on the page, but cannot get anything better than that.

    I'll try private mail to see if that will "take."

    PRELUDiCON TS Rookie Topic Starter

    Got your email, thanks!

    Gonna try to attach it myself... same error that you got after clicking

    Anyways, how is the new firmware so far?

    Found a thread in another forum discussing performance of the drive in question...

    After reading through that, I googled "HD Tach", suppose to be a good HD benchmark tool. Here's the link to the HD Tach website...

    I ran a couple tests last night, and was not impressed with results. I did have a few things running in the background though. Will try again tonight with nothing running and post my results.

    Would be interested to see how other 6B300SO drives perform.

    And before I flash mine, want to get my hands on my original firmware [BANC1B10] just in case.

    I read the readme.txt inside the file you sent me, and it says to disconnect all other ATA devices before running...further says that it will allow you to flash other Maxtor drives not compatible with this firmware and rendering them useless.

    Just wondering if this flash tool just goes nuts flashing devices or it simply gives you a list of drives to choose from?

    I really don't want to disconnect everything if I don't have to.
  24. LA Fred

    LA Fred TS Rookie

    The software only updates one drive at a time. It asks you if you want to do it before it does.

    I have had no other problems with the Maxtor or the start up since installing the new fireware.

    I downloaded the HD Tech and ran it. It says that the Maxtor has a Random Access of 16.3 MS and an Average Read of 54.6 MB/s.

    In comparison, my Western Digital Raptors running in RAID stripe 0 had a Ramdom Access of 8.8 MS and an Average read of 66.7 MB/s.

    I wish I had known of this software before I ran the firmware. If I had run it before the installation, I could have seen if the patch slowed it down. I know the Avg. seek is advertised at much better than 16.3.

    I also downloaded Sandra. It was too much for me to figure out. It looks as if you need to go to school to learn how to run it.
  25. LA Fred

    LA Fred TS Rookie

    I guess I was unfair to Maxtor to compare it to the Raptor drives.

    Here is what the software said about my Western Digital SATA 250GB drive (WD250JD):

    Random Access: 13.7MS
    Avr Read 50.0 MB/s
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...