Microsoft Vista Basic required driver for USB devices?!

Not open for further replies.
Hi all,

I got a problem with my Dell laptop which using Windows Vista Home Basic, when I plug in my USB devices like Digital camera, external hard disk, etc, the Windows Vista ask for the drivers, this sounds very weird coz all this USB devices is working fine under Windows XP, can anyone provide some clues about this?

Many thanks...



Posts: 7   +0
Hi LM,

try this once and check whether ur able to use USB .........
have you tried updating the usb controllers or if no update is available reinstalling it.

reply me with the result.



Posts: 18   +0
Yep, this is soon may be a hottie (or is it just smoke in my crystal ball?)

I'm starting to get USB problems with HP's C3186 (and no doubt others). Vista on an Acer Laptop was the latest.

Any blips, like paper jam, loading of other USB drivers, eg. Blue tooth has lead to prompts from Vista that it can't find the Printer drivers, even tho they are present on the system.

Did find a solution thanks to one hit using the error code from details popped down from the driver search options for loading. I entered this long error code which starts with PnP..XXXXX (so long can't remember it) googled it and came up with a solution.

The main problem seems to lie in the Vista software where the Driver store locks most techies out. The driver store has all the history of drivers loaded and utilised. When the hardware is USB'd Vista goes to the driver store and looks up what's needed. Somehow this gets out of synch and the "drivers not found" gets returned.

The solution was to uninstall the HP software completely, reboot and leave the printer disconnected.
You need to access the Windows/inf/ directory (reset permissions if necessary) scroll down to the INFCACHE.inf and DELETE. It will recycle and regenerate by itself.
You may have to temporarily turn off recovery point utility.

If you get a access denied message, right click the INFCACHE.inf file >properties and reset permissions for access to this file (expand from read only) to delete it. Then quit out.

Reboot with the printer not USB'd

Make sure any anti-virus is deactivated (recommended by HP) and you have a clean Vista (HP Site Download +\- 150Mb) HP C3186 installation disk and reload.

At the time where you are asked to plug in the printer, tick the "load later box" and proceed with installation.

At the end you should find all the software has been installed. (task bar bottom right will show device installation progress if balloon clicked). Check to see that drivers have been installed in progress task board as well as the other software.

Reboot and the printer should be operable. Check by going into Win Word and >file/print blank doc. The HP printer should be found.

The bug is a toughie to get past and I spent some 10 hrs and a final three after finding the INFCACHE solution.

At the end (forgive the full details for step by step instruction) the printer did its job, no problems.

BUT.... I don't hold out much hope for continued reliability.... the next upset on the PnP side will spring Vista into Driver seek mode again I am sure.

The winds that blow indicate that there maybe a problem on the HP/MS Vista drivers marriage here and HP's quest for the universal printer driver is in the pot, with tasters now and then.

HP has recently issued a driver download for networked bombed C3186... and a patch to suit.

OK, that's it for now... til next ;)
Hi, i managed to solved the USB driver problem by rename the INFCAHCE.inf file, all USB devices is working properly now, many thanks again!!

Not open for further replies.