Mounting problems on Linux

By ETF Soldier
Oct 29, 2013
Post New Reply
  1. Hey guys, I've only just installed Linux 13.10 today, and I'm brand new to the OS. I keep getting a problem with my secondary HDD.

    The facts:
    128GB SSD Partition
    Windows on 60GB
    Linux on 30GB
    3GB spare for w/e.

    I then have a 1TB Western Digital Caviar Blue dynamic HDD, partitioned into 3 main sections (but they're a bit split up due to a repartitioning issue - see photo)

    The 'Stuff' partition I can access from Linux, but the 'Games' and 'Spare' partitions give me this message every time I try and mount:

    Error mounting system-managed device /dev/sdb2: Command-line `mount "/mnt/622CFFFC2CFFC8D5"' exited with non-zero exit status 12: Failed to read last sector (590368767): Invalid argument
    HINTS: Either the volume is a RAID/LDM but it wasn't setup yet,
    or it was not setup correctly (e.g. by not using mdadm --build ...),
    or a wrong device is tried to be mounted,
    or the partition table is corrupt (partition is smaller than NTFS),
    or the NTFS boot sector is corrupt (NTFS size is not valid).
    Failed to mount '/dev/sdb2': Invalid argument
    The device '/dev/sdb2' doesn't seem to have a valid NTFS.
    Maybe the wrong device is used? Or the whole disk instead of a
    partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
    Being a complete newbies, I have no idea what to do, can you help?

    Attached Files:

  2. Joseph8th

    Joseph8th TS Rookie

    Hiya. You are getting this error because you are trying to mount a partition of a Windows 'Dynamic Disk', which the 'mount' program can't handle without some considerable preliminary setup. Not sure if you can convert it back to 'Basic Disk' or not, but that would be the simplest.

    If you are determined, well it'll be a good learning experience. Here's some instructions (haven't tried them, myself):
  3. ETF Soldier

    ETF Soldier TS Evangelist Topic Starter Posts: 463   +136

    I managed to solve the solution by deleting the games and spare volumes of the HDD and re-partitioning as you can see the 'Games' and 'Spare' partitions were split, however the 'Stuff' partition wasn't and I could access that, but thank you anyway!
  4. ETF Soldier

    ETF Soldier TS Evangelist Topic Starter Posts: 463   +136

    Nice picture by the way, my dog is excited by it.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...