1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

My PC can't install drivers for external USB drives

By Twister86 · 64 replies
Jul 13, 2013
Post New Reply
  1. Hello all ,

    I need major help and I've tried google this trouble for 2 days now and asked around and no solution for this problem can be found anywhere or have I found anyone else with this issue...

    Well I basicly cloned my Intel SSD to a Samsung SSD, and I'm using my Samsung SSD now , but not any of my external hard drives work.

    I've tried WD Book (1TB) and also smaller USB flash storage devices such as memory sticks on 2 GB, 4 GB, 8 GB etc. None can work!!!

    It doesn't show on My Computer, or Disk Management, and in the Device Manager if I click on Storage tab it's there but a yellow triangle and it cant be installed. (says driver cant be installed)

    please help!!!

  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Don't know if I can help but will take a look. What version of Windows are you running? And is it 32 or 64-bit version?

    List any Problem devices
    • Make sure devices are connected and powered on
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
    • On the other hand, if no devices are listed, tell me so
  3. Twister86

    Twister86 TS Rookie Topic Starter

    Windows 64-bit

    SanDisk Cruzer Blade USB Device USBSTOR\DISK&VEN_SANDISK&PROD_CRUZER_BLADE&REV_1.19\20044321911149B1C3B0&0 This device is working properly.
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Is it Windows 7? Windows 8? or ????

    That came up under Problem Device??? That confuses me since it's status="This device is working properly" means it's not a problem device. If that's the device status I'd expect that drive to now be working or, at minimum, at least appear under Disk Management.

    Given your last Device Manager screen shot I was expecting to see the 2 devices with the yellow triangles appear as Problem Devices.

    Have things changed?? Did you do the Problem Device report right??

    Look at Device Manager again.
    > Show me another screen shot of your Device Manager
    > For each device with a yellow triangle, right click Properties. Look at the General tab for Device Status. Devices with a yellow triangle are NOT working properly. Instead you should see a code number plus a message listed. You can just tell me the code number. (I can look-up the message based on code number)

    Run the Problem Device report again. I'd expect entries for the USB devices that have the yellow triangles in DevMgr.
  5. Twister86

    Twister86 TS Rookie Topic Starter

    I removed the WD external because I didnt wanna damage it, I had less important information on the usb stick. And I figured if I can get that to work, the other will work too.

    It's windows 7.

    Yea that came up on problem device, and I tried the USB stick also on my macbook and it worked fine there. It's not the device that got problem, its my computer.

    It dont show up under disk management, because it can't be installed (the driver) --> thats why I got the yellow triangle in the device manager, but it's there since it works (device is not broken) but there is no driver installed for it that works. :\

    If I right click it, it says under Volume it's all empty. (blank)

    And this message under Device Status:

    Det går inte att läsa in den här enhetens drivrutin. Drivrutinen kanske är skadad eller saknas. (Kod 39)

    Not able to read this device driver. Driver may have been damaged or missing. (Code 39)
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Good. So we know the USB stick seems to work on your other computer.

    Problem Device Report
    One thing that's odd on your Windows computer, is any device showing up on the Report where device status shows Working Properly. (Note, that's the status of the device). So it's strange if when that same device appears in device manager with a yellow triangle and a driver error code! Yet it shows up as Working Properly in the Problem Device Report. So you might double check if that keeps occurring (as that's very strange) but we'll otherwise ignore the discrepancy.

    Driver Background Info
    Before moving on, here's some background info (based on what I've seen/learned playing with Windows and device drivers)
    > When you insert a USB flash, Windows installs several drivers
    > USB flash drives are a type of USB Mass Storage Devices (fyi.... so are CD/DVD devices). When you insert the flash, Windows first recognizes the flash as a USB Mass Storage device. Windows installs a USB Mass Storage driver for it and you should see a new USB Mass Storage device appear in DevMgr.
    > Windows should next realize it's a disk and then search for and install the disk driver which is where the problem seems to be happening

    Win 7 Device Manager Trace Log
    Now here's where it gets interesting..... Windows 7 keeps a device manager trace log so maybe we'll find something useful by comparing the trace on your machine vs. the trace on my machine. (I run Windows 7 32-bit). Though, beware these trace logs aren't easy to read/follow but still worth taking a look

    Do the following
    1. Start with the flash drive inserted
    2. Delete file C:\Windows\inf\setupapi.dev.log (this is the trace log)
    3. In Device Manager, right click the flash drive->Uninstall
    4. Now at top of DevManager menu select Action->Scan for Hardware Change. Windows will reinstall the disk driver. Does the error/yellow triangle still occur??
    5. We should now have a trace of the Uninstall/Re-Install. Go back to C:\Windows\inf\setupapi.dev.log. Change the file extension to .txt in order that you can now upload it to your next TechSpot post.
    I've attached the one from my machine after doing the same steps myself yesterday, July 13. Also note, I have a dual boot machine which is why you'll find you see my Windows 7 installed on the E: drive

    Attached Files:

    misor likes this.
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    One additional point just occurred to me. Is your SanDisk flash a U3 device? U3 device installation will be somewhat different then a simple flash drive.
  8. Twister86

    Twister86 TS Rookie Topic Starter

    Well I don't have the file, setupapi.dev.log in my C:\Windows\inf\ folder, but I do have a bunch of setupapi.app.txt, setupapi.dev.txt, setupapi.ev1, setupapi.ev2, setupapi.ev3, setupapi.offline.txt files, and also a long setupapi.dev.20120713_105322.txt file.

    But none are as small as yours, and I just reinstalled the driver, error still occur and no setupapi.dev.log was created either, just the bunch of other files are still there, and the list/size is huge.......

    I googled the code 39 error I have got in the device status, and got this

    I tried this also but it didn't work either, but I havn't tried other HKEY registers, as I do not know what a USB Flash memory stick is classified as, Universal Serial Bus controller, DVD/CD-ROM drives, or Disk Drives. I only deleted the upperfilters and lowerfilters for Universal Serial Bus controller, but is this anything plugged in to my USB slot? Like a webcam, iphone, mouse, keyboard, etc. or a USB memory stick?

    Is it riskful to delete the lowerfilters and upperfilters for DVD/CD-Rom and Disk drives if I already have an working DVD/CD-Rom unit and two working internal Hard drives, one Samsung SSD and one Seagate 500GB?
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Best not to do anything until I have the chance to look at this further and get back to you
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    You're 7 hours ahead of me (so I'm still waking up ha-ha). Probably not able to look further till much later in the day.

    I'm familiar with upper/lower filters and we can talk about those too (and I'll show you how to safely check them). If there's a problem with filters they're almost always with non-Microsoft filters. But will discuss more later.

    For now, you may want to skim through SetupAPI Logging and SetupAPI Logging Registry Settings

    1) Check if HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup\LogLevel exists and, if so, is set to zero

    2) Verify %SystemRoot%\inf if, in fact, is C:\Windows\inf on your machine or something else
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    I can tell from the DevMgr snapshot in your first post, you have Acronis True Image installed (your DevMgr lists an Acronis device). I use Acronis TI as well. This is interesting because I know Acronis installs disk and storage volume device driver filters.

    Think of filters as device driver "add-on" parts. A Windows driver can be "layered" and filters can be added to a driver just like adding upper and lower "layers to a cake". If a filter is bad or faulty the entire driver is faulty (the entire "cake" goes bad).

    I will guess you don't have any USB controller filters installed but I do know you have disk and storage volume filters installed because you're using Acronis TI.

    1) I suggest you un-install Acronis TI to see if the problem still exists when its only Windows software drivers and filters installed for your disk and other devices.

    2) Here's an easy (and safe method) to see what driver files and filters are installed before and after you uninstall Acronis TI. (I've also seen Acronis TI leave filters behind even after its supposed to be uninstalled so it's also helpful to check and know whats there both before and after the uninstall)

    To see the upper/lower filters defined in the registry
    > Right click the device in DevMgr->Properties->Details tab. Use the pull down menu to see the Class Upper Filters and Class Lower Filters and jot down their names

    To see the device's driver files on disk and who published them
    > Right click the device in DevMgr->Properties-Drivers tab. Click Driver Details button. Select each file to see which ones are from Microsoft and which are from Acronis. You can compare file names to filter names understand which is which

    So first verify which filters are installed and who they're from. Then uninstall Acronis and verify the Acronis registry entries and Acronis files are no longer associated with the device. Are the Acronis filters and files removed? Does the problem still occur? Or does it work now??
  12. Twister86

    Twister86 TS Rookie Topic Starter

    1) Setup got a LogLevel and is set to 0 yes.

    2) What do you mean? if you mean by inf folder, yes its located in C:\Windows\inf

    Do you know a good file host? I'm trying to upload the setupapi files now but it's says they are too large to be uploaded here.

    I read your 2nd post now and
    in upper class filter it's

    and in lower class filter it's

    that is the value. (This is the Cruzer sandisk memory stick USB)

    I also
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Looks like we both posted at the same time :)

    Move on for now and, per my last post, check the upper/lower filters and files and try the Acronis TI uninstall first. If it still fails after that then we'll go back to looking at setupapi (while Acronis is still uninstalled)
  14. Twister86

    Twister86 TS Rookie Topic Starter

    Damn it, I just wrote a huge post and then it said my edited time had expired :\
  15. Twister86

    Twister86 TS Rookie Topic Starter

    C:\Windows\system32\DRIVERS\disk.sys (Microsoft)
    C:\Windows\system32\drivers\partmgr.sys (Microsoft)
    C:\Windows\system32\DRIVERS\vsflt53.sys (Acronis)

    This is under Driver Details.

    upper class filter

    lower class filter
  16. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Rats! btw.. also which version of Acronis TI are you running? I have TI 2013 installed. And I know snapman is an Acronis disk filter
  17. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Interesting... I used to run TI 2010. Recently upgraded to 2013. It doesn't look like snapman is used anymore by TI 2013!

    Which version of TI are you running and what is the build number?
  18. Twister86

    Twister86 TS Rookie Topic Starter

    Thanks dude, uninstalled Acronis solved the problem.

    The device is now working properly again, I'm suspecting that the driver C:\Windows\system32\DRIVERS\vsflt53.sys (Acronis) which also was in lower_class_filter vidsflt53 somehow interfered with the USB storage device. And Windows was loading that driver in and so it wasn't succesfuly installed because of this.

    So now that we found the cause, and solved the issue, will I never be able to use Acronis again? I mean this must be a serious program by a serious company, so the program should not cause matters like this?
  19. Twister86

    Twister86 TS Rookie Topic Starter

    I used Acronis True Image WD Edition which was downloaded from here:

    I used this program to clone my SSD, since the cloning program that was provided with my Samsung SSD (830 series) didn't work (got error when I tried to clone) and my Intel SSD cloning program only worked when cloning from <Any manufacturer hard drive> --> <Intel> , not the other way around.

    Besides I read that Intel's cloning software was built and based on Acronis, and Acronis True Image WD Edition was the only software I found on Western Digitals website (since they are the one who made the program) that was free. (not needed to purchase or was on trial period)

    And it worked on any harddrives, even tho I got 2 Western Digital harddrives (external) so I am a WD customer.

    Really good thing that you caught up that I had Acronis installed in the device manager.
  20. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Whoo Hooo! Glad to hear we got the problem fixed! (y)

    As for Acronis, I see the WD edition is based on TI 2009. I currently have TI 2013 installed on my desktop. On the one hand, I've been using Acronis TI over the years even though I found it has had its share of bugs. On the other hand, in your case, if memory serves me it's odd you had snapman defined in registry yet snapman.sys file not on disk. And that would definitely cause a code 39 error. So it might have been a faulty installation for some reason???

    I may still have TI 2010 installed on my laptop. And can check about snapman if I do. But off to sleep soon so will check over next couple of days and let you know. G'nite ZZZZZZzzzzzzz :)
  21. Twister86

    Twister86 TS Rookie Topic Starter

    Okay I checked the driver again, and it still got all 3 drivers.

    (C:\Windows\system32\DRIVERS\disk.sys (Microsoft), C:\Windows\system32\drivers\partmgr.sys (Microsoft), C:\Windows\system32\DRIVERS\vsflt53.sys (Acronis))

    However what was different this time was upper class filter only had PartMgr not snapman, so snapman definitely caused the driver error not being installed successful.

    Yeah check if there is *any* Acronis version out there that doesn't have snapman and/or is available for download (prefer free) on their website.
  22. Twister86

    Twister86 TS Rookie Topic Starter

    Also stumbled upon this thread:

    It also shows related to my problem, and the fix is uninstall Acronis from the system. They also had code 39 error on same external hard drive devices.

    On the bottom of the thread, however, there seems one guy found a fix, I quote.

    So the file tdrpman273.sys being copied over to somewhere in the C:\Windows\ directory should also solve the problem. Do you have that file? And do you know where in the Windows directory it should be copied into? (what folder)

    ...Incase I might gonna need to use Acronis True Image again, in the future.
  23. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    First, my bad! fyi... snapman.sys is still part of ATI 2013. I had my search settings wrong DUH

    Second, typically Code 39 driver problems (as pertains to Acronis) is because Acronis doesn't always uninstall or upgrade itself properly from the registry. If Windows thinks it needs a device or driver listed it finds in the registry but can't find the the driver file on disk, you get the Code 39 error.

    The WD Acronis version you used is downloaded and run by many, many people. I wouldn't worry about the next time you install vs. just knowing where to look for stray registry entries when it's supposed to be uninstalled. Although why your snapman.sys file was missing is a mystery unless:
    > Had you uninstalled/reinstalled or upgraded Acronis before?
    > Keep an eye on your anti-virus. Perhaps it finds a false positive on these files and removes them??? (IDK.. that's just speculation/wild a$$ guess)

    On my 32bit machine, most (not all) drivers are under C:\Windows\system32/drivers. Not sure how it varies for 64bit.

    All that said, is Acronis supposedly uninstalled?? I ask because you report you mention you still have an Acronis Disk filter listed. Also check Storage Volumes in DevMgr for Class Upper/Lower Filters and driver files. (You only need check one device in a category. By definition, Class filters apply to EVERY device in the class. So every disk has the same class filters. Every Storage Volume has the same class filters, etc.)

    Also download Serviwin. Click View->Services and View->Drivers. Look for any entry where the Company column=Acronis. (just click the column header to alpha sort by company)
  24. Twister86

    Twister86 TS Rookie Topic Starter

    Idk, but I don't wanna mess around too much now. I am happy that I have my usb external device working now :)
  25. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    No prob. Makes sense. Besides, if you're happy, I'm happy. :)

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...