My problems with Direct3D

By mustafa2020
Jul 8, 2009
  1. Hey guys,

    My graphics card is a Cirrus Logic 5430/5440 Compatible Graphics Adapter, driver version 5.01.2535.0 . I tried running a game (Astro Avengers 2) and it didn't work, some sort of error message that related to some problem with 3D rendering popped up. The game started but the screen remained completely blank. So I installed DirectX 9.0c. Didn't make any difference.

    I ran "dxdiag" and under the "Display" tab, The button marked "Test Direct3D" and the 3 options under the heading "DirectX Features" were all grayed out and in the notes below there was something about there being an error in Direct3D. I think this is why the game wouldn't work. Does anyone have any ideas about a possible fix for the problem?

    I don't know much about the computer except that it runs Windows XP, the total memory is 40 GB and the RAM is 128 MB.

    From the way the question is framed, you've probably realised that I'm a total newbie. An answer which is a little simply worded would be really cool. Thanx a lot.
  2. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,377

    Your graphics adapter is ancient by computer standards. You should do a Google search for the newest drivers.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...