My USB Wireless Adapter Not Working

Hi. I suddenly had a problem with my usb wireless adapter.. Before, when it was perfectly working, the driver installed for my wireless adapter was RTL8188. Everything was working perfectly, the adapter and the software "realtek wireless lan utility" still detects my adapter. But oneday, I really don't know what happened, my pc just started to not recognize my adapter. The "realtek lan utility" doesn't detect my adapter. The "disable adapter" option box is always "checked" and when I unchecked it nothing happens. I also notice that every time I plug my usb wireless adapter, a pop-up icon saying "This USB device can perform faster if you connect it to a hi-speed USB 2.0 port" which before doesn't appear every time I plug it in. Also the "Found new harware" message appears every time. I don't know what happen but I think somehow my pc is not recognizing the usb wireless adapter properly. Because when I uninstalled the driver and re-installed it, nothing happens. When I plug my usb it still says "found new hardware". I tried using "driver identifier" to reinstall the driver and searching it on the net but I was surprised because the driver it was pointing to was "RTL8192u" someting like that which installs "RTL8192cu" and not the original "RTL8188". The device ID is "VID_0BDA&PID_8192". I tried installing the driver but the system crashes displaying a blue screen message and so I think it really was not the driver for it. I really don't know what to do so if anyone can help I'd really appreciate it.