1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Need help with 1st step in Malware Removal Procedure

By geoffd86 ยท 77 replies
Mar 11, 2010
  1. I have had a search engine redirect virus for several weeks.

    My computer specs:

    I am running Windows XP Pro SP2 with an Intel Pentium M 2.13 GHz processor and 1.0 Gig of RAM

    My harddrive is 80 GB with 55.3 GB free

    Video Card is ATI Mobility Radeon X700

    I started out by running Avira, which detected 6 or 7 trojan files. I then quarantined the files and restarted, then re-scanned. It would detect 6 or 7 more trojans, and I did the process over again 3 more times, then decided to stop.

    I then un-installed Avira and installed Comodo and scanned. It found 20 or so files, but I couldn't figure out how to get rid of them, so I proceeded to step 2.

    I completed one Clean in step 2, but I want to make sure I don't need to do something in step one before I do the rest.

    Am I doing this correctly?

    Also, when I have anti-virus software installed, does it interfere with the successive steps? Do I need to uninstall it?

    I am a new poster so let me know if I need to include more information/do something differently.

    Thanks a lot.
  2. Broni

    Broni Malware Annihilator Posts: 53,867   +370

    You have to have antivirus program installed.
    Go ahead with next steps.
  3. geoffd86

    geoffd86 TS Rookie Topic Starter Posts: 50

    Finished 8 Steps - Log Files

    Continuing with redirect virus removal...

    Here are log files.

    Attached Files:

  4. Broni

    Broni Malware Annihilator Posts: 53,867   +370

    Please download ComboFix from Here or Here to your Desktop.

    **Note: In the event you already have Combofix, this is a new version that I need you to download. It is important that it is saved directly to your desktop**
    1. Please, never rename Combofix unless instructed.
    2. Close any open browsers.
    3. Close/disable all anti virus and anti malware programs so they do not interfere with the running of ComboFix.
      • Very Important! Temporarily disable your anti-virus, script blocking and any anti-malware real-time protection before performing a scan. They can interfere with ComboFix or remove some of its embedded files which may cause "unpredictable results".
      • Click on this link to see a list of programs that should be disabled. The list is not all inclusive. If yours is not listed and you don't know how to disable it, please ask.
      NOTE1. If Combofix asks you to install Recovery Console, please allow it.
      NOTE 2. If Combofix asks you to update the program, always do so.
      • Close any open browsers.
      • WARNING: Combofix will disconnect your machine from the Internet as soon as it starts
      • Please do not attempt to re-connect your machine back to the Internet until Combofix has completely finished.
      • If there is no internet connection after running Combofix, then restart your computer to restore back your connection.
    4. Double click on combofix.exe & follow the prompts.
    5. When finished, it will produce a report for you.
    6. Please post the "C:\ComboFix.txt" along with a new HijackThis log for further review.
    **Note: Do not mouseclick combofix's window while it's running. That may cause it to stall**

    Make sure, you re-enable your security programs, when you're done with Combofix.

    DO NOT make any other changes to your computer (like installing programs, using other cleaning tools, etc.), until it's officially declared clean!!!
  5. geoffd86

    geoffd86 TS Rookie Topic Starter Posts: 50

    ComboFix Erroring Out

    When I run Combofix a box comes up that says it doesn't have permission to open a file of type with a bunch of numbers, then /hidec.exe

    When I click ok the same box comes up almost 10 times.

    Then it tries to open a file and asks whether to use the internet to find the correct program to open it or to browse. What's going on?

    I still have all of the programs installed from the 8 step procedure. I disabled Comodo, the only anti-virus software on here, and superantispyware. I downloaded combofix directly from your link and placed it on the desktop. All browsers are closed, and I attempted to follow all directions.

    Also, when I started combofix, it asked me which user I wanted to use, and whether I wanted to protect my computer from unauthorized access. I used current user/administrator or something like that, and tried it with the protection box checked and unchecked. Both times it didn't work.

    Thanks for the help
  6. geoffd86

    geoffd86 TS Rookie Topic Starter Posts: 50

    ComboFix Problem - A little more info

    I forgot to mention I also did a scan with comodo before I got the instructions on using combofix, but I didn't clean any files, I just wanted to see if it would find anything.
  7. Broni

    Broni Malware Annihilator Posts: 53,867   +370

    Yeah, your computer has been infected with couple of really nasty ones, a backdoor trojan and a rootkit.

    Download TDSSKiller and save it to your Desktop.
    Extract its contents to your desktop and make sure TDSSKiller.exe (the contents of the zipped file) is on the Desktop itself, not within a folder on the desktop.
    Go to Start > Run (Or you can hold down your Windows key and press R) and copy and paste the following into the text field. (make sure you include the quote marks) Then press OK.

    "%userprofile%\Desktop\TDSSKiller.exe" -l C:\TDSSKiller.txt -v

    If it says "Hidden service detected" DO NOT type anything in. Just press Enter on your keyboard to not do anything to the file.
    When it is done, a log file should be created on your C: drive called TDSSKiller.txt please copy and paste the contents of that file here.
  8. geoffd86

    geoffd86 TS Rookie Topic Starter Posts: 50

    Tdsskiller log

    Didn't look like it found anything, but here's the log

    Attached Files:

  9. Broni

    Broni Malware Annihilator Posts: 53,867   +370

    Delete your Combofix file.
    Download fresh one and rename combofix.exe to broni.exe BEFORE saving it to the desktop.
    Don't run it yet.

    Please download and run the below tool named Rkill (courtesy of BleepingComputer.com) which may help allow other programs to run.

    There are 4 different versions. If one of them won't run then download and try to run the other one.

    Vista and Win7 users need to right click Rkill and choose Run as Administrator

    You only need to get one of these to run, not all of them. You may get warnings from your antivirus about this tool, ignore them or shutdown your antivirus.

    * Rkill.com
    * Rkill.scr
    * Rkill.pif
    * Rkill.exe

    * Double-click on the Rkill desktop icon to run the tool.
    * If using Vista or Windows 7 right-click on it and choose Run As Administrator.
    * A black DOS box will briefly flash and then disappear. This is normal and indicates the tool ran successfully.
    * If not, delete the file, then download and use the one provided in Link 2.
    * If it does not work, repeat the process and attempt to use one of the remaining links until the tool runs.
    * Do not reboot until instructed.
    * If the tool does not run from any of the links provided, please let me know.

    Once you've gotten one of them to run then try to immediately run broni.exe.
  10. geoffd86

    geoffd86 TS Rookie Topic Starter Posts: 50

    Used Rkill but Combo (broni) file still not working

    First I redownloaded combofix and named it broni before saving to desktop.

    The second rkill link worked correctly (the black window showed up then went away)

    I ran the broni file immediately, and it gave this message, then terminated.

    A required privelege is not held by the client

    When I clicked ok, this came up

    C:\ folder is not accessible
  11. Broni

    Broni Malware Annihilator Posts: 53,867   +370

    Reboot to safe mode, run rkill and broni.exe again.
  12. geoffd86

    geoffd86 TS Rookie Topic Starter Posts: 50

    Ran Broni.exe some problems - Log file included

    I rebooted to safe mode and ran the rkill file, which didn't do the same thing that it did before. Instead of leaving the black screen, it stayed on black screen and then created a log file that said processes terminated by Rkill of while it was running:
    C:\Documents and Settings\Administrator\Desktop\rkill.scr

    I then proceeded with combofix(broni file) which ran and gave a log file, but had some problems because I wasn't connected to the internet.

    I then rebooted, but now the internet connection does not work, so now I am using my girlfriends computer to post this.

    Anyway here is the log

    Attached Files:

  13. Broni

    Broni Malware Annihilator Posts: 53,867   +370

    1. Please open Notepad
    • Click Start , then Run
    • Type notepad .exe in the Run Box.

    2. Now copy/paste the entire content of the codebox below into the Notepad window:

    c:\documents and settings\All Users\Application Data\Avira
    c:\program files\AVG
    c:\documents and settings\All Users\Application Data\avg9

    3. Save the above as CFScript.txt

    4. Then drag the CFScript.txt into ComboFix.exe as depicted in the animation below. This will start ComboFix again.


    5. After reboot, (in case it asks to reboot), please post the following reports/logs into your next reply:
    • Combofix.txt
    • A new HijackThis log.
  14. geoffd86

    geoffd86 TS Rookie Topic Starter Posts: 50

    Safe Mode?

    Should I do this step in safe mode like last time?

    And do I need to change the file name back to combofix, or can I still use broni.exe?

  15. Broni

    Broni Malware Annihilator Posts: 53,867   +370

    Use broni.exe and try to run it in normal mode.
  16. geoffd86

    geoffd86 TS Rookie Topic Starter Posts: 50

    Didn't work

    Says A required privilege is not held by the client then doesn't finish running
  17. Broni

    Broni Malware Annihilator Posts: 53,867   +370

    Try Safe Mode. Run rkill first
  18. geoffd86

    geoffd86 TS Rookie Topic Starter Posts: 50

    More Problems

    I'm having the same problems as before.

    A prompt comes up telling me to turn of Comodo, so I turn it off, then hit okay, but it says that Comodo is still on, even though I followed the same instructions to turn it off as in step 3 of the removal procedure. It says to run at my own risk.

    Then it says the machine does not have the 'Microsoft Windows recovery console' installed. Without it, Combofix shall not attempt the fixing of some serious infections. Since I'm in safe mode and my machine can't connect to the internet anyway, I can't download it.

    What should I do?
  19. Broni

    Broni Malware Annihilator Posts: 53,867   +370

    You're fine. Please, run it.
  20. geoffd86

    geoffd86 TS Rookie Topic Starter Posts: 50

    Ran Combofix and hijackthis - Log files

    I ran the combofix program and then hijackthis in the way the you said.

    My internet still isn't working, but I was wondering if I will need to install the Windows recovery console, and also if I should un-install Comodo for the time being, because it's giving me problems with combofix, even when it's off.


    Attached Files:

  21. Broni

    Broni Malware Annihilator Posts: 53,867   +370

    OK. Let's try to get your connection back now....

    Turn off computer. Disconnect router, and modem from power source for 30 seconds.
    Power them back on.
    Restart computer.

    If that doesn't work, bypass router, and connect computer straight to the modem.

    If that doesn't work...
    Go Start>Run (Start search in Vista), type in:
    Click OK (in Vista, while holding CTRL, and SHIFT, press Enter).

    In Command Prompt window, type in following commands, and hit Enter after each one:
    ipconfig /flushdns
    ipconfig /registerdns
    ipconfig /release
    ipconfig /renew

    Restart computer.

    If that doesn't work...
    Go Start>Run (Start search in Vista), type in:
    Click OK (in Vista, while holding CTRL, and SHIFT, press Enter).

    At Command Prompt, type in:
    netsh int ip reset reset.log
    Hit Enter.
    Type in:
    netsh winsock reset catalog
    Hit Enter.

    Restart computer.

    If that doesn't work...
    Download, install, and run WinSockFix: http://www.softpedia.com/get/Tweak/Network-Tweak/WinSockFix.shtml (doesn't work in Vista)
    Restart computer, and check again.

    If that doesn't work...
    Download Dial-A-Fix (DAF) (doesn't work in Vista):

    Have XP CD available in case DAF needs a file. Likely not!

    Check all boxes on the screen (clear any restrictions if it shows any)
    Then click GO!

    When the entire page is finished click the HammerHead at bottom to go to the second DAF page.

    Here, one at a time, do the below:

    Reinstall BITS
    Reinstall Windows Firewall
    Repair Permissions
    Reset networking

    Watch for any File not found or other errors and make note as this may lead to the fix!

    Restart computer.
  22. geoffd86

    geoffd86 TS Rookie Topic Starter Posts: 50

    I tried all steps except DAF, but unfortunately I don't have an XP cd. Can I still run it?
  23. Broni

    Broni Malware Annihilator Posts: 53,867   +370

    Yes, go ahead...
  24. geoffd86

    geoffd86 TS Rookie Topic Starter Posts: 50

    I ran DAF and this is exactly what it said for a few files. I might have missed the second one because I thought it was repeating the first one, but here goes:

    Error 127 C:\WINDOWS\system32\iesetup.dll in not registerable or the file is corrupted. Your version of iesetup.dll is: 8.00.6001.18702. Please contact dial-a-fix@DjLizard.net so that an exception can be made for your version of this file.

    Same message for inseng.dll or ensing.dll (i think) ???

    All had the same message, file path and number

    Also when I started the program couldn't figure out which version of ie i was running so i sent them an e-mail like it said

    I also didn't do the hammerhead step because it required the internet or the XP cd
  25. Broni

    Broni Malware Annihilator Posts: 53,867   +370

    1. Click Start>Run (Start>"Start search" in Vista).

    2. Type in (or copy and paste):

    cmd /c ping google.com>%temp%\$.$&notepad %temp%\$.$

    and press Enter.

    3. Notepad will open.

    4. Copy all text in Notepad ([Ctrl-A], then [Ctrl-C]), and then post it (paste = [Ctrl-V]) in your next reply.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...