Need help with weird crashing issue

I just built a new PC for my mother, and she came across random crashing. The screen flickers from black, gray, and green and the only way to fix it is to restart the pc. I tried to figure it out but the only error I could find in event viewer is: License Activation (slui.exe) failed with the following error code: hr=0x80072EFD Command-line arguments: RuleId=31e71c49-8da7-4a2f-ad92-45d98a1c79ba;Action=AutoActivate;AppId=55c92734-d682-4d71-983e-d6ec3f16059f;SkuId=2b1f36bb-c1cd-4306-bf5c-a0367c2d97d8;NotificationInterval=1440;Trigger=NetworkAvailable Windows is not activated but not pirated (it was from the Microsoft website). I am wondering if activating Windows will fix the problem. Thanks Specs: Ryzen 2200G (with Vega 8) Stock cooler corsair vengeance 16gb 3200mhz Gigabyte B450m Ds3h EVGA 450w 80+ bronze EDIT: I tried running heaven but about 10 seconds in the problem occurs.
EDIT 2: It blue screened at one point saying LiveKernelEvent:
Fault bucket , type 0 Event Name: LiveKernelEvent Response: Not available Cab Id: 0
Problem signature: P1: 141 P2: ffffd78f707ee010 P3: fffff8065e8aa7b0 P4: 0 P5: 1868 P6: 10_0_18362 P7: 0_0 P8: 256_1 P9: P10:
Attached files: \?\C:\Windows\LiveKernelReports\WATCHDOG\WATCHDOG-20200902-0722.dmp \?\C:\Windows\TEMP\WER-30171-0.sysdata.xml \?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER8D3C.tmp.WERInternalMetadata.xml \?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER8D4C.tmp.xml \?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER8D6B.tmp.csv \?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER8D8B.tmp.txt
These files may be available here: \?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\Kernel_141_f4b74160e0375a96cdb671e79b3ce7d74d1baaae_00000000_cab_4f87025a-c2c6-4d64-afee-b7a8360f8b0a
Analysis symbol: Rechecking for solution: 0 Report Id: 4f87025a-c2c6-4d64-afee-b7a8360f8b0a Report Status: 2049 Hashed bucket: Cab Guid: 0
 

Kshipper

Posts: 78   +9
TechSpot Elite
I got a BSOD too and a Watchdog error on my main machine when I plugged a new USB 2.5" enclosure into my computer. I Googled around and many said AHCI drivers and make sure you have the latest BIOS. I plugged the same drive into a different computer (that is using the same motherboard and CPU you have) and I got different errors.

I don't think any of it is related to activation because mine is activated and that 2n d machine passed all the benchmarks I threw at it. I built it properly too, F50 BIOS latest chipset drive from AMD and Adrenaline driver. Win 10x 64 vers 1909. Drivers from the Gigabyte website (other then VGA and chipset).