NET::ERR_CERT_AUTHORITY_INVALID

Setfree

Posts: 24   +4
I cannot get to startpage.com because no matter what browser I use (Chrome, Opera, or Brave), I get this error: "Your connection is not private," "NET::ERR_CERT_AUTHORITY_INVALID," Error also mentions HSTS. This even happens when trying to go to pandasecurity.com to see how to fix the error.
Nothing I have tried at Google Chrome Help or pandasecurity or elsewhere has fixed it. I do not have this issue on any other PC no matter the O.S. The PC with the issue has a new load of Windows 7 Pro, 4GB ram, Dell Inspiron E1505.

Any help is appreciated. Thanks
 

Setfree

Posts: 24   +4
  • Thread Starter Thread Starter
  • #3
There's a bad Certificate on the system -- look for an update
Thanks Jobeard. I tried that with a known good Certificate from a working PC. No fix. Also tried: Settings → Advanced → Manage Certificates-Import-Export...No fix. Is there a different way?
 

Setfree

Posts: 24   +4
  • Thread Starter Thread Starter
  • #7
So far Jobeard, the only 2 are pandasecurity.com and startpage.com that I know of. The interesting thing is I can get to my startmail.com (which is a partner of startpage.com) I was referred by startmail.com support, to contact startpage.com support, which I did on 5/9/2020...but so far they have not contacted me. From what I found I am not alone with that issue although not necessarily with startpage.
 

Setfree

Posts: 24   +4
  • Thread Starter Thread Starter
  • #10
Did not have to install Firefox 76.1. Installing SP2 did the trick Jobeard. Tanks a heap! 😁 Funny thing is, my other Win7 PC's only have SP1, and don't have the issue. Mark this baby SOLVED, thanks to Jobeard!
 

jobeard

Posts: 13,868   +1,756
BTW: it wasn't SP2 directly, but it reloaded fresh Windows Certs and that was the fix -- albeit SP2 was the short path :)
 
Last edited:
  • Like
Reactions: Setfree