Network Connection Problems

By Creamy_Goodness ยท 22 replies
Jul 9, 2008
  1. Hi guys - A while back my workstation started doing something rather strange.

    Specs as follows according to Everest, if it helps.

    OS is XP Pro SP2
    MB is Acer E91M with a P4 3.2ghz 540J

    At first login the PC would tell me I had a network error - the message varied between "Limited or No Connectivity" to "Network cable unplugged". After a random amount of time a connection would suddenly be established. (Random as in the shortest time I had to wait was around 60 seconds and the longest 2 hours) Restarting didn't solve the problem.

    Once the connection was re-established it wouldn't drop at all even if I did a cold boot. The problem was only at 1st login.
    My first guess was that the on-board adapter was damaged, so disabled it and replaced with a seperate NIC but with no luck. Also tried different network points and cables.
    Today for the first time it started dropping connection at random during the course of the day as well.

    Has anybody had similar experiences? I'm starting to think it's a software issue and not hardware but before I start doing a full re-installation I thought I'd pick some brains.

    thanks for any help you can provide!
  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Note particularly: "Allow the computer to turn off this device to save power
    If the network adapter supports this option, it is available on the Power Management tab of the network adapter properties dialog box. To resolve this issue, disable this option on the Power Management tab. For more information about how to disable this power management option, click the following article number to view the article in the Microsoft Knowledge Base:
    811595 ( "A network cable has been unplugged" message appears at seemingly random intervals"
  3. Creamy_Goodness

    Creamy_Goodness TS Rookie Topic Starter Posts: 26

    Thanks - Have disabled "save power" function on on-board interface. The NIC doesn't support that function.
    I'll have to see in the morning what the results are, and will post then.

    For some reason I cannot connect to Microsoft Support but will keep on trying.

    Thanks once again.
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    To test/debug what might really be going on here requires a brief overview on how a computer attains its IP address.​

    There are different methods possible for a computer to attain an IP address. One of the most common follows a protocol called DHCP. It stands for "Dynamic Host Configuration Protocol". In a simplified view of the process, your computer "requests" an IP address from a DHCP server. The DHCP server grants the request and assigns it an IP address. Note, with this method
    • The requesting computer is not guaranteed the same IP address everytime. The choice of IP address is up to the DHCP server which can change it if it feels like it.
    • If your computer sits behind a router in your own Local Area Net (LAN) there are two DHCP servers involved
    • Computers on your LAN are typically configured to use your router as a DHCP server.(These are all you LAN IP addresses)
    • Your router is typically configured to request its IP address from a DHCP server at your ISP (This is your one public IP address)
    In reality, the DHCP protocol gets a bit more involved.
    • The client computer "requests" an IP address
    • The server grants it "a lease" to an IP address. The lease time is the amount of time the client is allowed to use the IP adress granted. Note the IP address granted is not guaranteed to never change even while the client stays up and running.
    • When half-the-lease-time has expired, the client must start issuing "renew" requests asking the server to renew its least.
    • Anytime before lease expiration, the server may choose assign a new lease time for the IP address or deny the renew request in which case it would typically follow it with a new lease on a new IP address.
    just fyi: As i recall the minimum lease time is 8 hours which, for this case, mean a client would start trying to renew its lease as early as every 4 hours.. So theoretically, this method can change your IP address every 4 hours!

    To troubleshoot your problem, suggest you understand:
    • Is the problem with the ISP assigning the IP to the router?
    • Is the problem with your router assigning the IP to your LAN devices?
    • Understanding why a IP lease renew request is being denied (if that's the case) and for how long it's being denied. It shouldn't be a problem if it's denied but immediately granted a new lease to a new IP (unless for example maybe the computer who was denied doesn't handle the new IP reassignment very well or so quickly)
    To resolve these, you might want to:
    1. Test without using a router. Only one computer and one DHCP server in that case
    2. Test with mutliple computers going through the router. Some routers will log the DHCP release/renew events which you can read to better undersand what's going ont
    3. Go through you router documentation as they often have several options to see what is happening
      • Logging DHCP events
      • Display router current status including what it believes to be the current IP assignment for each computer
      • They provide functions you can use to release/renew IP addresses when you want to
    4. Use the ipconfig from a command window on your computer to release/renew IP addresses with the router ipconfig /release or ipconfig /renew
    5. Add a "network sniffer" to monitor your LAN traffic and capture and see the DHCP commands between your computers and the router to better understand what might really be going on
  5. wakasaki

    wakasaki TS Rookie

    Hello Creamy_Goodness,

    Definitely read and try what LookinAround has posted. Good job LookinAround, I copied all that down and put it in a text file for later personal use.

    The only other thing I can think of would be viruses or spyware. They can do almost anything to computers these days.

    I would sugest one of the following anti-viruses
    Avast Anti-Virus
    AVG Anti-Virus
    Avira Anti-Virus
    Choose one of those free Anti-Viruses, don't use them all at once. May cause conflicts.

    I would recommend Spybot S&D as your Spyware and other malicious software descovery tool.

    I would also recommend using CCleaner to remove unneeded files from your computer and to "fix" potential issues in your registry.

    Also use ATF_Cleaner to remove unneeded files.

    Good Luck :)
  6. djfastlane1

    djfastlane1 TS Rookie

    hi everyone im almost having the same problem, i just purchased a wirless netgear wgt624 router and i have a hp vista laptop. i also have an arris touchtone comcast dsl modem. my problem is that i can connect to the internet wirelessly thought the router. but i can not connect on the internet on my desktop. i would like to get the internet goin at the same time both through the router. i have tried to insert an e cable from the router directly to the computer but i get limited or no connectivity. and its not the cable bcuz i swapped out with another e cable and the same result occurs. plz help
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hi djfastlane1

    I'm sure you'll be able to get some help. However, you should start by reviewing some Guidelines AND starting a new thread which addresses your problem and put it in the correct forum (for your specific case, ie. Mobile Computing)

    Be sure to give more specifics about your hp vista laptop (like make/model and exactly which version of vista). It would also help if you found the tag on your cable modem and stated its exact make/model number as well.

    There are many variables involved in fixing a problem. Always start by indicating your hardware and software specifics for what;s involved. (e.g. There are several different versions of Vista. Knowing which version can make a difference)

    TechSpot Forums Community Guidelines

    TechSpot Forums Software FAQ (Frequently Asked Questions)
  8. jobeard

    jobeard TS Ambassador Posts: 11,123   +982

    get a command prompt (run->cmd) and enter
    ipconfig /all
    copy and paste the results in your follow.

    'limited connectivity' usually means your system did not find the DHCP service
    and therefore took a default 169.x.x.x address.

    If you see that, then go to your NIC and be sure to set DHCP for both the IP & DNS addresses.
  9. djfastlane1

    djfastlane1 TS Rookie

    what is a NIC? and how do i this?
  10. Johnnypass

    Johnnypass TS Rookie


    NIC stands for Network Interface Card....

    Go to RUN and type in "cmd" press enter

    Type in ipconfig /all and press enter

    Various information will be displayed

    We need to know what Ip address, subnet mask, default gateway you have been assigned and wether you have DHCP enabled.... oh and your DNS details would be helpfull too.
  11. djfastlane1

    djfastlane1 TS Rookie

    ok i did all of that and yes dns is enabled. now wat?
  12. jobeard

    jobeard TS Ambassador Posts: 11,123   +982

    DNS or DHCP?
  13. djfastlane1

    djfastlane1 TS Rookie

    sorri bout that DHCP
  14. xxdanielxx

    xxdanielxx TS Booster Posts: 1,069

    sounds like you need to clear your winsocket try what I have posted below.

    Open a Command Prompt window
    1. Start>Run>Type cmd and click ok you will get a black box.
    2. Type netsh int ip reset resetlog.txt and press Enter make sure to put the spaces. The original prompt will reappear.
    3. Now type netsh winsock reset catalog and press Enter
    4. type exit press Enter and reboot the laptop.

    Let me know if this solve the problem.
  15. djfastlane1

    djfastlane1 TS Rookie

    if im doin all of this on my laptop, or am i? but if im doin this on my laptop then how does it help my connection on my desktop?
  16. xxdanielxx

    xxdanielxx TS Booster Posts: 1,069

    lol this is a normal thing I post I forgot to change it to desktop
  17. djfastlane1

    djfastlane1 TS Rookie

    ok i did wat u said and nothing happened.
  18. xxdanielxx

    xxdanielxx TS Booster Posts: 1,069

    sorry can you give more information. Nothing happen when you entered the commands in the black window or after you rebooted you still get the same problem
  19. djfastlane1

    djfastlane1 TS Rookie

    after i rebooted i had the same problem
  20. xxdanielxx

    xxdanielxx TS Booster Posts: 1,069

    I want to see if you dont have a malware that is blocking your internet

    * Click here to download HJTsetup.exe
    • Save HJTsetup.exe to your desktop.
    • Doubleclick on the HJTsetup.exe icon on your desktop.
    • By default it will install to C:\Program Files\Hijack This.
    • Continue to click Next in the setup dialogue boxes until you get to the Select Addition Tasks dialogue.
    • Put a check by Create a desktop icon then click Next again.
    • Continue to follow the rest of the prompts from there.
    • At the final dialogue box click Finish and it will launch Hijack This.
    • Click on the Do a system scan and save a logfile button. It will scan and the log should open in notepad.
    • Click on "Edit > Select All" then click on "Edit > Copy" to copy the entire contents of the log.
    • Come back here to this thread and Paste the log in your next reply.
    • DO NOT have Hijack This fix anything yet. Most of what it finds will be harmless or even required.
  21. djfastlane1

    djfastlane1 TS Rookie

    Logfile of Trend Micro HijackThis v2.0.2
    Scan saved at 7:55:35 AM, on 7/13/2008
    Platform: Windows XP SP2 (WinNT 5.01.2600)
    MSIE: Internet Explorer v7.00 (7.00.6000.16674)
    Boot mode: Normal

    Running processes:
    C:\Program Files\Bonjour\mDNSResponder.exe
    C:\Program Files\Dell AIO Printer A940\dlbabmgr.exe
    C:\Program Files\Java\jre1.6.0_05\bin\jusched.exe
    C:\Program Files\HP\HP Software Update\HPWuSchd2.exe
    C:\Program Files\Messenger\msmsgs.exe
    C:\Program Files\Dell AIO Printer A940\dlbabmon.exe
    C:\Program Files\HP\Digital Imaging\bin\hpqtra08.exe
    C:\Program Files\Kodak\Kodak EasyShare software\bin\EasyShare.exe
    C:\Program Files\HP\Digital Imaging\bin\hpqSTE08.exe
    C:\Program Files\HP\Digital Imaging\Product Assistant\bin\hprblog.exe
    C:\Program Files\Internet Explorer\iexplore.exe
    C:\Program Files\Ares\Ares.exe
    C:\Program Files\Trend Micro\HijackThis\HijackThis.exe

    R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Bar =*
    R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Page =*
    R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page =
    R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL =
    R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL =*
    R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Bar =*
    R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page =*
    R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page =
    R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant =
    R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =
    R1 - HKCU\Software\Microsoft\Internet Explorer\SearchURL,(Default) =*
    R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,ProxyServer = :0
    O2 - BHO: &Yahoo! Toolbar Helper - {02478D38-C3F9-4efb-9B51-7695ECA05670} - C:\PROGRA~1\Yahoo!\Companion\Installs\cpn\yt.dll
    O2 - BHO: Yahoo! IE Services Button - {5BAB4B5B-68BC-4B02-94D6-2FC0DE4A7897} - C:\Program Files\Yahoo!\Common\yiesrvc.dll
    O2 - BHO: (no name) - {6B690ACD-9479-4C41-8A2D-D6083F650E81} - C:\WINDOWS\system32\HPDirecter.dll
    O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre1.6.0_05\bin\ssv.dll
    O2 - BHO: (no name) - {E6280729-9251-41D7-BC1C-572C9548C962} - C:\WINDOWS\system32\HPI4.dll
    O3 - Toolbar: Yahoo! Toolbar - {EF99BD32-C1FB-11D2-892F-0090271D4F88} - C:\PROGRA~1\Yahoo!\Companion\Installs\cpn\yt.dll
    O4 - HKLM\..\Run: [Dell AIO Printer A940] "C:\Program Files\Dell AIO Printer A940\dlbabmgr.exe"
    O4 - HKLM\..\Run: [SunJavaUpdateSched] "C:\Program Files\Java\jre1.6.0_05\bin\jusched.exe"
    O4 - HKLM\..\Run: [HP Software Update] C:\Program Files\HP\HP Software Update\HPWuSchd2.exe
    O4 - HKCU\..\Run: [MsnMsgr] "C:\Program Files\MSN Messenger\MsnMsgr.Exe" /background
    O4 - HKCU\..\Run: [ares] "C:\Program Files\Ares\Ares.exe" -h
    O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\system32\ctfmon.exe
    O4 - HKCU\..\Run: [MSMSGS] "C:\Program Files\Messenger\msmsgs.exe" /background
    O4 - HKCU\..\Run: [Yahoo! Pager] "C:\PROGRA~1\Yahoo!\MESSEN~1\YAHOOM~1.EXE" -quiet
    O4 - HKCU\..\Run: [swg] C:\Program Files\Google\GoogleToolbarNotifier\GoogleToolbarNotifier.exe
    O4 - Global Startup: HP Digital Imaging Monitor.lnk = C:\Program Files\HP\Digital Imaging\bin\hpqtra08.exe
    O4 - Global Startup: Kodak EasyShare software.lnk = C:\Program Files\Kodak\Kodak EasyShare software\bin\EasyShare.exe
    O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~2\Office12\EXCEL.EXE/3000
    O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_05\bin\ssv.dll
    O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_05\bin\ssv.dll
    O9 - Extra button: Send to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\PROGRA~1\MICROS~2\Office12\ONBttnIE.dll
    O9 - Extra 'Tools' menuitem: S&end to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\PROGRA~1\MICROS~2\Office12\ONBttnIE.dll
    O9 - Extra button: Yahoo! Services - {5BAB4B5B-68BC-4B02-94D6-2FC0DE4A7897} - C:\Program Files\Yahoo!\Common\yiesrvc.dll
    O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MICROS~2\Office12\REFIEBAR.DLL
    O9 - Extra button: (no name) - {CD67F990-D8E9-11d2-98FE-00C0F0318AFE} - (no file)
    O9 - Extra button: Run IMVU - {d9288080-1baa-4bc4-9cf8-a92d743db949} - C:\Documents and Settings\jauniece\Start Menu\Programs\Yahoo! Messenger\IMVU\Run IMVU.lnk (file missing)
    O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
    O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe
    O16 - DPF: {01A88BB1-1174-41EC-ACCB-963509EAE56B} (SysProWmi Class) -
    O16 - DPF: {02BF25D5-8C17-4B23-BC80-D3488ABDDC6B} -
    O16 - DPF: {138E6DC9-722B-4F4B-B09D-95D191869696} (Bebo Uploader Control) -
    O16 - DPF: {1D4DB7D2-6EC9-47A3-BD87-1E41684E07BB} -
    O16 - DPF: {30528230-99f7-4bb4-88d8-fa1d4f56a2ab} (Installation Support) - C:\Program Files\Yahoo!\Common\Yinsthelper.dll
    O16 - DPF: {54BE6B6F-3056-470B-97E1-BB92E051B6C4} (DeviceEnum Class) -
    O16 - DPF: {639658F3-B141-4D6B-B936-226F75A5EAC3} (CPlayFirstDinerDash2Control Object) -
    O16 - DPF: {77E32299-629F-43C6-AB77-6A1E6D7663F6} -
    O16 - DPF: {8AD9C840-044E-11D1-B3E9-00805F499D93} (Java Runtime Environment 1.6.0) -
    O16 - DPF: {AF2E62B6-F9E1-4D4F-A10A-9DC8E6DCBCC0} (VideoEgg ActiveX Loader) -
    O16 - DPF: {B8BE5E93-A60C-4D26-A2DC-220313175592} (MSN Games - Installer) -
    O16 - DPF: {BAE1D8DF-0B35-47E3-A1E7-EEB3FF2ECD19} (CPlayFirstddfotgControl Object) -
    O16 - DPF: {BF985246-09BF-11D2-BE62-006097DF57F6} (SimCityX Control) -
    O16 - DPF: {CF40ACC5-E1BB-4AFF-AC72-04C2F616BCA7} (get_atlcom Class) -
    O16 - DPF: {D27CDB6E-AE6D-11CF-96B8-444553540000} (Shockwave Flash Object) -
    O16 - DPF: {D4323BF2-006A-4440-A2F5-27E3E7AB25F8} (Virtools WebPlayer Class) -
    O16 - DPF: {D71F9A27-723E-4B8B-B428-B725E47CBA3E} -
    O16 - DPF: {DA80E089-4648-43D5-93B4-7F37917084E6} (CacheManager.CacheManagerCtrl) -
    O16 - DPF: {DC75FEF6-165D-4D25-A518-C8C4BDA7BAA6} (CPlayFirstDinerDashControl Object) -
    O16 - DPF: {E5D419D6-A846-4514-9FAD-97E826C84822} (HeartbeatCtl Class) -
    O16 - DPF: {EA6246B4-F380-443F-8727-9AEA3371146C} (CPlayFirstWeddingDashControl Object) -
    O20 - Winlogon Notify: GoToAssist - C:\Program Files\Citrix\GoToAssist\508\G2AWinLogon.dll
    O23 - Service: Ares Chatroom server (AresChatServer) - Ares Development Group - C:\Program Files\Ares\chatServer.exe
    O23 - Service: ASP.NET State Service (aspnet_state) - Unknown owner - C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_state.exe (file missing)
    O23 - Service: ##Id_String1.6844F930_1628_4223_B5CC_5BB94B879762## (Bonjour Service) - Apple Computer, Inc. - C:\Program Files\Bonjour\mDNSResponder.exe
    O23 - Service: FLEXnet Licensing Service - Macrovision Europe Ltd. - C:\Program Files\Common Files\Macrovision Shared\FLEXnet Publisher\FNPLicensingService.exe
    O23 - Service: GoToAssist - Citrix Online, a division of Citrix Systems, Inc. - C:\Program Files\Citrix\GoToAssist\508\g2aservice.exe
    O23 - Service: InstallDriver Table Manager (IDriverT) - Macrovision Corporation - - C:\WINDOWS\system32\LEXBCES.EXE
  22. djfastlane1

    djfastlane1 TS Rookie

    O23 - Service: LexBce Server (LexBceS) - Lexmark International, Inc. - C:\WINDOWS\system32\LEXBCES.EXE
    O23 - Service: InstallDriver Table Manager (IDriverT) - Macrovision Corporation - C:\Program Files\Common Files\InstallShield\Driver\11\Intel 32\IDriverT.exe
    End of file - 10169 bytes
  23. xxdanielxx

    xxdanielxx TS Booster Posts: 1,069

    I only saw a couple of things which are not malware but can be removed if you like.

    As for the internet connection as a last resort I want you to download winsock xp fix from the link below then run it.

    Make sure to click on ReG-Backup first to backup your registry then click on fix

    Winsock XP Fix
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...