New build, freezing occasionally w/black screen and oversized mouse cursor

By mentalkayse ยท 15 replies
Jul 24, 2010
Post New Reply
  1. Ok, I just put this computer together for my mother in law and it's been randomly freezing, usually with a black screen and an oversized mouse cursor arrow. Once it had like 4 mouse cursor arrows.
    This is what the even viewer says;
    The Monitor Image service terminated with the following error:
    A dynamic link library (DLL) initialization routine failed.

    Google has been no help at all.
    I think I may need update the video drivers but I'm not sure. I've been trying to download them since early this morning but the computer crashes before I can.
  2. EXCellR8

    EXCellR8 The Conservative Posts: 1,835

    which operating system is this and what are you using for a graphics card?
  3. mentalkayse

    mentalkayse TS Rookie Topic Starter Posts: 23

  4. mentalkayse

    mentalkayse TS Rookie Topic Starter Posts: 23

    OK, I uninstalled the vga drivers and am now running on the default drivers. Everyone likes the way it looks now better anyways so I'm gonna try that and see if that stops the freezes.
  5. mentalkayse

    mentalkayse TS Rookie Topic Starter Posts: 23


    Computer ran fine for 9+ hours, sitting idle, while I was working on someone's PC. About 10 minutes after I connect to the net, I get a BSOD. 0x7F.
    Attached is the one minidump that I got from this.
    I'll run memtest tonight and see what that comes up with, if it passes then I'll run quicktech tomorrow. Although, they both passed earlier today so I dunno...

    Attached Files:

  6. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    It is indeed an 0x7F_D UNEXPECTED_KERNEL_MODE_TRAP_M error, which occurs because a trap of a kind that the kernel isn't allowed to have/catch (bound trap) or that is always instant death (double fault).

    Anyway, the process mentioned in the minidump i.e. win32k.sys, and I suspect it has to do with your VGA.

    Generally, 0x7F_D means it is an hardware issue. But before jumping to any conclusion, if you have more minidumps, I'd rather like to have a look at them, please zip them in a single file and attach with your next post. Regards
  7. mentalkayse

    mentalkayse TS Rookie Topic Starter Posts: 23

    Sure thing, boss. I got a couple more from last night.

    btw, Memtest passed, 8 passes no errors.

    Attached Files:

  8. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    Again exactly the same error, UNEXPECTED_KERNEL_MODE_TRAP which indicates that your CPU generated a trap that the error handler did not catch, so the CPU signaled a double fault. In this case looking at the first parm = 0x0 (UNKNOWN_DIVIDE_BY_ZERO) a division by zero was attempted and obviously cannot be done. So the CPU signaled that an illegal instruction was attempted; BSOD followed.

    I need you to do this, so it can be determined what driver is causing the problem, which may lead us to suspected hardware component as well, I need you to enable driver verifier.


    Before proceeding on the following steps please ensure that you can boot your system in safe mode.

    1) Windows Key + R (or go to Start, then click on Run..)
    2) Type in 'verifier' and hit enter
    3) Make sure 'Create Standard Setting' is selected and hit next
    4) Click on 'Select all drivers installed on this computer' and hit Finish
    5) Reboot

    There is a possibility that your computer will crash on reboot. If this occurs hit F8 when rebooting just before the windows logo screen and select the safe mode boot option. Follow the same steps above but on step 4 choose 'Select driver names from a list'; hit next; check the box next to any driver where the provider is not Microsoft; hit Finish; reboot.

    This will slow the performance of you computer a little while enabled but will hopefully catch the driver causing corruption. Next time you crash the blue screen will hopefully say something like "DRIVER_VERIFIER_DETECTED_VIOLATION". When this occurs please post your new minidump.

    Please note that Driver Verifier will continue to run on every boot up until you run (by going to Start, then to Run):

    verifier /reset


    One more thing which I noticed is you are running XP with SP2, please consider upgrading to SP3.

    Lastly, if this thing is still in warranty (which I believe it should be) consider about taking it back and asking them to either fix it or replace it. Regards
  9. mentalkayse

    mentalkayse TS Rookie Topic Starter Posts: 23

    I'll try verifier in a few. The motherboard is still under warranty so I'm gonna call the manufacturer monday and see about a replacement, if it is hardware related. Also, I can't update to SP3 yet since I can't get the computer to connect to the internet for more than a few minutes at a time. Do you think it could be the modem causing it? We are on dial up out here and the modem is well over 10 years old. Also, on this last reboot, it said that the modem couldn't be found or was busy and then when I restarted it said the modem was out of order when I tried to connect. I tried again and it worked just fine.
  10. mentalkayse

    mentalkayse TS Rookie Topic Starter Posts: 23

    I let verifier run 3 times and all three came up with "a device driver attempting to corrupt the system has been caught the faulty driver on the kernal stack must be replaced with a working version"
    the stop is 0xC4
    attached is the minidumps.

    Attached Files:

  11. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    All three dumps are off 0xc4_60, citing memory corruption as the cause. Unfortunately none of the dumps came up with a specific device driver. Probably the driver is unloading without first freeing all its memory pools, hence the OS is crashing with 'memory corruption' error. the fourth parameter which tells the total number of paged/nonpaged pool allocations is 1.

    I guess at this moment, I'd suggest you to wait till monday and take this thing back to store where you purchased it.
  12. mentalkayse

    mentalkayse TS Rookie Topic Starter Posts: 23

    Not that simple, I didn't buy it at any store, I pieced it together with some new parts from newegg and some old parts from a previous build. I'm now reduced to using my laptop as the computer, while it will run fine, won't let me on the internet. When I try to connect, it will either reboot or blue screen within 10 minutes or tell me that the modem wasn't found. Not a big deal, the modem is over 10 years old. I just got back from a virus removal job and was going to barter an old modem out of them but forgot to get it so I guess I'll pick up one at the pawn shop tomorrow and see if that fixes it. The computer will run fine all day long as long as I don't try to connect so I'm almost positive it's the modem.
  13. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    Fair enough, start from vga, if you can find some friend who could lend you a PCI-E graphic card, try that and see whether it helps.

    Then memory (if you have multiple memory modules, run system with one at a time).
  14. mentalkayse

    mentalkayse TS Rookie Topic Starter Posts: 23

    Got a new (used) modem from the pawn shop for $2, been connected for 20+ minutes with no trouble at all so far. I'll post if anything else pops up but at this time, I think it's been solved.
  15. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    Ok, please do keep things update here about your progress.
  16. mentalkayse

    mentalkayse TS Rookie Topic Starter Posts: 23

    Computer was on all night last night, connected to the net for well over 10 hours. Still running like a top.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...