New build not powering up

By SNGX1275 ยท 8 replies
Mar 2, 2012
Post New Reply
  1. A friend of mine bought some components and had not built a computer before so he brought them over and I helped him put it together. We put it together, hit the power switch and nothing. I suspect a bad motherboard, but I know thats a common thought when things don't work initially, and most of the time its incorrect. So here is what we did to try and troubleshoot it.

    Unplugged the PSU from the motherboard, and shorted out the green wire and a ground. PSU fan spun up. So figured PSU is ok, but I know thats not always true because I've seen bad ones do that too.

    Tried known good PSU from my collection.

    Removed the power switch headers and tried shorting with a screwdriver incase I put the wrong wires on the headers. (The case he's using is one of my old ones and its got all individual wires rather than the nice block to put on the headers, so I thought maybe it was possible I made a simple mistake).

    Removed the motherboard from the case, to eliminate a short somewhere.

    Reset CMOS.

    Removed the RAM (this was a longshot I know)

    So in summary, I think I've ruled out the following:
    Bad power switch or incorrectly wired power switch.
    Bad PSU.
    Short between the mobo and the case.

    What have I missed?

    Hardware involved:
    Corsair CX 500 PSU
    ASRock H61M/U3S3 Mobo
    Intel i3-2100
    Patriot Signature Line DDR3 RAM (2x4GB)
    No HDDs or Optical drives connected at this time.
  2. TomSEA

    TomSEA TechSpot Chancellor Posts: 2,718   +860

    Do you have another MOBO lying around you can plug in? That will provide your "which part is broken" answer in a matter of a few seconds.
  3. Buckshot420

    Buckshot420 TS Enthusiast Posts: 301

    did you turn on the power switch on the new PSU? You say you did on the old one but just wondering if maybe you forgot on the new one. Sometimes it's that simple so I have to ask.
  4. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,742   +421

    Unfortunately, no. My main system is a C2D, and my girlfriend's system is an AMD AM3 system.

    Yep, tried that :)
  5. TomSEA

    TomSEA TechSpot Chancellor Posts: 2,718   +860

    I'd pack the box up and head to a reputable computer repair store. Not Best Buy Geeks or any chain store like that. Most of the smaller computer repair places are more than happy to help you diagnostic it. And they'll definitely have a spare MOBO lying around you can check it out on. Good luck!
  6. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    As you mentioned, the PSU could still definitely be at fault.

    The flow chart for this would be pretty simple. Barring some exceptional circumstance (like a bad add-on card shorting the PCI-e bus), you're left with two possibilities: motherboard or PSU.

    More often than not, PSUs seem to be the problem. It wouldn't be the first bad, new motherboard I've seen though. I"m sure raybay can give you statistics.

    Also, it sounds like you have some other systems hanging around. Someone suggesting trying a new motherboard, but how about trying the PSU in another system? If it powers up your C2D PC, for example, the PSU is almost certainly good. After that, you could conclude the issue is the motherboard with a very high degree of certainty.
  7. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    You didn't forget to connect the 12volt AUX connector near the CPU did you?
  8. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,742   +421

    Rick, I tested the not working system with 2 PSUs, one of which I have used to power other systems before, so that should eliminate this being a PSU issue.

    Tmagic650 - nope, I connected everything properly :)
  9. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Motherboard then :(

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...