New build rig worked for a week, then died. No power

  1. I built a new rig one week ago. It worked fantastic since then,. Shut it down last night after it appeared to go into sleep mode, but I couldn't get out of it and just manually shut down.

    This morning I wake up, push "power" and nothing. No response whatsoever. No fans, no recognition at all by the machine. The green LED light on the mobo is on.

    I have an Ultra PSU and thought perhaps it was the culprit. Bought a Corsair, installed it, and again nothing when I press power. Reinstalled the Ultra, again no response at all.

    Completely at a loss.

    Processor: Phenom 2 965
    RAM: 4 GB
    GPU: 5870
    Mobo: Asus M4A79XTD Evo
    PSU: Ultra 650w LS
    Haven't even touched any overclocking.

    I beg you, please help.
  2. kristoffbrujah

    kristoffbrujah TS Rookie Topic Starter

    Tried taking out my GPU, RAM, and disconnecting my HDD and optical drive. Tried pressing power and no beeps, no sounds, no fans, nothing. :/
  3. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    It sounds like the motherboard has died, or the power switch and/or associated connections have a fault. You would need to test the wiring going to the power switch to make sure the switch is closing the circuit. If that is working ok check there is a supply voltage present going to the switch. If the wiring and the switch all prove to be fine then I think you should return the motherboard for a replacement. In your last test did you also disconnect keyboard and mouse, if not try it, disconnect absolutely everything except the monitor.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...