No Display on my Custom Built PC

By Calibur66 ยท 9 replies
Jul 1, 2009
  1. After spending hours putting together my new PC ( some new parts, some old parts from my previous computer) I finally get the thing to boot up. THe fans are spinng and the lights go on, but the only thing is theres no display. Ive tried multiple things to get it to work, but still no luck. If anyone has any feedback as to what i should do, it would be greatly appreciated.

    Here are the Specs:

    ASRock AOD790GX/128M AM2+/AM2 AMD 790GX ATX AMD Motherboard

    AMD Phenom 9750 2.4GHz Socket AM2+ 125W Quad-Core Processor

    Western Digital Caviar Black WD7501AALS 750GB 7200 RPM SATA 3.0Gb/s 3.5

    APEVIA ATX-AS520W-BK 520W ATX Power Supply

    POWERCOLOR AX3650 1GBD2 Radeon HD 3650 1GB 128-bit GDDR2 PCI Express 2.0 x16

    OCZ Platinum 2GB 240-Pin DDR2 SDRAM DDR2 1066 (PC2 8500)

    Also keep in mind the MoBo has an onbord video card which I've tried already, by itself and while the graphics card was still attached.
  2. FoReWoRd

    FoReWoRd TS Booster Posts: 204

    when you disconnect the video card, does the onboard work?
  3. Calibur66

    Calibur66 TS Rookie Topic Starter

    No it doesnt, Ive tried both the onboard video and my separate video card as well. Niether of them give off a display.
  4. raybay

    raybay TS Evangelist Posts: 7,241   +10

    As a first step, examine all cables, connectors, and sockets carefully... look for dirt/dust as well as bent components or wires pullled out of their protective sheathing.
    Often, the problem is the most simple of stuff...
    Also, double check your cpu. Look for one pin laying down, and to see if the CPU is flat against thermal paste evenly.

    Then remove everything you can, so that only the CPU, one memory module and hard drive are connected. Test. Then change memory module with the other, and test again.
    It is good to get these simple problem areas out of the way.
    It is also good to get away from the computer for a day or an evening, then come back to it when you are no longer frustrated, and well rested.
    We have all been there, and are all glad it is you instead of us.
  5. T77

    T77 TS Enthusiast Posts: 300   +6

    check whether the dvi or whatever cable is properly attached to the graphic card and the monitor.
  6. Calibur66

    Calibur66 TS Rookie Topic Starter

    Now I tried my old MoBo and it worked, I got a display. So i have a feeling its the mobo thats shot im going to RMA it and hopefully have some luck with the new one.
  7. FoReWoRd

    FoReWoRd TS Booster Posts: 204

    have you tried raybay's method of error testing.

    have you got a speaker attached so you can listen for any beep codes?
  8. Calibur66

    Calibur66 TS Rookie Topic Starter

    So I have my new mobo now pretty much the same as listed above (first post) with some slight diffrences and after a few trial and errors I acually got everything to work. Now I installed windows and all the drivers, but when I shut it down and went to attach more RAM and another hardrive I came to the same problem, which was it turning off almost instantly right after booting it up. So now im back to square one. I tried the hardrive I installed windows on with another MoBo and the same PSU and it worked, so im completely stumped as to what the problem could be. If it not the PSU, what I think it could be is that the ampage on the PSU is not high enough because the mobo im trying to run has a quad-core procceser (and the one that worked was only dual-core), but I would like to be sure before going ahead and buying another PSU.

    Does anyone have any idea what to do, or any advice as what I should try?
  9. raybay

    raybay TS Evangelist Posts: 7,241   +10

    How can it be anything else but bad memory or bad drivers... My bet is that one of your memory modules is bad... Have you retested, while using only one module at a time?
    You replaced the board. You replaced the CPU. So you ruled out two issues.
    Something you kept is bad.
    Could be an incorrect driver? Can you boot into <SAFE MODE> while depressing the <F8> key repeatedly once per second as soon as your depress the <ON> button? Then go to Start->Control Panel->System->Hardware->Device Manager to see how many red or yellow flags you have?
    I seriously doubt it is the power supply based upon what you have told us so far... "amperage is not high enough"? Seriously?
    Others: cpu fan wire pulled out? Damaged Power Supply wire? Power output from the wall? Look at your power box where you live to assure none of the power switches has popped to half open... long shot; Are you using a power sensor or protector such as an APC?
    Same computer case, presumably, so look there for a pulled, stretched, damaged wire or socket or power switch; Look for anything that may be grounding or shorting out in the case... also short or grounding in optical drive or hard drive - some Seagate drives were defective a few months ago and causing similar chaos. We have seen often enough problems where there is a great case and lousy wiring harness for the case... they are too often not tested..
    We assume you have done this, but it is always helpful (even if just to rule out possibilities) to break down. Reduce the system to fundamentals... different, old, or used power supply - or none at all, one minimal memory module... to as simple as you can... if it starts, you know something. If it doesn't start, you know something... then add or change... keeping notes as you go so as to keep your logic straight... It is as helpful to rule out problems as it is to find a cause.
    But my guess is something fundamental in the setup, or a bad memory module.
    Keep us posted. It is a lot more fun for us than it is for you... but we have all been there with that stress and anxiety and severe frustration...
    The best tool you have is to get lots of rest and focus on something else until you get this frustration out of your system... then try again.
    Good luck. You will figger it out.
  10. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...