1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

No post no beeps no display

By spunk59 ยท 5 replies
Dec 7, 2010
Post New Reply
  1. hey guys, recently bought a new case, switched my parts over flipped the switch and woot no post no beeps no display, no usb power, solid red HDLED in the front, power supply indicator light on the back of the PSU stays solid read, fans turn, fan led's operational, Motherboard power indicator is green.

    my first thought was a ground short in the case, checked and double checked not the case, so i thought ok faulty board or faulty CPU, ordered a new CPU and MB, put everything together properly all components seated correctly, plug the PSU in fans auto start no beeps no post no usb power no display, tried swapping ram and single testing, removed all components from case, tried just MB 1 stick of ram, and PSU ontop of the motherboard box, same issue, PSU light still stays solid red through this whole process (normal status is green, red is standby) computer will run like this indefinitly, have to remove power cord or flip psu switch to power off.

    even tried screwdriver bridge on pwr swtch pins, still stays on.

    tested PSU with tester, everything checked out, could my board + CPU be out of range for my PSU?

    any idea's?

    light spec's.

    Nspire 450W PSU
    AMD Phenom II X2 545 Callisto 3.0GHz 2 x 512KB L2 Cache 6MB L3 Cache Socket AM3 80W Dual-Core Processor
    GeIL Value PLUS 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1333 (PC3 10660)
    ASUS M4N68T-M V2 AM3 NVIDIA GeForce 7050PV/nForce 630a Micro ATX AMD Motherboard
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    I think you need a bigger, better power supply. Look into the Corsair line.

    What video card are you running?
  3. spunk59

    spunk59 TS Rookie Topic Starter

    yeah i figured it might be the psu its like 5 years old so probably doesnt have anywhere near the output it should.

    Nvidia Geforce 9500 GT is the card im using.
  4. gwailo247

    gwailo247 TechSpot Chancellor Posts: 2,010   +18

    So just to clarify, you first put all the same components from your old case into your new case, and had the problems.

    Then you replaced the mobo and CPU and had essentially the same problems?

    I'd tend to agree with Route44, try a different power supply. Its possible that when you moved stuff from one case to another something happened, but if all the same gear ran in the old case, there is no reason why the new case would change anything.

    I've had stuff like this happen to me, but it usually ended up being some plug or connector that wasn't secured, so after double checking everything it usually works, but since you already did that, this doesn't seem to be the cause.
  5. tronnex

    tronnex TS Rookie

    did you ever figure the problem out

    i am having same issue with same mobo, did you ever find the solution?
  6. Mark56

    Mark56 TechSpot Paladin Posts: 1,889

    Tronnex, your best bet is to start a new thread, list your system details and explain what is happening and someone should offer some help, attaching to an old thread is unlikely to get much help.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...