No signal from HD 5970

By Whiffen · 11 replies
May 8, 2010
  1. Hello, I recently purchased a Sapphire OC 5970 2GB and I can't seem to get any signal at all from it. I have 3 monitors (Planning to use eyefinity) and I have tried each of them one by one in the DVI ports but they all stay in Standby mode while the computer is turned on. I've tried using the VGA adapter as well to no avail.

    I've tried reseting bios, reseating, checking power connections, turning the monitors on and off, I swapped it back out for my 4850 and everything works fine.

    I have an ASUS M3N78 PRO which I will be upgrading to a ASUS Crosshair IV soon. My current power supply is a Corsair HX 750w PSU which should be able to handle it.

    When I press the power button the 5970 goes to full fan speed and displays red lights, not sure if thats meaningful or not, and I get the normal startup one beep code.

    Dead card? Something else I can try? Could the newer motherboard possible solve this?

    Thanks for any help in advance :D
  2. EpicPie

    EpicPie TS Rookie Posts: 46

    Did you download the catalyst drivers for the 5970?
  3. Whiffen

    Whiffen TS Rookie Topic Starter Posts: 235

    I downloaded the newest drivers and no luck either :p
  4. klepto12

    klepto12 TechSpot Paladin Posts: 1,115   +9

    sounds like you might not be getting enough power did you plug both connectors into the card? you might also try using a program like driver sweeper to make sure that you get all the little driver pieces out of the system then install the 5970.
  5. Whiffen

    Whiffen TS Rookie Topic Starter Posts: 235

    I'll try a complete wipe of the drivers.

    As for power I'm sure a high quality 750w is enough :) Only a Phenom II, 4GB DDR2, 1 HDD and 1 DVD.
  6. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    According to ATI/AMD you need:

    650 Watt or greater power supply with one 75W 6-pin and one 150W 8-pin PCI Express® power connectors recommended.

    Now if these additional power connectors are not delivering the required power you can have issues.

    Anyway, if your system gives display with your older/other graphic card, and the PSU is delivering the required power, you can be very certain that you've got a faulty graphic card to blame. Regards
  7. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    If you aren't getting a signal to the monitor during post, playing with drivers won't help. Any driver you install takes effect only when Windows starts. The BIOS comes with its own basic graphics driver which you can't touch unless you flash the whole BIOS. If the problem is no picture only when Windows starts, then it might be a driver problem but I don't think that applies here.

    As klepto12 and Archean suggest, I think you either have a defective card or a power problem.
  8. kalma

    kalma TS Rookie

    Hey Whiffen, I had the exact same problem and after doing all that was suggested in the previous posts, I brought my vid card back to where I bought it. They tested it and determined it was defective. They RMA'd it for me and I have a brand new card now and it works great! :D
  9. Whiffen

    Whiffen TS Rookie Topic Starter Posts: 235

    Thanks you guys, I will bring it in then :D
  10. Whiffen

    Whiffen TS Rookie Topic Starter Posts: 235

    Well, I brought it in and they stuck it in a testing rig. Worked fine. My expression was WHAT HOW HUH DO NOT GET!!! WTF

    I was starting to think that maybe I really didn't haven enough power... But on the way home I decided to buy the ASUS Crosshair IV, a 4GB kit of DDR3 and a Corsair Obsidian Case to complete my build and see how that would work....

    The card sullenly works flawlessly. I guess it didn't like the mobo :eek:

    Pictures of the build :)
  11. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    That's odd! Maybe a mobo chipset incompatibility. At least you got it working.
  12. Thomas3087

    Thomas3087 TS Rookie Posts: 18

    had a similar problem with my radeon 4750 swapped into a brand new system. monitors would shut off and go into standby mode either shortly after boot or before boot. for me it was my windows xp. don't know exactly but after every possible combination, windows 7 32bit solved the problem. now i'm runnin a lightning rod machine.


    Intel DH55TC mobo
    Intel i3 2.93 Duo core
    512gb DDR3 ATI Radeon HD 4750
    4gb DDR3 Corsair RAM
    1tb 7200RPM HD
    2x DVD-RW
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...