1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

ntfs.sys PAGE FAULT IN NONPAGE AREA bluescreen

By mgorbach ยท 145 replies
Jun 25, 2005
  1. Razorback

    Razorback TS Rookie

    CPC, I have been reading this thread and am having the same problems. I am attaching some of the minidump files I have had recently. If you wouldn't mind, I would appreciate knowing what you think. My memory runs Memtest flawlessly. I am going to reseat my ram in different slots in the meantime. TIA for any help.
  2. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Hi Razorback,
    One minidump crashes at IRQL x'1d' (ie 28) which is clock level interrupt. This is the symptom of hardware problem. According to my record, 50% is faulty CPU, 33.3% is faulty RAM and 16.7% is faulty M/B.

    An attempt was made to access a pageable (or completely invalid) address at an
    interrupt request level (IRQL) that is too high. This is usually
    caused by drivers using improper addresses.
    If a kernel debugger is available get the stack backtrace.
    Arg1: 00080000, memory referenced
    Arg2: 0000001c, IRQL
    Arg3: 00000001, value 0 = read operation, 1 = write operation
    Arg4: 804e2521, address which referenced memory

    One minidump crashes with code corruption due to memory corruption. This is the symptom of hardware error as well.

    CHKIMG_EXTENSION: !chkimg -lo 50 -d !nt
    805d8300-805d8302 3 bytes - nt!RtlpNewSecurityObject+4f6
    [ 90 90 8b:68 f5 df ]
    3 errors : !nt (805d8300-805d8302)

    MODULE_NAME: memory_corruption
    IMAGE_NAME: memory_corruption
    FOLLOWUP_NAME: memory_corruption
  3. Razorback

    Razorback TS Rookie

    Thanks for the quick response cpc2004. I have moved my ram to the other dual channel slots. So far so good. I recently upgraded from 512 MB to 1024 MB of ram. I was told to reset cmos via the jumper. I had only set bios to defaults when I changed it out. I went ahead and reset the bios this time with the jumper. If you were looking into this, what else would you check. It sounds like it might be anything. :confused:
  4. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    It may be the clock frequnecy of old and new ram is not identifical. For some of resolved cased relating error at IRQL x'1c', downclock the RAM may resolve your problem. Actually, you have 4 occurences of the problem within a month and it is acceptable. If you can tolerate the crash, just leave it.
  5. Porphyria

    Porphyria TS Rookie

    Hey, I've been having the ntfs.sys "Page Fault in Non Paged Area" error message for ages now. Whether I'm formatting my HD to reinstall windows, playing games, updating XP, etc, etc. I even brought my comp into the local shop where I bought it, and after 3 weeks, the guy only thought it was overheating. I've replaced my heatsink and even have a large fan situated in front of the open case...something tells me it isn't an overheating problem! Memory has been switched around, and sometimes it seems to run longer before getting the same error screen, but the problem still hasen't left. Hopefully someone could give me an idea of what might be wrong! Almost all the components of my computer have been replaced since I bought it (upgrades), so the only parts that have been around since the beginning of the problem is the motherboard, processor, memory, and of course the power supply. XP doesn't have SP2 installed yet, as I can't get that far without my comp freezing or shutting off. I had it updated before and it didn't help.

    I'm currently running a comp with:

    AMD Athlon 64 2000+
    Aopen AK7-8XN
    DDR333, one 256MB and one 512MB chip
    Ati Radeon 9600
    SB Audigy 2
    160GB HD and one 80GB HD
  6. Porphyria

    Porphyria TS Rookie

    Also, if it helps...my 512MB chip recently fried, I noticed it was no longer being recognized in the BIOS or in Windows....running my comp with only the 512 chip leads to it not even booting up...and with it out, so far my computer has been running fine, but I tried using only the 256mb chip before and it didn't get rid of my problem...
  7. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Hi Porphyria,

    I've studied your minidump. One minidump is inaccesible. Four minidumps have different bugcheck codes. It is hardware error. Most likely it is RAM problem, but I can't eliminate it is faulty CPU and M/B. Attach more minidumps here so I can find out which hardware component is faulty.
  8. Porphyria

    Porphyria TS Rookie

    I attatched more minidumps...however I switched to Windows 2000, I really hope that doesn't mess things up as far as you studying the mindumps, I wanted to see how it ran under something other than XP. These minidumps have all occured today running Win2000. Also, I took out the faulty memory chip (512MB). Didn't make a difference. Thanks for taking the time to check this out, it's the most help I've been able to get with this problem so far.
  9. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    It is hardware error. Re-install W2k does not resolve your problem. one of the W2K minidump is inaccessible. After studying your W2K minidump, I think it is bad ram.

    BugCheck 7F, {d, 0, 0, 0}
    Probably caused by : win32k.sys ( win32k!HmgDecrementShareReferenceCount+33
    f9caca14 804dd54a 0000007f 0000000d 00000000 nt!KeBugCheckEx+0x19
    f9caca14 bf87adf9 0000007f 0000000d 00000000 nt!KiSystemFatalException+0xe
    bc4034b0 00000001 00050285 00000000 e15ab618 win32k!HmgDecrementShareReferenceCount+0x33
  10. Porphyria

    Porphyria TS Rookie

    Is there anyway I can test this for sure? I tried MemTest before and it would always complete without errors...is there a better program? I just would like to know before I slowly replace everything until it works! (Might save some $$)! :) Thanks!
  11. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    There has no reliable tools to test the RAM and CPU. You must aware some faulty RAM can pass memtest. Try reseating the RAM and CPU. Clean up the dust inside the computer. If it doesn't work, replace the RAM.
  12. rtji1

    rtji1 TS Rookie


    My computer started giving me the BSOD message relating with ntfs.sys page fault in nonpage area recently.

    This is my mini dump, the BSOD usually appear randomly and during playing graphic intense game.
  13. cjohnsto

    cjohnsto TS Rookie

    Crash repeatable when plug in USB HD

    I recently formatted a USB HD to NTFS since then as soon as I plug it into my computer it causes similar crahses to what is being reported here. It doesn't crash at any other time and always crashes when I plug the drive in, windows crashes during start up if is is plugged in at the time.

    I have a feeling the ntfs partition is corrupted or something. However I can't reformat it or repartition it since I can't plug it in. My mother board does not support USB drives directly so I need windows. Suggestions?

    I've attached my minidumps to help you work out exactly what is happening.

    BTW how are you interpreting the .dmp files?

    Thanks for any help.

    Attached Files:

  14. Ben.Whitey

    Ben.Whitey TS Rookie


    I have a similar problem.

    I upgraded my ram from 512MB of PC2700 to 2x512 of PC3200 OCZ.

    Shortly after upgrading I have this error message:


    Stop: 0x00000050 (0xA2408055, 0X000000001, 0X867c3e19, 0x000000000)
  15. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    All of the minidumps crash with the same symptom. From the stack trace, XP tries to mount the NTFS volume and then XP crashes. Probably yours usb HD is corrupted.

    Invalid system memory was referenced. This cannot be protected by try-except,
    it must be protected by a Probe. Typically the address is just plain bad or it
    is pointing at freed memory.
    Arg1: f7f26000, memory referenced.
    Arg2: 00000001, value 0 = read operation, 1 = write operation.
    Arg3: f7638f4e, If non-zero, the instruction address which referenced the bad memory
    Arg4: 00000000, (reserved)

    Debugging Details:
    Could not read faulting driver name
    WRITE_ADDRESS: f7f26000

    f7638f4e 66ff02 inc word ptr [edx]

    BUGCHECK_STR: 0x50
    LAST_CONTROL_TRANSFER: from f7639023 to f7638f4e

    f7c62464 f7639023 00000400 f7f1a000 00000400 Ntfs!NtfsTransformUsaBlock+0x92
    f7c62654 f7638c97 f7c62664 86534008 0110070a Ntfs!NtfsCommonWrite+0x180c
    f7c627c8 804e37f7 85fac3c8 86534008 00000000 Ntfs!NtfsFsdWrite+0xf3
    f7c627d8 804eeadd f7c62814 f7c629b0 00000000 nt!IopfCallDriver+0x31
    f7c627ec 804ee6a6 85f19e09 f7c62814 f7c628a8 nt!IoSynchronousPageWrite+0xaf
    f7c628c8 804ee45d e302fc00 e302fc04 e302fc04 nt!MiFlushSectionInternal+0x38b
    f7c62904 804eed68 00000000 e302fc00 00000000 nt!MmFlushSection+0x1e0
    f7c6298c f768731a 00001000 00000000 00000000 nt!CcFlushCache+0x372
    f7c629c0 f7687a69 85f2aef0 85fac4a8 85f2aef0 Ntfs!UndoPass+0xc9
    f7c62a60 f7681004 85f2aef0 85fac4a8 f7c62c9f Ntfs!NtfsRestartVolume+0xe7
    f7c62cb8 f7680392 85f2aef0 85f01008 85f2aef0 Ntfs!NtfsMountVolume+0xcf7 <-- ??
    f7c62ccc f763e9a1 85f2aef0 85f01008 85f2aff0 Ntfs!NtfsCommonFileSystemControl+0x39
    f7c62d74 804e426b 85f2aef0 00000000 867c5640 Ntfs!NtfsFspDispatch+0x1ff
    f7c62dac 8057be15 85f2aef0 00000000 00000000 nt!ExpWorkerThread+0x100
    f7c62ddc 804fa4da 804e4196 00000000 00000000 nt!PspSystemThreadStartup+0x34
    00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16
  16. cjohnsto

    cjohnsto TS Rookie

    Yep, It was the USB drive, I reformatted it under linux and it was then fine.
  17. Razorback

    Razorback TS Rookie

    I know you are probably tired of looking at minidumps but I am still trying to determine what my problem. I have done a fresh install and have tried different ram. Tonight I received an IRQL BSOD. I am attaching the minidump. Nothing shows up in the event logger. If you don't mind, please take a look at it and see what you think. Thanks.
  18. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Hi Razorback,

    Refer my previous post, base upon my record, 50% is CPU% and 33.3% is RAM. You should replace CPU. However overheat may also cause system crash at IRQL x'1c'. Check the temperature of the CPU. BTW, do you use AMD CPU?

  19. Razorback

    Razorback TS Rookie

    Hey cpc2004,
    I am using a 3.2c P4. Had it for about a year. Temps in my bios show around 95 F which should be fine. I guess my last IRQL showed the same info. Besides the BSOD's which have been from PFN_LIST to PAGE_FAULT to KERNEL_APC_PENDING_DURING_EXIT, on boot I get the couldn't find or corrupt SYSTEM file black screen error. I can reset the mobo and reboot and get into the desktop after that. So you think it is the cpu? Bummer. :(
  20. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    This is hardware poblem. What do you mean you have to try all different ram? I guess you mean you reseat the RAM and the BSOD still occurs
  21. Razorback

    Razorback TS Rookie

    I borrowed another set of ram - 512 MB of PC4000 to see if my new ram was the problem. Just to recap, I replaced my ram a couple of months back. I went from 512 MB of OCZ PC4000 to 1 GB of OCZ PC3700. I wanted to rule out the new ram so I used the ram that borrowed from work.
  22. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    How often does your windows crash? Open the computer case. If your windows does not crash, it is overheat.
  23. hdragon689

    hdragon689 TS Rookie

    My problem

    Dear cpc2004,
    I just found this discussion thread today. I have
    experiencd the same problem for few months. The
    system automatically reboot randomly, few times a day.
    Can you also help me check my system? My minidumps
    files is uploaded to this place,
    Thank you very much .... :D

  24. Metamorphosis

    Metamorphosis TS Rookie

    dear cpc2004

    i have also been having trouble with the page fault and ntfs.sys error.
    problem is that i have allot of tests at my college, I have to learn JAVA and C++ so I don't really have the time to learn how to debug the minidump files, i know you got allot of work from everyone else here, but my computer is very unstable, and it's not helping me study well, so if you could please help me out, it would be greatly appreciated, but like I said, if it is too much work, no offense taken.
  25. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Hi Metamorphosis,

    Faulty RAM is the culprit. One minidump crashed at IRQL x'1c' which is clock level interrupt. It crashes only if hardware error. Bugcheck C5 is the symptom of bad ram.

    BugCheck A, {a8f5ab1c, 1c, 1, 804f7826}
    BugCheck C5, {80a6d5c8, 2, 0, 805395de}

    As your hardware problem does not occur very frequently. Reseat the memory stick to another memory or downclock the RAM may resolve the problem.

    If it still crashes, you have to diagnostic which memory stick is faulty.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...