ntfs.sys PAGE FAULT IN NONPAGE AREA bluescreen

By mgorbach ยท 145 replies
Jun 25, 2005
  1. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    Three of the minidumps are inaccessible and they are symptoms of the faulty ram. Do you try to use new memory sticks only? Report the problem to microsoft if it still crashes.
  2. metago

    metago TS Rookie

    Thank You.

    Thank You for all your help. I really do Appreciate it. I seem to have fixed the issue by downclocking the Cpu. Although this brings up another question. Is this a patch for another piece of hardware or even the cpu that may be going or is bad? Or is it simply poor design by either the cpu mfg or the mobo mfg? It doesn't seem like i should have to downclock my cpu to get stability but thats exactly what has happened.
  3. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    Your problem is relate to memory and it includes memory modules, Level 2 (L2) SRAM cache, or video adapter RAM. Over 90% of the problem is related to ram. For your case, it is hardware problem of L2 cache memory of your CPU. Do you downclock the ram and set the clock of CPU to original value?
  4. FourQ

    FourQ TS Rookie

    I think I have the same problem

    I'm getting BSOD constantly, sometimes when my is idle, but most of them when i'm playing games, even old ones, like SimCopter.
    I've attached my 8 latest minidumps.
    Help please!
  5. metago

    metago TS Rookie

    I have tried to downclock the ram and leave cpu as factory settings but that didnt do anything. Downclocking the cpu was a fix, so I guess that explains it then if the L2 cache is bad. I did still get a ntfs page error the other day even with it downclocked but it allows me to do more with the computer before it errors out if the cpu is downclocked. So not a total fix just a band-aid really. Sorry also btw i didnt see your question about the ram in the earlier post. Yes it was new ram out of the package and i was still having the same problems as i did with the old ram which was new also. Well I think its going to be like pulling teeth but ill try to get an rma for the cpu.
  6. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    The NTFS page error is also the symptom of the faulty CPU. You had better run chkdsk /r to make sure that all the folders are healthy.
  7. metago

    metago TS Rookie

    I have the same exact cpu in a computer at work, ill try it in this one and see how it works. Thanks..
  8. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Hi FourQ,

    Your problem is a different case. The culprit is faulty video display card. Do you overclock the display card?

    1. Make sure that the CPU is not overheat (ie CPU < 60C)
    2. Reseat video card and clean up the dust inside the computer case
    3. Downclock the video card
    4. Swap the video card if possible to confirm it is video card problem

    Worst case
    Replace the video card
  9. loopy00

    loopy00 TS Rookie

    Hi cpc, I am also having this problem.
    Could you take a look at my minidumps for me?
  10. loopy00

    loopy00 TS Rookie

    Sorry, didn't mention this before, I have swapped the RAM with no success and i also dual boot this machine with XP64 Pro with no problems. Any help would be appreciated.
  11. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    The culprit maybe ZoneAlarm. Do you install the same version of ZoneAlarm at XP64?
  12. metago

    metago TS Rookie

    Thank You Cpc2004,
    You sent me in the right direction. What i found out is that AMD 3000+ Barton core processors have this inherant problem. Its a simple fix in the cmos. You downclock the FSB by 1 and it resolves the issue. I took mine from 166 to 165 and the issue is gone and with very little lost Cpu speed. Just an fyi for the future.
  13. rekrdskratcher

    rekrdskratcher TS Rookie

    hey cpc2004,

    it looks like you're the guy around here, so if you wouldn't mind, i'm having many of the same symptoms as everyone else - BSOD with either ntfs.sys errors or irql_not_less_or_equal errors - and i think i'm narrowing it down to faulty ram, but i thought i'd leave that up to you. i've attached my minidump zips.
  14. Chicken Boy

    Chicken Boy TS Rookie

    I have the same problem and I think it's the ram but it's 6 months old. I use win 2000 and I will attach last 6 minidump and can someone look what is wrong.

  15. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    4 of your minidumps crash at sr.sys, which is the filter driver for system restore.

    2 of your minidumps crash with memory corruption.

    Ram is the most likely culprit here, but you may also have a corrupt windows installation.

    Take out your ram stick`s and clean the contacts with an eraser. Blow away the remnants and replace. Try running with just one ram stick.

    Test you ram using the Memtest86+ programme from www.memtest.org.

    Let the programme run for at least seven passes. If you don`t have a floppy drive, there is a pre-built iso version that you can burn to cd, and then boot from that.

    Please note. Some faulty ram can pass memtest. If memtest finds errors, then you have faulty ram.

    If that doesn`t work, try replacing the ram.

    You might also want to consider running a Windows repair, as per this thread HERE

    Regards Howard :wave: :wave:
  16. rekrdskratcher

    rekrdskratcher TS Rookie

    hey howard...

    i have memtest running right now on my box... it's passed 4 times so far with no errors, i'll keep running it overnight and see what happens.

    the XP install is fresh, so i'd be surprised if it was corrupted... of course, in the world of computing, is anything surprising?

    i've had problems of this nature in the past with this machine, when running win2k- i replaced the HDD, which WAS actually going bad. one of the things i had done before then was run memtest to see if it was ram (it passed at least 7 times, if i recall correctly). so i replaced that HDD (an IDE) with an SATA system... and got XP working, at least for a couple days. then i started encountering these errors (the ntfs.sys, irql_not_less_or_equal, etc.) which of course XP's online crash analysis said was a driver problem... but updating drivers didn't seem to help anything, nor did removing possibly offending hardware.

    here's the rundown on my system, if anyone can see any conflicts

    -Athlon XP 2800+ (i'm assuming barton core) w/ included heatsink
    -ABIT KV7-V motherboard
    -1 GB Corsair Valueselect DDR Dual-Channel (2x512 MB)
    -120 GB Samsung HDD/80 GB Seagate HDD (both SATA, not running a RAID currently; had it on RAID 1 on first XP install)
    -Visiontek ATI Radeon 9250 AGP (128 MB)
    -M-Audio Delta 24/96 PCI soundcard (currently not installed, was installed during original XP install)
    -Dynex 52X CD-ROM
    -Dynex DVD-ROM/CD-RW
    -Cannibalized Floppy Drive from a different machine

    i'll post again with the memtest results later.
  17. Chicken Boy

    Chicken Boy TS Rookie

    I run mamatest over the night and it passed all 10 tests. I don't know what is wrong so I will attach some minidump files and if someone can have some time that he could look what is wrong.
  18. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Hi Chicken Boy,

    Your windows is W2K and microsoft does not have symbolic file of your W2K version. I cannot format the stack trace of your minidumps and it is difficult to diagnostic your problem.

    8 minidumps crash with bugcheck 24, 1 with 0A, 1 with 1E and 1 with 7F. The culprit is hardware as your windows encounter illegal instruction and general protection fault. They are symptom of hardware error. Probably it is faulty motherboard or ram but I am not sure. You had better report the problem to microsoft and complain that microsoft does not provide the W2K symbolic file for problem diagnostic.

    BugCheck A, {15, 2, 0, 8043231a}
    BugCheck 1E, {c000001d, 8048e94e, bbbf9000, bbbf8d64}
    Illegal Instruction
    BugCheck 7F, {d, 0, 0, 0}
    General Protection fault

    Try chkdsk /r at command prompt. Maybe some folders have bad blocks.
  19. Chicken Boy

    Chicken Boy TS Rookie

    Thank you for taking time and looking my problem. If I have win XP I have more problems when I have win 2000 so I will stay on win 2000 until I find what is the problem. I have some old disk 10GB in my machine and I will remove that disk and see what will happend.
  20. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Hi Chicken Boy,

    Install W2K3 and it is more stable.
  21. Chicken Boy

    Chicken Boy TS Rookie

    I had w2k3 but I have sister who likes to play games sow I must have 2000. When I will buy new computer this one will have sister.
  22. rekrdskratcher

    rekrdskratcher TS Rookie

    hokay folks... (especialy howard)

    memtest passed my ram 9 times with no errors. i tried the XP repair install... and right after i got to the desktop, we had our good friend BSOD!!! yarrhhh!! interesting thing is, TWICE after it crashed, windows online crash analysis asked for me to send a kernel dump for more information... hmmm...

    i've seen posts in other forums where the power supply might have been the problem... not in this case. (har har... case... never mind.) i DID have a generic 600w (which came with my 40 dollar e-bay case) so it probably was not that high class, but i've got an antec 500w supply in there and i can't tell the difference... it's a little quieter, maybe.

    i posted this earlier, but i'll post it again so you all can see what i've got, and see if there's any conflicts...

    -Athlon XP 2800+ (i'm assuming barton core) w/ included heatsink
    -ABIT KV7-V motherboard (via kt600 chipset)
    -1 GB Corsair Valueselect DDR Dual-Channel (2x512 MB)
    -120 GB Samsung HDD/80 GB Seagate HDD (both SATA, not running a RAID currently; had it on RAID 1 on first XP install)
    -Visiontek ATI Radeon 9250 AGP (128 MB)
    -M-Audio Delta 24/96 PCI soundcard (currently not installed, was installed during original XP install)
    -Dynex 52X CD-ROM
    -Dynex DVD-ROM/CD-RW
    -Cannibalized Floppy Drive from a different machine
    -Antec Neo HE 500W power supply

    not working... this is sucky... i'm attaching more minidumps...
  23. illusionxt

    illusionxt TS Rookie

    Hi, basically ive been getting the NTFS.sys Blue screens, i woudl include minidumps with this post, but i haven't even been able to complete the Windows Setup after isntallation, it can be installing the components for windows and then it just suddnely crashes and gives me the blue screen. most of the time is shows "Ntfs.sys", not sure if this will help but i copied some of the numbers and stuff down from one of the many crashes.

    -------Crash #1-------

    The problem seems to be caused by the following file: Ntfs.sys


    (writing, warning etc)

    STOP: 0x00000050 (0xFF676B8C, 0x00000000, 0xF83650FB, 0x00000000) at F8360000, Datestamp 41107eea


    notsure if that'll help but yea.. can't relayl access C:\windows\minidump when i haven't even finished the installation for windows. Personally i tihnk it might be a corrupted hard drive, due to the fact that i can't see the second partition of my Seagate 80gb, i only see 33gbs of it when it's totla is 80... i've tried to use the Seagate HD Bootdiskettes to format the drive but hasn't relaly worked.. its just able to only see 33.8gbs

    Ty for the help if possible~
  24. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Your latest batch of minidumps crash with memory corruption, and sr.sys.

    Since you have done a Windows repair, you can rule out software as the cause. This is deffinitely a hardware problem.

    Some faulty ram can pass memtest.

    I urge you to try a new stick of ram. If that doesn`t work then maybe it`s your cpu L2 cache ram that`s bad.

    Regards Howard :)
  25. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Hi rekrdskratcher,

    Howard's finding is correct. Some faulty ram can pass memtest. It is worthwhile to reseat the memory stick and cleanup the dust inside your Windows

    Additional Suggestion
    1. Some minidumps crashes at IRQL 1 which is related to paging. Maybe your paging space is bad or software error at Windows. I have to some research at MicroSoft Web
    An attempt was made to access a pageable (or completely invalid) address at an
    interrupt request level (IRQL) that is too high. This is usually
    caused by drivers using improper addresses.
    If a kernel debugger is available get the stack backtrace.
    Arg1: ffbdf110, memory referenced
    Arg2: 00000001, IRQL
    Arg3: 00000000, value 0 = read operation, 1 = write operation
    Arg4: 80505390, address which referenced memory

    2. Some minidumps crashes after filtering
    Microsoft Product Support's Reporting Tools
    Run the SetupPerf one and look for the output from FltrFind.exe. Maybe some drivers are corrupted.
    3. Upgrade your windows to latest patches.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...