1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Onboard sound but 'No Audio Device' in device properties

By DacorDave · 26 replies
Jul 6, 2010
  1. I am on son's Clevo laptop and they tell me they have not had sound for a very long time.

    I check, download and install latest drivers from the Clevo website, but still no sound.

    I have deleted all device drivers and allowed Windows to rediscover the drivers again - everything went well but found a PCI device that could not find drivers for so put the yellow Exclamation Mark - but still no Audio Device.

    I checked the BIOS, there is no option to turn on/off the sound so I presume audio is turned on as everything is integrated, but still the Sounds and Audio Device Properties says that there are No Audio Devices. So either the device is faulty or there is some other way of being able to get the computer to recognise the Audio Devices.

    If there is any suggestion(s) it would be greatly appreciated.

  2. raybay

    raybay TS Evangelist Posts: 6,908   +10

    Sometimes kids overdrive the audio chips until they overheat and burn out. If burned out, it will not detect.
    Might be time to disable the onboard sound and install an external sound card and software.
  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Let's try to get some more info
    • Make sure all your devices are connected and powered on
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post

    Generate and attach a DirectX report
    • click Start->Run, enter dxdiag
    • Notice progress in lower left window corner
    • When done, click Save Information button and save to your Desktop
    • In TechSpot, use the paper clip icon to attach the report. (If you don't see icon you may need to first click Go Advanced)
  4. DacorDave

    DacorDave TS Rookie Topic Starter

    Thanks LookinAround...

    I ran msinfo32 as suggested... nothing appeared in the Problem Devices area, (incidently, nothing appeared in the Sound Device area either).

    Here is the DirectX report for the laptop.
    View attachment DxDiag.txt

    Many thanx for any help you can offer.

  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Hmmm.. Let's try the following

    • Look in Device Manager. I'm going to guess you no longer see any devices with Yellow Icons? yes? no?
    • Let me know above question, but regardless, i want you to look under Device Manager System Devices for Microsoft UAA Bus Driver for High Definition Audio. Rt click it, select uninstall to uninstall it. Then reboot your machine
    • Now check your sound again. If still a problem, try running the two reports again as you did before
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Excuse the double post, but to clarify:

    After you uninstall the UAA Bus Driver and reboot.. give the machine several minutes to finish startup to Windows desktop as i expect you will see some little pop-ups in lower right of your screen telling you drivers are being reinstalled.

    > I expect you to see a pop-up msg first about UAA Bus Driver getting re-installed
    > and then (with a bit-of-luck) after its reinstalled you should also see pop-ups about other Hi Def audio devices being installed as well;

    In any case, let's see what happens
  7. sigh22

    sigh22 TS Rookie

    Similar Issues

    I have an older emachines comp and am having similar problems. My computer cannot dectect an audo device.

    I follwed the instructions LookinAround posted and have found a PCI device that apparently has no drivers, I do have a device/driver search engine installed on my machine and it tells me that all drivers are installed.

    in regards to the list when msinfo32 is typed into run i get the following under problem devices;

    PCI Device PCI\VEN_8086&DEV_2668&SUBSYS_4037107B&REV_03\3&11583659&0&D8 The drivers for this device are not installed.

    I have tried searhing for the drivers but with no success.

    Is there any help anyone can offer.

    Kind Regards,

  8. raybay

    raybay TS Evangelist Posts: 6,908   +10

    Of course you have the audio device if you have a sound port from the motherboard pointing out the back of your computer.

    Give us the brand and model of the computer, brand and model number of motherboard, or the model numbers off the motherboard, and the numbers off the chips on it... and we can help you look it up.

    Or use Belarc Advisor, Everest, CPUID, CPU-Z, ClearApps, WMIAudit, PXServer, SystemHound, or other free hardware inventory program to produce a screen printout of your system configuration.
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Hi Sigh22

    1) Tell us the make and model of your computer (emachine you said?) and what version Windows and SP level is installed
    2) However.... my guess just based on the PCI device you listed above, I'm going to guess part of your problem is you are running XP SP2 or earlier???? You're missing a Microsoft driver that can be manually added to XP SP2 but IMHO, you're best to upgrade to SP3
    > The driver you need comes already packaged in XP SP3 plus
    > MS has stopped support for XP SP2 so is good to upgrade in any case

    Do backup all your stuff (or better yet - create a hard drive image clone backup) first. SP3 upgrades are smooth 99% of the time... but your own mileage may vary :)
  10. sigh22

    sigh22 TS Rookie

    thanks for all the help so far,

    didnt realise i was runnin on SP2, i am now on SP3. i have downloaded the PCI driver but i still have no sound, i tried downloading the k-lite codec pack, but still no success, any futher help or advice?

    thanks again,
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    Try running the msinfo32 Problem Report again. Let's see if the same PCI device appears or not.

    Now that you have the driver installed for it, i would guess it should have disappeared and, in its place, you might now see some HDAUDIO hardware IDs. In any case, try running it again and post the result. If you ARE seeing HDAUDIO IDs, it means you now need to download and reinstall the audio drivers for your computer.

    (fyi. for anyone who might come across this thread.. High Definition audio device chips/chipsets, by definition, must connect to an audio bus controller. If the audio bus controller driver is missing or not working, as was in this case, Windows can't "see" the Hi Def devices which connect to it until the audio bus controller and its driver are both working.

    /* edit */
    Note: This only applies to the current Hi Def audio standard. This is NOT true for older AC97. Audio bus controllers didn't exist for the old AC97 sound standard
  12. sigh22

    sigh22 TS Rookie

    Still no joy....

    the PCI has gone from the msinfo as you expected, but no HD audio has com in its place, in the system informantion it now says i have 2 audio devices;

    1) Realtek High Definition Audio
    2) Unimodem Half-Duplex Audio Device

    Both status say "ok"
    I reinstalled the drivers but to no avail.

    Something i thought would be worth mentioning that when i try to run a video the fault that comes up is;

    K:\Movies\Against the Dark.avi::Audio 1
    MPEG-1 Audio Decoder::Out
    Audio Switcher::Out

    Media Type 0:
    Audio: PCM 48000Hz stereo 1536Kbps

    majortype: MEDIATYPE_Audio {73647561-0000-0010-8000-00AA00389B71}
    subtype: MEDIASUBTYPE_PCM {00000001-0000-0010-8000-00AA00389B71}
    formattype: FORMAT_WaveFormatEx {05589F81-C356-11CE-BF01-00AA0055595A}
    bFixedSizeSamples: 1
    bTemporalCompression: 0
    lSampleSize: 1
    cbFormat: 18

    wFormatTag: 0x0001
    nChannels: 2
    nSamplesPerSec: 48000
    nAvgBytesPerSec: 192000
    nBlockAlign: 4
    wBitsPerSample: 16
    cbSize: 0 (extra bytes)

    0000: 01 00 02 00 80 bb 00 00 00 ee 02 00 04 00 10 00 ....€»...î......
    0010: 00 00

    thanks again ..
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    So, to double check, you're saying nothing currently appears when you run Problem Device Report, right?
    Sounds like the drivers are installed OK now so maybe something else must be now interfering

    Also, i'm not really familiar with how to interpret your movie player error message so i'm going to stick to trying to figure out if/why your basic Windows sounds audio are or aren't first working

    And am glad to try and help :)

    1) Could you tell me the make/model of your computer?
    2) Per above, you're saying no Problem Devices are currently reported, right?
    3) Click Control Panel->Sound
    > On the audio tab, make sure the default playback is set to your Realtek Hi Def audio
    > On the sounds tab, can you select a system sound (like Asterisk), can you click the Play button (the triangular button you'll see towards bottom of window). Do you hear any sound? (Also, to double check, you've checked and mute isn't checked?)
    4) Are you relying on internal speakers? Are you plugging in speakers?

    If still problems, Generate and attach a DirectX report
    • click Start->Run, enter dxdiag
    • Notice progress in lower left window corner
    • When done, click Save Information button and save to your Desktop
    • In TechSpot, use the paper clip icon to attach the report. (If you don't see icon you may need to first click Go Advanced)
  14. sigh22

    sigh22 TS Rookie

    1) My computer is an emachines 8230

    2) within msinfo there are no problem devices.

    3) I tried to play a sound with no success, i did however notice that there is still no sound device detected/selected. the HD audio device is listed in the componants (in the hardware tab) but it is not selected as the default device. When i tried to change the default device the only option is a device listed is "Modem #0 Line Playback", do you have any idea how i can search for new devices in the audio tab?

    4) I use external speakers for my machine

    I have attached the dxdiag report


    Attached Files:

  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +185

    When all the hardware/software audio things are working (audio drivers, hardware OK, Windows services, etc) THEN you should see and be able to choose Realtek as an audio playback option. So, is still proof somethings wrong

    Next puzzle: you earlier said
    Based on that, i'd expect to see Realtek High Definition Audio in your DxDiag as well but it's not. Your DxDiag report only shows the modem (which is consistent with you only seeing the modem in audio playback pulldown tab)

    Let's look for Realtek in msinfo32 again. Where did you see Realtek listed before and do you STILL see it listed?? Or has it disappeared? In msinfo32, look under Components->Sound Device also Modem and copy/paste the info you see in those categories
    Do you see still see Realtek somewhere?

    Let's also look in Device Manager, In DevMgr, click View->Devices by Connection. (see my example below) Expand ACPI categories and the PCI bus.
    > Look for the Microsoft UAA Bus Driver for Hi Def Audio (this was the PCI Problem device we fixed earlier by upgrading to SP3)
    > When you expand it, you should see your Realtek connected to it (In my own example, you'll see I have Soundmax)
    > Is Realtek there? Rt click Properties. On the General tab, is its status still = OK?

    If Realtek has disappeared, check your BIOS settings. Check for something like an Onboard Audio setting. Is it set to Enable????

    In my own example, look for my audio bus controller and Hi Def sound card listed towards the bottom of the window

    /* edit */
    And if Realtek HAS disappeared from msinfo32, check Problem Device Reports to see if anything is appearing there now
  16. pinewaves

    pinewaves TS Rookie

    try pluggingin in an audio device and see if he system recognises it...it may be plugg and play
  17. pinewaves

    pinewaves TS Rookie

  18. pinewaves

    pinewaves TS Rookie

  19. pinewaves

    pinewaves TS Rookie

  20. pinewaves

    pinewaves TS Rookie

  21. pinewaves

    pinewaves TS Rookie

    dont mind what im doing jes want to achieve the minimum ten posts to send a visitor message t someone thanks fro understanding
  22. pinewaves

    pinewaves TS Rookie

  23. pinewaves

    pinewaves TS Rookie

  24. sigh22

    sigh22 TS Rookie

  25. sigh22

    sigh22 TS Rookie

    thanks pinwaves but its a no go, i have tried that already.


    I looked at the ststem information first. I have copied the info in for you to see;

    Name Realtek High Definition Audio
    Manufacturer Realtek
    Status OK
    PNP Device ID HDAUDIO\FUNC_01&VEN_10EC&DEV_0880&SUBSYS_08600000&REV_0900\4&1B8287CF&0&0201
    Driver c:\windows\system32\drivers\rtkhdaud.sys ( built by: WinDDK, 5.81 MB (6,088,296 bytes), 7/26/2010 11:06 PM)

    Name Microsoft LifeCam VX-2000.
    Manufacturer Microsoft
    Status OK
    PNP Device ID USB\VID_045E&PID_0761&MI_02\6&1667B811&0&0002
    Driver c:\windows\system32\drivers\usbaudio.sys (5.1.2600.5512 (xpsp.080413-2108), 58.63 KB (60,032 bytes), 7/25/2010 4:23 PM)

    Name Unimodem Half-Duplex Audio Device
    Manufacturer Microsoft
    Status OK
    PNP Device ID MODEMWAVE\0\{9B03D699-1B78-4090-90ED-2AD73934EA1C}
    Driver c:\windows\system32\drivers\modemcsa.sys (5.1.2600.0 (xpclient.010817-1148), 15.75 KB (16,128 bytes), 7/25/2010 4:24 PM)

    Realtek is there with ad there are no further additions in the problem devices list.

    here is the info under modem;

    Name Smart Link 56K Voice Modem
    Description Smart Link 56K Voice Modem
    Device ID PCI\VEN_163C&DEV_3052&SUBSYS_000514FE&REV_04\4&23C0B1C&0&08F0
    Device Type Internal Modem
    Attached To COM3
    Answer Mode Not Available
    PNP Device ID PCI\VEN_163C&DEV_3052&SUBSYS_000514FE&REV_04\4&23C0B1C&0&08F0
    Provider Name Microsoft
    Modem INF Path mdmhamrw.inf
    Modem INF Section Modem1
    Blind Off X4
    Blind On X3
    Compression Off %C0
    Compression On %C3
    Error Control Forced \N2
    Error Control Off \N0
    Error Control On \N3
    Flow Control Hard &H1
    Flow Control Off &H0
    Flow Control Soft Not Available
    Default <
    Inactivity Timeout 0
    Modulation Bell Not Available
    Modulation CCITT B0
    Prefix AT
    Pulse P
    Reset ATZ<cr>
    Responses Key Name Smart Link 56K Voice Modem::Smart Link (www.smlink.com)::Microsoft
    Speaker Mode Dial M1
    Speaker Mode Off M0
    Speaker Mode On M2
    Speaker Mode Setup M3
    Speaker Volume High L3
    Speaker Volume Low L1
    Speaker Volume Med L2
    String Format Not Available
    Terminator <cr>
    Tone T
    Memory Address 0xDFEFF000-0xDFEFFFFF
    I/O Port 0x0000B800-0x0000B8FF
    IRQ Channel IRQ 22

    with reagrds to the device manager, the realtek is showing under the MS UAA Bus Driver for HDA, when i look at the properties it says that the device is working properly.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...